Use getpassphrase() on SunOS to allow passwords longer than 8 chars.
This commit is contained in:
parent
01e319b6f3
commit
ceb9888a9a
2 changed files with 17 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.40 2011/03/12 15:42:22 adam Exp $
|
||||
$NetBSD: distinfo,v 1.41 2011/12/09 13:51:56 hans Exp $
|
||||
|
||||
SHA1 (unrarsrc-4.0.7.tar.gz) = e4c8b0d47278475f3dfb77e8497f5818eca3d4a0
|
||||
RMD160 (unrarsrc-4.0.7.tar.gz) = 0629f8600e9ddb298f59fc05b9569bd40703acaf
|
||||
Size (unrarsrc-4.0.7.tar.gz) = 152853 bytes
|
||||
SHA1 (patch-ac) = ca8bcbc1ce6723a2cd576067c6fbd171abb0c711
|
||||
SHA1 (patch-consio.cpp) = 341dd714b165fabf3dec0213b9bb3e57dcc146f5
|
||||
|
|
15
archivers/unrar/patches/patch-consio.cpp
Normal file
15
archivers/unrar/patches/patch-consio.cpp
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-consio.cpp,v 1.1 2011/12/09 13:51:56 hans Exp $
|
||||
|
||||
Use getpassphrase(3C) on SunOS to allow passwords longer than 8 chars.
|
||||
|
||||
--- consio.cpp.orig 2011-03-02 08:43:12.000000000 +0100
|
||||
+++ consio.cpp 2011-12-09 14:38:05.903683508 +0100
|
||||
@@ -129,6 +129,8 @@ void GetPasswordText(wchar *Str,uint Max
|
||||
char StrA[MAXPASSWORD];
|
||||
#if defined(_EMX) || defined(_BEOS) || defined(__sparc) || defined(sparc) || defined (__VMS)
|
||||
fgets(StrA,ASIZE(StrA)-1,stdin);
|
||||
+#elif defined(__sun)
|
||||
+ strncpyz(StrA,getpassphrase(""),ASIZE(StrA));
|
||||
#else
|
||||
strncpyz(StrA,getpass(""),ASIZE(StrA));
|
||||
#endif
|
Loading…
Reference in a new issue