Import RPostgreSQL v0.3-2.

Database interface and PostgreSQL driver for R.  This package provides
a Database Interface (DBI) compliant driver for R to access PostgreSQL
database systems.  A wiki and issue tracking system for the package
are available at Google Code at https://code.google.com/p/rpostgresql/.
This commit is contained in:
brook 2012-04-15 17:57:36 +00:00
parent 66ce0fe5d2
commit cec2ba7b01
5 changed files with 64 additions and 0 deletions

4
math/R-RPostgreSQL/DESCR Normal file
View file

@ -0,0 +1,4 @@
Database interface and PostgreSQL driver for R. This package provides
a Database Interface (DBI) compliant driver for R to access PostgreSQL
database systems. A wiki and issue tracking system for the package
are available at Google Code at https://code.google.com/p/rpostgresql/.

View file

@ -0,0 +1,23 @@
# $NetBSD: Makefile,v 1.1.1.1 2012/04/15 17:57:36 brook Exp $
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_R_CRAN:=contrib/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= ${R_HOMEPAGE_BASE}/RPostgreSQL/
COMMENT= R interface to the PostgreSQL database system
LICENSE= gnu-gpl-v2 AND postgresql-license
R_PKGNAME= RPostgreSQL
R_PKGVER= 0.3-2
DEPENDS+= R-DBI>=0.2.5:../../math/R-DBI
USE_TOOLS+= sh
REPLACE_SH+= ${WRKSRC}/inst/devTests/copyTest.sh
CHECK_INTERPRETER_SKIP= lib/R/library/RPostgreSQL/devTests/*
.include "../../math/R/Makefile.extension"
.include "../../mk/pgsql.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2012/04/15 17:57:36 brook Exp $
SHA1 (R/RPostgreSQL_0.3-2.tar.gz) = cffa6237894727008d7079e24ab3a561ae139816
RMD160 (R/RPostgreSQL_0.3-2.tar.gz) = 4c53b8183716455100883545465d3437e2ef17f9
Size (R/RPostgreSQL_0.3-2.tar.gz) = 470695 bytes
SHA1 (patch-configure) = a1aa7d41ee22ff965dd5634e3024386b1ca6e413
SHA1 (patch-configure.in) = a50d4d43da4c73020de86d06a3eb45a7944b8659

View file

@ -0,0 +1,15 @@
$NetBSD: patch-configure,v 1.1.1.1 2012/04/15 17:57:36 brook Exp $
# see http://code.google.com/p/rpostgresql/issues/detail?id=39
--- configure.orig 2011-12-31 13:11:52.000000000 +0000
+++ configure
@@ -3008,7 +3008,7 @@ as_val=`eval 'as_val=${'$as_ac_File'}
ENABLE_LIBPQ=
-if test $R_OS_TYPE == "darwin" ; then
+if test $R_OS_TYPE = "darwin" ; then
ENABLE_LIBPQ='
PKG_CPPFLAGS=-Ilibpq

View file

@ -0,0 +1,15 @@
$NetBSD: patch-configure.in,v 1.1.1.1 2012/04/15 17:57:36 brook Exp $
# see http://code.google.com/p/rpostgresql/issues/detail?id=39
--- configure.in.orig 2011-12-31 13:11:52.000000000 +0000
+++ configure.in
@@ -115,7 +115,7 @@ AC_SUBST(PKG_CPPFLAGS)
AC_SUBST(PKG_LIBS)
ENABLE_LIBPQ=
-if test $R_OS_TYPE == "darwin" ; then
+if test $R_OS_TYPE = "darwin" ; then
ENABLE_LIBPQ='
PKG_CPPFLAGS=-Ilibpq