textproc/libxslt [1.22 -> 1.2.23]

one nominal change in pkgsrc:

- MASTER_SITES+=${MASTER_SITE_GNOME} is commented out. They evidently
  have not placed this product on their shelves yet.

  changes since prior release
  ---------------------------

    * python/generator.py: fix an infinite loop bug

    * libxslt/xsltutils.c: avoid a scary realloc() loop should fix
      #520383

    * libexslt/date.c: applied patch from Peter Pawlowski  fixing
      a timezone offset problem, fixes #521680
    * libxslt/namespaces.c: a bit of space/tabs cleanup

    * doc/xsltproc.xml doc/xsltproc.1 doc/xsltproc.html: small fix to
      man page synopsis, should fix #525822

    * libexslt/functions.c: fixed minor error reported on the mailing
      list by Mark Howe, which caused a segfault if func:result was
      postitioned as top-level element.

    * doc/xsltproc.xml doc/xsltproc.1: fix maxdepth default value
      documentation fixes #519921.

    * libxslt/extensions.c: fixed minor error bug #516483

    * libxslt/xslt.c: applied documentation patch from Jason Viers
      for xsltParseStylesheetDoc

    * doc/xslt.html doc/docbook.html: fix links for Cygwin DocBook
      setup as suggested by Philippe Bourcier

    * libxslt/keys.c, libxslt/pattern.c, libxslt/xsltInternals.h:
      fixed a problem on superfluous re-generation of keys reported
      on the mailing list by Josef Urban.

    * configure.in: avoid a problem in configure if an old gcrypt
      version is installed, patch from Brent Cowgill, fixes #500390

    * libexslt/common.c, libexslt/dynamic.c: After discussion on
      Bugzilla with Peter Pawlowski, added same code for preventing
      deletion of function result during garbage collection (see
      bug #495995).

    * libexslt/strings.c: Added code to mark the results of
      str:tokenize and str:split as "function result" to avoid
      garbage-collecting them during global variable initialisation.
      Should fix bug #495995.

    * python/libxslt.c: changed iterator argument for Py_Dict_Next
      from int to ssize_t (seems Python docs are incorrect) to fix
      x86_64 bug #489854.

    * python/libxslt.c: applied patch from Daniel Gryniewicz to
      fix a segfault caused by a parameter array not being preset
      to zero.
This commit is contained in:
bjs 2008-04-18 20:43:55 +00:00
parent 2473d77380
commit cef39c3e0b
3 changed files with 20 additions and 20 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.79 2008/03/11 17:56:16 tnn Exp $
# $NetBSD: Makefile,v 1.80 2008/04/18 20:43:55 bjs Exp $
DISTNAME= libxslt-1.1.22
DISTNAME= libxslt-1.1.23
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/libxslt/1.1/} \
ftp://xmlsoft.org/libxslt/
MASTER_SITES+= ftp://xmlsoft.org/libxslt/
#MASTER_SITES= ${MASTER_SITE_GNOME:=sources/libxslt/1.1/}
MAINTAINER= recht@NetBSD.org
HOMEPAGE= http://xmlsoft.org/XSLT/

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.47 2007/08/29 23:26:45 wiz Exp $
$NetBSD: distinfo,v 1.48 2008/04/18 20:43:55 bjs Exp $
SHA1 (libxslt-1.1.22.tar.gz) = 55ce4dc659681d9a5ba2322c45cbdfe75b46639c
RMD160 (libxslt-1.1.22.tar.gz) = bc2d32a4d7fea777c3d4b0ce3f5a70c8ea3f8969
Size (libxslt-1.1.22.tar.gz) = 2783003 bytes
SHA1 (patch-aa) = 6f750027b7f42b519f2211b33f90f49457933257
SHA1 (libxslt-1.1.23.tar.gz) = 9b6bb279808893643d9116e514eafecb22eff76c
RMD160 (libxslt-1.1.23.tar.gz) = fcecbaddd9b35e4d5e44670f6bd6d9d5fff327bc
Size (libxslt-1.1.23.tar.gz) = 2791463 bytes
SHA1 (patch-aa) = 7351945ab86addef9b5a69be887252fc0b3c1aa5
SHA1 (patch-ae) = ea154e23704cbd73e3199271e2d0d4a80b2832e8

View file

@ -1,9 +1,9 @@
$NetBSD: patch-aa,v 1.18 2007/08/29 23:26:45 wiz Exp $
$NetBSD: patch-aa,v 1.19 2008/04/18 20:43:55 bjs Exp $
--- doc/Makefile.in.orig 2007-08-23 11:22:57.000000000 -0400
--- doc/Makefile.in.orig 2008-04-08 13:18:24.000000000 -0400
+++ doc/Makefile.in
@@ -211,7 +211,7 @@ sysconfdir = @sysconfdir@
target_alias = @target_alias@
@@ -210,7 +210,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
# The name of the module.
-DOC_MODULE = libxslt-$(VERSION)
@ -11,7 +11,7 @@ $NetBSD: patch-aa,v 1.18 2007/08/29 23:26:45 wiz Exp $
# The top-level SGML file.
DOC_MAIN_XML_FILE = libxslt.xml
@@ -221,7 +221,7 @@ DOC_SOURCE_DIR = ..
@@ -220,7 +220,7 @@ DOC_SOURCE_DIR = ..
# A file in win32 depends upon two of the doc files
WIN32_DIR = $(top_srcdir)/win32
@ -20,7 +20,7 @@ $NetBSD: patch-aa,v 1.18 2007/08/29 23:26:45 wiz Exp $
PAGES = API.html bugs.html contribs.html FAQ.html docs.html \
downloads.html help.html index.html intro.html news.html \
xsltproc.html xsltproc2.html
@@ -494,9 +494,9 @@ $(PAGES): xslt.html $(srcdir)/site.xsl
@@ -498,9 +498,9 @@ $(PAGES): xslt.html $(srcdir)/site.xsl
$(EPAGES): EXSLT/exslt.html $(srcdir)/site.xsl
-@(if [ ! -d EXSLT/html ] ; then \
mkdir -p EXSLT/html ; fi )
@ -32,7 +32,7 @@ $NetBSD: patch-aa,v 1.18 2007/08/29 23:26:45 wiz Exp $
--stringparam dirname EXSLT/ \
--stringparam libname libexslt \
--stringparam logo_base ../ \
@@ -507,20 +507,20 @@ $(EPAGES): EXSLT/exslt.html $(srcdir)/si
@@ -511,20 +511,20 @@ $(EPAGES): EXSLT/exslt.html $(srcdir)/si
$(bindir)/xmllint --nonet --valid --noout $(EPAGES) ; fi );
../NEWS: $(srcdir)/news.xsl news.html
@ -59,7 +59,7 @@ $NetBSD: patch-aa,v 1.18 2007/08/29 23:26:45 wiz Exp $
$(srcdir)/api.xsl \
xslt.html ; fi );
-@(if [ -x $(bindir)/xmllint ] ; then \
@@ -528,9 +528,9 @@ $(APIPAGES): libxslt-refs.xml site.xsl a
@@ -532,9 +532,9 @@ $(APIPAGES): libxslt-refs.xml site.xsl a
$(bindir)/xmllint --nonet --valid --noout API*.html; fi );
$(EAPIPAGES): EXSLT/libexslt-refs.xml site.xsl api.xsl
@ -71,7 +71,7 @@ $NetBSD: patch-aa,v 1.18 2007/08/29 23:26:45 wiz Exp $
--stringparam libname libexslt \
--stringparam dirname EXSLT/ \
--stringparam logo_base ../ \
@@ -538,9 +538,9 @@ $(EAPIPAGES): EXSLT/libexslt-refs.xml si
@@ -542,9 +542,9 @@ $(EAPIPAGES): EXSLT/libexslt-refs.xml si
EXSLT/exslt.html ; fi );
html/index.html: libxslt-api.xml $(srcdir)/newapi.xsl
@ -83,7 +83,7 @@ $NetBSD: patch-aa,v 1.18 2007/08/29 23:26:45 wiz Exp $
$(srcdir)/newapi.xsl libxslt-api.xml ; fi );
-@(if [ -x $(bindir)/xmllint ] ; then \
echo "Validating the resulting XHTML pages" ; \
@@ -553,9 +553,9 @@ wiki: libxslt-api.xml $(srcdir)/wiki.xsl
@@ -557,9 +557,9 @@ wiki: libxslt-api.xml $(srcdir)/wiki.xsl
EXSLT/html/index.html: EXSLT/libexslt-api.xml \
$(srcdir)/newapi.xsl
@ -95,7 +95,7 @@ $NetBSD: patch-aa,v 1.18 2007/08/29 23:26:45 wiz Exp $
--stringparam libname libexslt \
--stringparam dirname EXSLT/ \
--stringparam logo_base ../../ \
@@ -577,22 +577,22 @@ xsltproc.1: xsltproc.xml
@@ -581,22 +581,22 @@ xsltproc.1: xsltproc.xml
# Note that in the following, xmllint output is piped to xsltproc
search.php: $(srcdir)/api.xsl $(srcdir)/site.xsl $(srcdir)/search.templ \
$(srcdir)/search.xml $(srcdir)/search.php.inc