Update to 1.16:
* What is new in gsl-1.16: ** fixed error in gsl_rng_fwrite where uninitialized padding bytes were being written (bug #39104) ** fixed error in gsl_block_alloc where padding bytes were not properly initialized (bugs #39101,#39102,#39103) ** fixed error in ntuple/test.c where padding bytes were not properly initialized (bug #39105) ** fixed triangle selection bug in gsl_sf_coupling_6j_e and gsl_sf_coupling_9j_e (bugs #39466 and #29606) (Håkan Johansson and Alexey Illarionov) ** added higher level wrapper routine gsl_multifit_fdfsolver_driver ** converted gsl_multifit_linear_residuals to use dgemv to improve efficiency (bug #39153) ** added functions gsl_stats_spearman and gsl_sort_vector2 to compute Spearman rank correlation ** added function gsl_poly_dd_hermite_init for Hermite interpolation ** Added support for robust linear least squares ** Added function gsl_linalg_SV_leverage for computing statistical leverages from SVD decomposition ** Added support for approximating the Jacobian of nonlinear least squares fits using forward finite differences ** Extended gsl_sf_coupling_3j to allow larger range and to handle the special case (ja jb jc; 0 0 0)=0 when ja+jb+jc is odd ** Fixed gsl_sf_mathieu_se_array to return zero when the order is zero [bug #33679]. ** Fixed overflow in gsl_sf_lncosh for large negative x (x<-354). ** Improved gsl_ran_negative_binomial_pdf to avoid underflow/overflow for large arguments. ** Multisets now allow k strictly greater than n. ** Fixed gsl_matrix_complex_fwrite/fread failure for noncontiguous matrices (Matthias Sitte).
This commit is contained in:
parent
f00de06541
commit
cf1110ad75
3 changed files with 11 additions and 11 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.33 2012/09/11 23:04:22 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.34 2013/07/21 20:11:11 wiz Exp $
|
||||
|
||||
DISTNAME= gsl-1.15
|
||||
DISTNAME= gsl-1.16
|
||||
CATEGORIES= math devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=gsl/}
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.26 2012/07/29 22:24:32 dholland Exp $
|
||||
$NetBSD: distinfo,v 1.27 2013/07/21 20:11:11 wiz Exp $
|
||||
|
||||
SHA1 (gsl-1.15.tar.gz) = d914f84b39a5274b0a589d9b83a66f44cd17ca8e
|
||||
RMD160 (gsl-1.15.tar.gz) = f34aa2a6514228f7df42fc94638286bcce5cd94c
|
||||
Size (gsl-1.15.tar.gz) = 3281134 bytes
|
||||
SHA1 (gsl-1.16.tar.gz) = 210af9366485f149140973700d90dc93a4b6213e
|
||||
RMD160 (gsl-1.16.tar.gz) = 45e707ad8b5abd77f760827ee49ece9277a36a80
|
||||
Size (gsl-1.16.tar.gz) = 3534080 bytes
|
||||
SHA1 (patch-aa) = 03ad827bfac387a227a26af36289d14aa496132a
|
||||
SHA1 (patch-ae) = ae00f8c0e18377c66672bcd0099cc49f151b1a07
|
||||
SHA1 (patch-af) = 6c0fe8679cf511f9455630bbd42bfba1f293c35d
|
||||
SHA1 (patch-af) = 2d69adfbe4a88bb3936a6eb7c647680d92262373
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-af,v 1.3 2009/10/31 01:27:26 wiz Exp $
|
||||
$NetBSD: patch-af,v 1.4 2013/07/21 20:11:11 wiz Exp $
|
||||
|
||||
Tags: not-for-upstream
|
||||
|
||||
--- siman/Makefile.in.orig 2009-09-08 10:32:19.000000000 +0000
|
||||
--- siman/Makefile.in.orig 2013-07-19 15:14:55.000000000 +0000
|
||||
+++ siman/Makefile.in
|
||||
@@ -50,7 +50,7 @@ CONFIG_HEADER = $(top_builddir)/config.h
|
||||
@@ -95,7 +95,7 @@ CONFIG_HEADER = $(top_builddir)/config.h
|
||||
CONFIG_CLEAN_FILES =
|
||||
CONFIG_CLEAN_VPATH_FILES =
|
||||
LTLIBRARIES = $(noinst_LTLIBRARIES)
|
||||
|
@ -12,4 +12,4 @@ Tags: not-for-upstream
|
|||
+libgslsiman_la_LIBADD = -lm
|
||||
am_libgslsiman_la_OBJECTS = siman.lo
|
||||
libgslsiman_la_OBJECTS = $(am_libgslsiman_la_OBJECTS)
|
||||
PROGRAMS = $(noinst_PROGRAMS)
|
||||
AM_V_lt = $(am__v_lt_@AM_V@)
|
||||
|
|
Loading…
Reference in a new issue