use c99 and patch out incompletely obsoleted sun specific processing.
This commit is contained in:
parent
d21b109751
commit
cf2d5869ef
3 changed files with 20 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.1 2015/07/02 03:37:48 rodent Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2015/07/04 06:38:06 richard Exp $
|
||||
|
||||
DISTNAME= xf86-input-hyperpen-1.4.1
|
||||
CATEGORIES= x11
|
||||
|
@ -13,6 +13,7 @@ COMMENT= Aiptek HyperPen 6000 input driver for the Xorg X server
|
|||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
USE_LANGUAGES+= c99
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2015/07/02 03:37:48 rodent Exp $
|
||||
$NetBSD: distinfo,v 1.2 2015/07/04 06:38:06 richard Exp $
|
||||
|
||||
SHA1 (xf86-input-hyperpen-1.4.1.tar.bz2) = 4a3555310e812dc895b7493b11f7377314c36a75
|
||||
RMD160 (xf86-input-hyperpen-1.4.1.tar.bz2) = 500b2bff3b91fbdc3814c32dbdef88e553ba2b2a
|
||||
Size (xf86-input-hyperpen-1.4.1.tar.bz2) = 266891 bytes
|
||||
SHA1 (patch-src_xf86HyperPen.c) = f2463f0dbbc37ea9125f5ba758b8a982e4613637
|
||||
|
|
16
x11/xf86-input-hyperpen/patches/patch-src_xf86HyperPen.c
Normal file
16
x11/xf86-input-hyperpen/patches/patch-src_xf86HyperPen.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-src_xf86HyperPen.c,v 1.1 2015/07/04 06:38:06 richard Exp $
|
||||
|
||||
sun specific processing obsoleted in 1.4.0
|
||||
https://bugs.freedesktop.org/show_bug.cgi?id=91216
|
||||
|
||||
--- src/xf86HyperPen.c.orig 2011-07-05 01:34:17.000000000 +0000
|
||||
+++ src/xf86HyperPen.c
|
||||
@@ -845,7 +845,7 @@ xf86HypInit(InputDriverPtr drv,
|
||||
pInfo->fd = -1;
|
||||
priv->AutoPT = 1;
|
||||
|
||||
-#if defined(sun) && !defined(i386)
|
||||
+#if 0 && defined(sun) && !defined(i386)
|
||||
if (dev_name) {
|
||||
priv->hypDevice = (char *)alloc(strlen(dev_name) + 1);
|
||||
strcpy(priv->hypDevice, dev_name);
|
Loading…
Reference in a new issue