adjust include paths to avoid header conflict with net/socks5 package

fixes PR pkg/33022 by Steven M. Bellovin
This commit is contained in:
jdolecek 2006-10-23 21:49:31 +00:00
parent e05726bde0
commit cf39e0030e
6 changed files with 71 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.47 2006/10/04 20:50:47 wiz Exp $
# $NetBSD: Makefile,v 1.48 2006/10/23 21:49:31 jdolecek Exp $
PSI_VERSION= 0.10
DISTNAME= psi-${PSI_VERSION}
PKGREVISION= 7
PKGREVISION= 8
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=psi/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.19 2006/09/02 20:21:54 rillig Exp $
$NetBSD: distinfo,v 1.20 2006/10/23 21:49:31 jdolecek Exp $
SHA1 (psi-0.10-20060806-1/psi-0.10.tar.bz2) = f1687f8b93338f47cb1c8fa363e4b4f58628f167
RMD160 (psi-0.10-20060806-1/psi-0.10.tar.bz2) = b8be1490cd02f61cf86f09f2dc9f29716ea4c186
@ -52,3 +52,7 @@ SHA1 (patch-aa) = 1cc8ebcc9317f48e1a1548e6a3895f57899f6cb7
SHA1 (patch-ac) = 011dfae070e171628ce03471c76360aa1f4a30d4
SHA1 (patch-ad) = 01c71c5a00284570b919a5d244fe0e96d141138e
SHA1 (patch-ae) = 93896bc73cb834a42d81e3eed1419940b75a49a0
SHA1 (patch-af) = 3be7b02847bbc1c552a15334ae1ba158b030326b
SHA1 (patch-ag) = ed53824947298272f5ac83af91bf59186d544b93
SHA1 (patch-ah) = 97eba977a7519488b2d3bef0ed2cbc3e2636de9b
SHA1 (patch-ai) = 06d0e9dc7aa67ca42462779acf4d2978904df66b

13
chat/psi/patches/patch-af Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.3 2006/10/23 21:49:31 jdolecek Exp $
--- src/psiaccount.cpp.orig 2006-10-23 23:12:24.000000000 +0200
+++ src/psiaccount.cpp
@@ -83,7 +83,7 @@
#include "psigrowlnotifier.h"
#endif
-#include"bsocket.h"
+#include"network/bsocket.h"
/*#ifdef Q_WS_WIN
#include<windows.h>
typedef int socklen_t;

13
chat/psi/patches/patch-ag Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ag,v 1.1 2006/10/23 21:49:31 jdolecek Exp $
--- iris/jabber/s5b.cpp.orig 2006-10-23 23:06:52.000000000 +0200
+++ iris/jabber/s5b.cpp
@@ -26,7 +26,7 @@
#include<qca.h>
#include"xmpp_xmlcommon.h"
#include"hash.h"
-#include"socks.h"
+#include"network/socks.h"
#include"safedelete.h"
#ifdef Q_OS_WIN

25
chat/psi/patches/patch-ah Normal file
View file

@ -0,0 +1,25 @@
$NetBSD: patch-ah,v 1.1 2006/10/23 21:49:31 jdolecek Exp $
--- iris/xmpp-core/connector.cpp.orig 2006-10-23 23:00:30.000000000 +0200
+++ iris/xmpp-core/connector.cpp
@@ -38,14 +38,14 @@
#ifdef NO_NDNS
#include<qdns.h>
#else
-#include"ndns.h"
+#include"network/ndns.h"
#endif
-#include"srvresolver.h"
-#include"bsocket.h"
-#include"httpconnect.h"
-#include"httppoll.h"
-#include"socks.h"
+#include"network/srvresolver.h"
+#include"network/bsocket.h"
+#include"network/httpconnect.h"
+#include"network/httppoll.h"
+#include"network/socks.h"
#include"hash.h"
//#define XMPP_DEBUG

13
chat/psi/patches/patch-ai Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ai,v 1.1 2006/10/23 21:49:31 jdolecek Exp $
--- psics.pri.orig 2006-10-23 22:53:43.000000000 +0200
+++ psics.pri
@@ -2,7 +2,7 @@ psics {
# iris
INCLUDEPATH += \
$$IRISCS_CPP/util \
- $$IRISCS_CPP/network
+ $$IRISCS_CPP
HEADERS += \
$$IRISCS_CPP/util/base64.h \