Update apache to 1.3.19. The pkgsrc-related changes include adding a

config.layout file instead of specifying every directory as on option to
the Apache configure script.  This layout file might be useful later when
we package Apache 2.x.  I also reordered a few lines so that it's easier
to diff apache/Makefile and apache6/Makefile (hi itojun!).  Also build
the mod_define shared module from the mod_ssl sources.

Relevant changes from version 1.3.17.1 include:

  *) Rewrite ap_unparse_uri_components() to make it safer and more readable
  *) Under certain circumstances, Apache did not supply the
     right response headers when requiring authentication.
  *) Clean up some end-of-loop not reached warnings
  *) Add the correct language tag for interoperation with the Taiwanese
     versions of MSIE and Netscape.
  *) Workaround enabled for a core dump which appeared in broken
     NameVirtualHost configurations.
  *) Sporadic core dump in ap_default_port_for_scheme() with
     internal requests
  *) SECURITY: The default installation could lead to mod_negotiation
     and mod_dir/mod_autoindex displaying a directory listing instead of
     the index.html.* files, if a very long path was created artificially
     by using many slashes. Now a 403 FORBIDDEN is returned.
  *) Trailing slashes (if they exist) are now removed from ServerRoot,
     because there were known problems with them.
  *) TPF startup/shutdown fixes.
  *) Correct a typo in httpd.conf.
  *) Get the correct IP address if ServerName isn't set and we can't
     find a fully-qualified domain name at startup.
  *) Fix pointer arithmetic in mod_rewrite map expansion.
  *) Fixed a problem with file extensions being truncated during
     the call to ap_os_canonical_filename().
This commit is contained in:
jlam 2001-03-13 20:52:26 +00:00
parent 40c4bdca6a
commit cf3f21d472
8 changed files with 91 additions and 55 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.62 2001/02/17 17:21:54 wiz Exp $
# $NetBSD: Makefile,v 1.63 2001/03/13 20:52:26 jlam Exp $
#
# The fourth number in the PKGNAME version indicates a NetBSD pkg revision
# (to indicate changes in the shipped third party patches such as the mod_ssl
@ -7,8 +7,8 @@
# This pkg does not compile in mod_ssl, only the `mod_ssl EAPI' (a set of
# code hooks that allow mod_ssl to be compiled separately later, if desired).
DISTNAME= apache_1.3.17
PKGNAME= apache-1.3.17.1
DISTNAME= apache_1.3.19
PKGNAME= apache-1.3.19
CATEGORIES= www
MASTER_SITES= http://httpd.apache.org/dist/ \
http://www.apache.de/dist/ \
@ -16,37 +16,26 @@ MASTER_SITES= http://httpd.apache.org/dist/ \
ftp://ftp.uni-trier.de/pub/unix/security/mod_ssl/source/ \
http://www.netbsd.org/images/logos/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${SSL_DISTNAME}${EXTRACT_SUFX} \
${MODSSL_DISTNAME}${EXTRACT_SUFX} \
sitedrivenby.gif
PATCH_SITES= http://httpd.apache.org/dist/
PATCHFILES= apache_1.3.17-fix.diff
MAINTAINER= jlam@netbsd.org
HOMEPAGE= http://httpd.apache.org/
COMMENT= HTTP (Web) server
CONFLICTS= apache-*modssl-* apache6-*
SSL_DISTNAME= mod_ssl-2.8.0-1.3.17
MODSSL_DISTNAME= mod_ssl-2.8.1-1.3.19
MODSSL_SRC= ${WRKDIR}/${MODSSL_DISTNAME}
EXTRACT_ONLY= ${DISTFILES:N*.gif}
HAS_CONFIGURE= # defined
CONFIGURE_ARGS+= --prefix=${PREFIX} \
--sbindir=${PREFIX}/sbin \
--libexecdir=${PREFIX}/lib/httpd \
--sysconfdir=${PREFIX}/etc/httpd \
--datadir=${PREFIX}/share/httpd \
--cgidir=${PREFIX}/libexec/cgi-bin \
--includedir=${PREFIX}/include/httpd \
--runtimedir=/var/run \
--logfiledir=/var/log/httpd \
--proxycachedir=/var/spool/httpd/proxy
CONFIGURE_ARGS+= --enable-rule=EAPI \
--enable-module=most \
--disable-module=ssl \
CONFIGURE_ARGS+= --with-layout="${WRKDIR}/config.layout:pkgsrc"
CONFIGURE_ARGS+= --enable-module=most \
--enable-module=auth_db \
--disable-module=auth_dbm
CONFIGURE_ARGS+= --enable-rule=EAPI \
--disable-module=ssl
CONFIGURE_ARGS+= --with-perl=${PERL5}
CONFIGURE_ARGS+= --with-port=80
CONFIGURE_ENV+= OPTIM="${OPTIM}"
@ -66,9 +55,11 @@ BUILD_DEFS+= APACHE_USER
.if !defined(NOPIC)
CONFIGURE_ARGS+= --enable-module=so # requires dlopen()
CONFIGURE_ARGS+= --enable-shared=proxy
CONFIGURE_ARGS+= --enable-shared=define # from mod_ssl pkg.addon
PLIST_SRC+= ${PKGDIR}/PLIST.shared
.else
CONFIGURE_ARGS+= --disable-module=proxy
CONFIGURE_ARGS+= --disable-shared=define
.endif
PLIST_SRC+= ${PKGDIR}/PLIST
@ -97,25 +88,30 @@ INSTALL_FILE= ${WRKDIR}/INSTALL
post-extract:
${CP} ${FILESDIR}/ap_include_extern.h ${WRKSRC}/src/include
${CP} ${WRKDIR}/${SSL_DISTNAME}/pkg.eapi/*.c ${WRKSRC}/src/ap
${CP} ${WRKDIR}/${SSL_DISTNAME}/pkg.eapi/*.h ${WRKSRC}/src/include
${CHMOD} a-x ${WRKSRC}/htdocs/README.rus ${WRKSRC}/htdocs/index.* \
${WRKSRC}/htdocs/apache_pb.gif
${CP} ${MODSSL_SRC}/pkg.addon/*.c ${WRKSRC}/src/modules/extra
${CP} ${MODSSL_SRC}/pkg.addon/*.html ${WRKSRC}/htdocs/manual/mod
${CP} ${MODSSL_SRC}/pkg.eapi/*.c ${WRKSRC}/src/ap
${CP} ${MODSSL_SRC}/pkg.eapi/*.h ${WRKSRC}/src/include
pre-patch:
cd ${WRKSRC} && ${CAT} \
${WRKDIR}/${SSL_DISTNAME}/pkg.eapi/eapi.patch \
${WRKDIR}/${SSL_DISTNAME}/pkg.sslcfg/sslcfg.patch \
${WRKDIR}/${SSL_DISTNAME}/pkg.sslmod/sslmod.patch \
${WRKDIR}/${SSL_DISTNAME}/pkg.sslsup/sslsup.patch \
${MODSSL_SRC}/pkg.addon/addon.patch \
${MODSSL_SRC}/pkg.eapi/eapi.patch \
${MODSSL_SRC}/pkg.sslcfg/sslcfg.patch \
${MODSSL_SRC}/pkg.sslmod/sslmod.patch \
${MODSSL_SRC}/pkg.sslsup/sslsup.patch \
| ${PATCH} ${PATCH_ARGS}
cd ${WRKSRC} && ${TAIL} +154 \
${WRKDIR}/${SSL_DISTNAME}/pkg.ssldoc/ssldoc.patch \
${MODSSL_SRC}/pkg.ssldoc/ssldoc.patch \
| ${PATCH} ${PATCH_ARGS}
${FIND} ${WRKSRC} -name '*.orig' -exec ${RM} -f {} \;
pre-configure:
${SED} -e "s|@PREFIX@|${PREFIX}|g" \
${FILESDIR}/config.layout > ${WRKDIR}/config.layout
post-build:
${SED} -e "s,@PREFIX@,${PREFIX},g" \
${SED} -e "s|@PREFIX@|${PREFIX}|g" \
${FILESDIR}/apache.sh > ${WRKDIR}/apache.sh
pre-install:

View file

@ -0,0 +1,20 @@
# $NetBSD: config.layout,v 1.1 2001/03/13 20:52:27 jlam Exp $
<Layout pkgsrc>
prefix: @PREFIX@
exec_prefix: @PREFIX@
bindir: ${exec_prefix}/bin
sbindir: ${exec_prefix}/sbin
libexecdir: ${exec_prefix}/lib/httpd
mandir: ${prefix}/man
sysconfdir: ${prefix}/etc/httpd
datadir: ${prefix}/share/httpd
iconsdir: ${prefix}/share/httpd/icons
htdocsdir: ${prefix}/share/httpd/htdocs
cgidir: ${exec_prefix}/libexec/cgi-bin
includedir: ${prefix}/include/httpd
localstatedir: /var/run
runtimedir: /var/run
logfiledir: /var/log/httpd
proxycachedir: /var/spool/httpd/proxy
</Layout>

View file

@ -1,6 +1,5 @@
$NetBSD: md5,v 1.19 2001/02/06 12:39:00 itojun Exp $
$NetBSD: md5,v 1.20 2001/03/13 20:52:28 jlam Exp $
MD5 (apache_1.3.17.tar.gz) = bcb3c0db956709ad8f04655fd75621e6
MD5 (mod_ssl-2.8.0-1.3.17.tar.gz) = 3a158f3b5442cb8b7bee4a55851c3794
MD5 (apache_1.3.19.tar.gz) = e9b12b6fbf9a566110f09ac1f3791855
MD5 (mod_ssl-2.8.1-1.3.19.tar.gz) = 7d7cd5db29e1081f5c2fb97fc86c8213
MD5 (sitedrivenby.gif) = ad0647dceb931d02bfd046e55915f7b1
MD5 (apache_1.3.17-fix.diff) = 92ad88730918bcd04763b99fe4493a41

View file

@ -1,11 +1,11 @@
$NetBSD: patch-sum,v 1.15 2001/03/01 13:40:01 wiz Exp $
$NetBSD: patch-sum,v 1.16 2001/03/13 20:52:28 jlam Exp $
MD5 (patch-aa) = 1f5ddd83cedeaff72df8c6428a8878ba
MD5 (patch-ab) = 86886e1e816bcc5527072c4027586cd3
MD5 (patch-ac) = afd85e3188013fa46392ccaa3727d09d
MD5 (patch-ad) = 40f2b9c12d7ef36bbc842480af61b833
MD5 (patch-ae) = c260133920eebada06030552c3306c3d
MD5 (patch-af) = 197a9b91da502834ec5d4cab2c99b2c1
MD5 (patch-ag) = 8c3021892d56ea8fd6023d7fecfe0f61
MD5 (patch-ah) = e27e529142e5ee6fc1be0f965e5510e0
MD5 (patch-ai) = 57b95d04f0ed35252b8ead041017feac
SHA1 (patch-aa) = aed136dfee27b1fe98892d669d218c1070782b5e
SHA1 (patch-ab) = ef7300383b4946ba78ffb592c174b5ea683b60f8
SHA1 (patch-ac) = 4c18bb80f3fbe8d44c941e403ff10fd92b820785
SHA1 (patch-ad) = 79e9b2adb23e412195f0382b30b56496af735297
SHA1 (patch-ae) = 29e1da736d6948d550039cc4ddd1e7743e7e0feb
SHA1 (patch-af) = 3396cbc389cdaad64573e8d99d1a2613a1e5915e
SHA1 (patch-ag) = 5586719f7fa7b5d670d2735e487943c046533ea6
SHA1 (patch-ah) = 553f8f2bf4bf7278adb46ff8749be154f10e39d3
SHA1 (patch-ai) = 6bf9f59849803e2594ef9eaff161b377c6d1071a

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.8 2000/10/13 21:46:45 jlam Exp $
$NetBSD: patch-ab,v 1.9 2001/03/13 20:52:28 jlam Exp $
--- conf/httpd.conf-dist.orig Fri Oct 13 15:58:57 2000
--- conf/httpd.conf-dist.orig Sun Mar 4 02:42:23 2001
+++ conf/httpd.conf-dist
@@ -199,7 +199,14 @@
@@ -197,7 +197,14 @@
# the order below without expert advice.
#
# Example:

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ae,v 1.4 2001/02/02 16:39:57 jlam Exp $
$NetBSD: patch-ae,v 1.5 2001/03/13 20:52:28 jlam Exp $
--- src/modules/standard/mod_include.c.orig Mon Jan 15 12:05:42 2001
--- src/modules/standard/mod_include.c.orig Fri Feb 23 11:37:26 2001
+++ src/modules/standard/mod_include.c
@@ -93,7 +93,11 @@
#include "http_log.h"
@ -54,7 +54,7 @@ $NetBSD: patch-ae,v 1.4 2001/02/02 16:39:57 jlam Exp $
rr = ap_sub_req_lookup_file(tag_val, r);
if (rr->status == HTTP_OK && rr->finfo.st_mode != 0) {
@@ -2160,6 +2168,16 @@
@@ -2162,6 +2170,16 @@
}
}
@ -71,7 +71,7 @@ $NetBSD: patch-ae,v 1.4 2001/02/02 16:39:57 jlam Exp $
/* -------------------------- The main function --------------------------- */
@@ -2284,6 +2302,13 @@
@@ -2286,6 +2304,13 @@
}
#endif
else {

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.18 2001/02/02 16:39:58 jlam Exp $
@comment $NetBSD: PLIST,v 1.19 2001/03/13 20:52:28 jlam Exp $
bin/dbmmanage
bin/htdigest
bin/htpasswd
@ -105,9 +105,11 @@ share/httpd/htdocs/manual/LICENSE
share/httpd/htdocs/manual/bind.html
share/httpd/htdocs/manual/cgi_path.html
share/httpd/htdocs/manual/configuring.html.en
share/httpd/htdocs/manual/configuring.html.html
share/httpd/htdocs/manual/configuring.html.ja.jis
share/httpd/htdocs/manual/content-negotiation.html
share/httpd/htdocs/manual/custom-error.html.en
share/httpd/htdocs/manual/custom-error.html.html
share/httpd/htdocs/manual/custom-error.html.ja.jis
share/httpd/htdocs/manual/dns-caveats.html
share/httpd/htdocs/manual/dso.html
@ -115,13 +117,17 @@ share/httpd/htdocs/manual/ebcdic.html
share/httpd/htdocs/manual/env.html
share/httpd/htdocs/manual/footer.html
share/httpd/htdocs/manual/handler.html.en
share/httpd/htdocs/manual/handler.html.html
share/httpd/htdocs/manual/handler.html.ja.jis
share/httpd/htdocs/manual/header.html
share/httpd/htdocs/manual/howto/cgi.html.en
share/httpd/htdocs/manual/howto/cgi.html.html
share/httpd/htdocs/manual/howto/cgi.html.ja.jis
share/httpd/htdocs/manual/howto/footer.html
share/httpd/htdocs/manual/howto/header.html
share/httpd/htdocs/manual/howto/ssi.html
share/httpd/htdocs/manual/howto/ssi.html.en
share/httpd/htdocs/manual/howto/ssi.html.html
share/httpd/htdocs/manual/howto/ssi.html.ja.jis
share/httpd/htdocs/manual/images/apache_header.gif
share/httpd/htdocs/manual/images/custom_errordocs.gif
share/httpd/htdocs/manual/images/home.gif
@ -133,11 +139,16 @@ share/httpd/htdocs/manual/images/mod_rewrite_fig2.gif
share/httpd/htdocs/manual/images/pixel.gif
share/httpd/htdocs/manual/images/sub.gif
share/httpd/htdocs/manual/index.html.en
share/httpd/htdocs/manual/index.html.fr
share/httpd/htdocs/manual/index.html.html
share/httpd/htdocs/manual/index.html.ja.jis
share/httpd/htdocs/manual/install-tpf.html
share/httpd/htdocs/manual/install.html.en
share/httpd/htdocs/manual/install.html.fr
share/httpd/htdocs/manual/install.html.html
share/httpd/htdocs/manual/install.html.ja.jis
share/httpd/htdocs/manual/invoking.html
share/httpd/htdocs/manual/invoking.html.fr
share/httpd/htdocs/manual/keepalive.html
share/httpd/htdocs/manual/location.html
share/httpd/htdocs/manual/man-template.html
@ -167,6 +178,7 @@ share/httpd/htdocs/manual/misc/vif-info.html
share/httpd/htdocs/manual/misc/windoz_keepalive.html
share/httpd/htdocs/manual/mod/core.html
share/httpd/htdocs/manual/mod/directive-dict.html.en
share/httpd/htdocs/manual/mod/directive-dict.html.html
share/httpd/htdocs/manual/mod/directive-dict.html.ja.jis
share/httpd/htdocs/manual/mod/directives.html
share/httpd/htdocs/manual/mod/footer.html
@ -187,6 +199,7 @@ share/httpd/htdocs/manual/mod/mod_browser.html
share/httpd/htdocs/manual/mod/mod_cern_meta.html
share/httpd/htdocs/manual/mod/mod_cgi.html
share/httpd/htdocs/manual/mod/mod_cookies.html
share/httpd/htdocs/manual/mod/mod_define.html
share/httpd/htdocs/manual/mod/mod_digest.html
share/httpd/htdocs/manual/mod/mod_dir.html
share/httpd/htdocs/manual/mod/mod_dld.html
@ -206,6 +219,7 @@ share/httpd/htdocs/manual/mod/mod_mime.html
share/httpd/htdocs/manual/mod/mod_mime_magic.html
share/httpd/htdocs/manual/mod/mod_mmap_static.html
share/httpd/htdocs/manual/mod/mod_negotiation.html.en
share/httpd/htdocs/manual/mod/mod_negotiation.html.html
share/httpd/htdocs/manual/mod/mod_negotiation.html.ja.jis
share/httpd/htdocs/manual/mod/mod_proxy.html
share/httpd/htdocs/manual/mod/mod_rewrite.html
@ -218,6 +232,7 @@ share/httpd/htdocs/manual/mod/mod_userdir.html
share/httpd/htdocs/manual/mod/mod_usertrack.html
share/httpd/htdocs/manual/mod/mod_vhost_alias.html
share/httpd/htdocs/manual/mod/module-dict.html.en
share/httpd/htdocs/manual/mod/module-dict.html.html
share/httpd/htdocs/manual/mod/module-dict.html.ja.jis
share/httpd/htdocs/manual/mpeix.html
share/httpd/htdocs/manual/multilogs.html
@ -226,6 +241,7 @@ share/httpd/htdocs/manual/new_features_1_0.html
share/httpd/htdocs/manual/new_features_1_1.html
share/httpd/htdocs/manual/new_features_1_2.html
share/httpd/htdocs/manual/new_features_1_3.html.en
share/httpd/htdocs/manual/new_features_1_3.html.html
share/httpd/htdocs/manual/new_features_1_3.html.ja.jis
share/httpd/htdocs/manual/new_features_2_0.html
share/httpd/htdocs/manual/process-model.html
@ -247,6 +263,8 @@ share/httpd/htdocs/manual/readme-tpf.html
share/httpd/htdocs/manual/search/manual-index.cgi
share/httpd/htdocs/manual/sections.html
share/httpd/htdocs/manual/server-wide.html.en
share/httpd/htdocs/manual/server-wide.html.fr
share/httpd/htdocs/manual/server-wide.html.html
share/httpd/htdocs/manual/server-wide.html.ja.jis
share/httpd/htdocs/manual/sourcereorg.html
share/httpd/htdocs/manual/stopping.html
@ -254,6 +272,7 @@ share/httpd/htdocs/manual/suexec.html
share/httpd/htdocs/manual/suexec_1_2.html
share/httpd/htdocs/manual/unixware.html
share/httpd/htdocs/manual/upgrading_to_1_3.html
share/httpd/htdocs/manual/urlmapping.html
share/httpd/htdocs/manual/vhosts/details.html
share/httpd/htdocs/manual/vhosts/details_1_2.html
share/httpd/htdocs/manual/vhosts/examples.html
@ -262,6 +281,7 @@ share/httpd/htdocs/manual/vhosts/footer.html
share/httpd/htdocs/manual/vhosts/header.html
share/httpd/htdocs/manual/vhosts/host.html
share/httpd/htdocs/manual/vhosts/index.html.en
share/httpd/htdocs/manual/vhosts/index.html.html
share/httpd/htdocs/manual/vhosts/index.html.ja.jis
share/httpd/htdocs/manual/vhosts/ip-based.html
share/httpd/htdocs/manual/vhosts/mass.html

View file

@ -1,4 +1,5 @@
@comment $NetBSD: PLIST.shared,v 1.1 2000/09/06 06:17:57 jlam Exp $
@comment $NetBSD: PLIST.shared,v 1.2 2001/03/13 20:52:29 jlam Exp $
lib/httpd/mod_define.so
lib/httpd/mod_proxy.so
lib/httpd/httpd.exp
@dirrm lib/httpd