Use poll instead of select. Fixes CVE-2012-6687.

This commit is contained in:
kim 2015-05-20 04:10:38 +00:00
parent 28742d92c2
commit cf43f48cc9
3 changed files with 89 additions and 3 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.18 2012/10/28 06:30:15 asau Exp $
# $NetBSD: Makefile,v 1.19 2015/05/20 04:10:38 kim Exp $
DISTNAME= fcgi-2.4.0
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= www devel
MASTER_SITES= http://fastcgi.com/dist/

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.5 2012/01/24 02:55:11 sbd Exp $
$NetBSD: distinfo,v 1.6 2015/05/20 04:10:38 kim Exp $
SHA1 (fcgi-2.4.0.tar.gz) = 2329404159e8b8315e524b9eaf1de763202c6e6a
RMD160 (fcgi-2.4.0.tar.gz) = df5c01b197bc72fca7abee184a34ec14253dd0f0
Size (fcgi-2.4.0.tar.gz) = 468682 bytes
SHA1 (patch-aa) = 13577b77ae3d124a5f27be0e456b470180c99550
SHA1 (patch-libfcgi_fcgio.cpp) = 542e620fd252d80696d6b53e34a65998c6545ad5
SHA1 (patch-libfcgi_os_unix.c) = c9c8245cadeddf7de75f2b7fceb5e85d53921f9c

View file

@ -0,0 +1,85 @@
$NetBSD: patch-libfcgi_os_unix.c,v 1.1 2015/05/20 04:10:38 kim Exp $
Use poll instead of select. Fixes CVE-2012-6687.
https://bugs.debian.org/cgi-bin/bugreport.cgi?msg=5;filename=poll.patch;att=1;bug=681591
--- libfcgi/os_unix.c.orig 2002-03-05 19:14:49.000000000 +0000
+++ libfcgi/os_unix.c 2015-05-20 03:46:19.000000000 +0000
@@ -42,6 +42,7 @@
#include <sys/time.h>
#include <sys/un.h>
#include <signal.h>
+#include <poll.h>
#ifdef HAVE_NETDB_H
#include <netdb.h>
@@ -103,6 +104,9 @@
static int shutdownPending = FALSE;
static int shutdownNow = FALSE;
+static int libfcgiOsClosePollTimeout = 2000;
+static int libfcgiIsAfUnixKeeperPollTimeout = 2000;
+
void OS_ShutdownPending()
{
shutdownPending = TRUE;
@@ -168,6 +172,16 @@
if(libInitialized)
return 0;
+ char *libfcgiOsClosePollTimeoutStr = getenv( "LIBFCGI_OS_CLOSE_POLL_TIMEOUT" );
+ if(libfcgiOsClosePollTimeoutStr) {
+ libfcgiOsClosePollTimeout = atoi(libfcgiOsClosePollTimeoutStr);
+ }
+
+ char *libfcgiIsAfUnixKeeperPollTimeoutStr = getenv( "LIBFCGI_IS_AF_UNIX_KEEPER_POLL_TIMEOUT" );
+ if(libfcgiIsAfUnixKeeperPollTimeoutStr) {
+ libfcgiIsAfUnixKeeperPollTimeout = atoi(libfcgiIsAfUnixKeeperPollTimeoutStr);
+ }
+
asyncIoTable = (AioInfo *)malloc(asyncIoTableSize * sizeof(AioInfo));
if(asyncIoTable == NULL) {
errno = ENOMEM;
@@ -755,19 +769,16 @@
if (shutdown(fd, 1) == 0)
{
- struct timeval tv;
- fd_set rfds;
+ struct pollfd pfd;
int rv;
char trash[1024];
- FD_ZERO(&rfds);
+ pfd.fd = fd;
+ pfd.events = POLLIN;
do
{
- FD_SET(fd, &rfds);
- tv.tv_sec = 2;
- tv.tv_usec = 0;
- rv = select(fd + 1, &rfds, NULL, NULL, &tv);
+ rv = poll(&pfd, 1, libfcgiOsClosePollTimeout);
}
while (rv > 0 && read(fd, trash, sizeof(trash)) > 0);
}
@@ -1116,13 +1127,11 @@
*/
static int is_af_unix_keeper(const int fd)
{
- struct timeval tval = { READABLE_UNIX_FD_DROP_DEAD_TIMEVAL };
- fd_set read_fds;
-
- FD_ZERO(&read_fds);
- FD_SET(fd, &read_fds);
+ struct pollfd pfd;
+ pfd.fd = fd;
+ pfd.events = POLLIN;
- return select(fd + 1, &read_fds, NULL, NULL, &tval) >= 0 && FD_ISSET(fd, &read_fds);
+ return poll(&pfd, 1, libfcgiIsAfUnixKeeperPollTimeout) >= 0 && (pfd.revents & POLLIN);
}
/*