Fix inline usage.

This commit is contained in:
joerg 2012-05-04 16:07:02 +00:00
parent 61017adf00
commit cf87ba4dff
2 changed files with 37 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.6 2006/12/29 23:00:32 wulf Exp $
$NetBSD: distinfo,v 1.7 2012/05/04 16:07:02 joerg Exp $
SHA1 (binutils-2.17.tar.gz) = a9ac9ac4e918568b297033cdc44a38beef8f9f6a
RMD160 (binutils-2.17.tar.gz) = bc5e8b23457f0e2e91f70b93eff00134e2d50434
Size (binutils-2.17.tar.gz) = 18196360 bytes
SHA1 (patch-aa) = 9b1dfc38135cc7fe34f26809a444898001858fb1
SHA1 (patch-af) = 274a98c45fb78af64ed01b59afe3cfcdd3312c86
SHA1 (patch-opcodes_cgen-ops.h) = 4dbe5cf86675c4f6236582aedf0f1318442dd288

View file

@ -0,0 +1,35 @@
$NetBSD: patch-opcodes_cgen-ops.h,v 1.1 2012/05/04 16:07:02 joerg Exp $
--- opcodes/cgen-ops.h.orig 2012-04-27 20:34:26.000000000 +0000
+++ opcodes/cgen-ops.h
@@ -27,7 +27,11 @@ with this program; if not, write to the
#if defined (__GNUC__) && ! defined (SEMOPS_DEFINE_INLINE)
#define SEMOPS_DEFINE_INLINE
-#define SEMOPS_INLINE extern inline
+# ifdef __GNUC_STDC_INLINE__
+# define SEMOPS_INLINE static inline
+# else
+# define SEMOPS_INLINE extern inline
+# endif
#else
#define SEMOPS_INLINE
#endif
@@ -298,6 +302,8 @@ extern SI TRUNCDISI (DI);
significant and word number 0 is the most significant word.
??? May also wish an endian-dependent version. Later. */
+#ifndef SEMOPS_DEFINE_INLINE
+
QI SUBWORDSIQI (SI, int);
HI SUBWORDSIHI (SI, int);
SI SUBWORDSFSI (SF);
@@ -314,7 +320,7 @@ SI SUBWORDTFSI (TF, int);
UQI SUBWORDSIUQI (SI, int);
UQI SUBWORDDIUQI (DI, int);
-#ifdef SEMOPS_DEFINE_INLINE
+#else
SEMOPS_INLINE SF
SUBWORDSISF (SI in)