games/xpipeman: fix buffer overflow when starting the game
This commit is contained in:
parent
94d8fbbf12
commit
cf96a77a30
3 changed files with 14 additions and 5 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.23 2018/01/14 17:34:02 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.24 2021/01/30 18:42:47 rillig Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xpipeman-1.5
|
||||
PKGREVISION= 5
|
||||
PKGREVISION= 6
|
||||
CATEGORIES= games x11
|
||||
MASTER_SITES= ${MASTER_SITE_SUNSITE:=games/strategy/}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.7 2015/11/03 20:57:09 agc Exp $
|
||||
$NetBSD: distinfo,v 1.8 2021/01/30 18:42:47 rillig Exp $
|
||||
|
||||
SHA1 (xpipeman-1.5.tar.gz) = 065ec572f7be019737e2bb9ed131bc907c713cc5
|
||||
RMD160 (xpipeman-1.5.tar.gz) = 9668409dadf70bf5bf4a546a3340846191937c74
|
||||
|
@ -8,6 +8,6 @@ SHA1 (patch-aa) = a0b3eebec3488cc4201cebdd05297efd8ae79056
|
|||
SHA1 (patch-ab) = 43bea8141e49a300402d435d4858ec61284efa52
|
||||
SHA1 (patch-ac) = d0c388585988208e47b69dcaa1131870f74676a1
|
||||
SHA1 (patch-actions.c) = a404f799157e49b0a756aa2adece2dac0c895acf
|
||||
SHA1 (patch-ad) = a01454631c6664798e85fb7a1599ab61dff653e2
|
||||
SHA1 (patch-ad) = 4bce754ef1ab5d613b535ec7b08be465ee76cd5f
|
||||
SHA1 (patch-ae) = 850a1d6d46df30303021d09b62879e0d7b3d960b
|
||||
SHA1 (patch-af) = fe20d1ef815c10a1130ac0bfeef5802dc9a8a1fe
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ad,v 1.3 2012/01/20 17:06:52 joerg Exp $
|
||||
$NetBSD: patch-ad,v 1.4 2021/01/30 18:42:47 rillig Exp $
|
||||
|
||||
--- main.c.orig 1991-09-13 20:32:10.000000000 +0000
|
||||
+++ main.c
|
||||
|
@ -83,3 +83,12 @@ $NetBSD: patch-ad,v 1.3 2012/01/20 17:06:52 joerg Exp $
|
|||
cleargc = XCreateGC(display, playfield,
|
||||
GCForeground | GCBackground | GCFunction, &gcv);
|
||||
|
||||
@@ -318,7 +320,7 @@ void
|
||||
update_remain(score)
|
||||
int score;
|
||||
{
|
||||
- char text[13];
|
||||
+ char text[16];
|
||||
(void)sprintf(text,"Remaining: %4d",score);
|
||||
XtSetArg(arglistremain_command[0],XtNlabel,text);
|
||||
XtSetValues(remain_command,arglistremain_command,1);
|
||||
|
|
Loading…
Reference in a new issue