Fix build on SunOS.

This commit is contained in:
hans 2012-02-16 15:00:58 +00:00
parent 7fc5400ec8
commit cfa33ca2f8
6 changed files with 47 additions and 7 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2008/04/07 17:22:11 joerg Exp $
# $NetBSD: Makefile,v 1.9 2012/02/16 15:00:58 hans Exp $
#
DISTNAME= iip-1.1.0
@ -12,6 +12,8 @@ COMMENT= The Invisible IRC Project
PKG_DESTDIR_SUPPORT= user-destdir
LDFLAGS.SunOS+= -lsocket -lnsl
BUILD_DIRS= src
MAKE_FLAGS+= CC=${CC:Q}
MAKE_FLAGS+= LD=${CC:Q}

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2005/12/13 16:59:37 joerg Exp $
$NetBSD: distinfo,v 1.3 2012/02/16 15:00:58 hans Exp $
SHA1 (iip-1.1.0.tgz) = 722ce551c3d330aad04729a4c9b729b10a0ca960
RMD160 (iip-1.1.0.tgz) = 5acc5e33bd060bbdc79e819ade9e5ef07ed7299c
Size (iip-1.1.0.tgz) = 139021 bytes
SHA1 (patch-aa) = 1c0c4bc32c84d0a95b2f88302547a218059ef00f
SHA1 (patch-aa) = 73b7d1be726bf639a97f404f2ea5219d0f48bf50
SHA1 (patch-src_misc_unix.c) = 2f72adc7dd64386ac1b41538ea21d10e390dcca4

View file

@ -1,13 +1,20 @@
$NetBSD: patch-aa,v 1.1 2005/12/13 16:59:37 joerg Exp $
$NetBSD: patch-aa,v 1.2 2012/02/16 15:00:58 hans Exp $
--- src/misc/compat.h.orig 2005-12-13 16:46:43.000000000 +0000
+++ src/misc/compat.h
@@ -70,7 +70,9 @@
@@ -70,7 +70,16 @@
#if defined(_WINDOZE_) || defined(_CYGWIN_)
#define LITTLE__ENDIAN
#else
-#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__MACH__) || defined(__NetBSD__)
+#if defined(__DragonFly__)
+#if defined(__sun)
+#include <sys/byteorder.h>
+#ifdef _BIG_ENDIAN
+#define BIG__ENDIAN
+#else
+#define LITTLE__ENDIAN
+#endif
+#elif defined(__DragonFly__)
+#include <sys/endian.h>
+#elif defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__MACH__) || defined(__NetBSD__)
#include <machine/endian.h>

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_misc_unix.c,v 1.1 2012/02/16 15:00:58 hans Exp $
--- src/misc/unix.c.orig 2002-06-21 05:27:01.000000000 +0200
+++ src/misc/unix.c 2012-01-20 18:18:01.041438535 +0100
@@ -11,11 +11,7 @@
#include <dirent.h>
#include <signal.h>
#include <unistd.h>
-/*
-#if !defined(LOCK_EX) && !defined(LOCK_NB)
#include <fcntl.h>
-#endif
-*/
#include <string.h>
#include <stdio.h>

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.10 2012/02/08 00:12:37 sbd Exp $
$NetBSD: distinfo,v 1.11 2012/02/16 15:07:48 hans Exp $
SHA1 (kmess-1.4.3.tar.gz) = 1613c65c7b9ffaa6a1f55396297d25ab7ee3103d
RMD160 (kmess-1.4.3.tar.gz) = 280bab4275903389d2f7d5b3884df937a83addf7
@ -6,4 +6,5 @@ Size (kmess-1.4.3.tar.gz) = 1869940 bytes
SHA1 (patch-aa) = 098da7e84f8b1eb70815949dca210184c91da6aa
SHA1 (patch-ab) = 90a3f7af4e2ded731b233b87e075e1df10709828
SHA1 (patch-af) = 1fb15e95b763089386adcdd500636f3e2fc16e09
SHA1 (patch-config.h.in) = 333f6c3213afd544e0f4606d5710dd8866f56c21
SHA1 (patch-kmess_prefix.cpp) = a0a1bba175df79f5d370d9ddc7c6b5fe0a7c4a47

View file

@ -0,0 +1,13 @@
$NetBSD: patch-config.h.in,v 1.1 2012/02/16 15:07:48 hans Exp $
--- config.h.in.orig 2012-01-20 19:10:13.658229763 +0100
+++ config.h.in 2012-01-20 19:12:30.887940973 +0100
@@ -163,7 +163,7 @@
* that defines bzero.
*/
-#if defined(_AIX)
+#if defined(_AIX) || defined(__sun)
#include <strings.h>
#endif