Update py-Pillow to 2.4.0.

* Based on patch from adam@.
* Add self test target.

Changelog (Pillow)
==================

2.4.0 (04/01/2014)
------------------

- Indexed Transparency handled for conversions between L, RGB, and P modes. Fixes #510
  [wiredfool]

- Conversions enabled from RGBA->P, Fixes #544
  [wiredfool]

- Improved icns support
  [al45tair]

- Fix libtiff leaking open files, fixes #580
  [wiredfool]

- Fixes for Jpeg encoding in Python 3, fixes #577
  [wiredfool]

- Added support for JPEG 2000
  [al45tair]

- Add more detailed error messages to Image.py
  [larsmans]

- Avoid conflicting _expand functions in PIL & MINGW, fixes #538
  [aclark]

- Merge from Philippe Lagadec’s OleFileIO_PL fork
  [vadmium]

- Fix ImageColor.getcolor
  [homm]

- Make ICO files work with the ImageFile.Parser interface, fixes #522
  [wiredfool]

- Handle 32bit compiled python on 64bit architecture
  [choppsv1]

- Fix support for characters >128 using .pcf or .pil fonts in Py3k. Fixes #505
  [wiredfool]

- Skip CFFI test earlier if it's not installed
  [wiredfool]

- Fixed opening and saving odd sized .pcx files, fixes #523
  [wiredfool]

- Fixed palette handling when converting from mode P->RGB->P
  [d_schmidt]

- Fixed saving mode P image as a PNG with transparency = palette color 0
  [d-schmidt]

- Improve heuristic used when saving progressive and optimized JPEGs with high quality values
  [e98cuenc]

- Fixed DOS with invalid palette size or invalid image size in BMP file
  [wiredfool]

- Added support for BMP version 4 and 5
  [eddwardo, wiredfool]

- Fix segfault in getfont when passed a memory resident font
  [wiredfool]

- Fix crash on Saving a PNG when icc-profile is None
  [brutasse]

- Cffi+Python implementation of the PixelAccess object
  [wiredfool]

- PixelAccess returns unsigned ints for I16 mode
  [wiredfool]

- Minor patch on booleans + Travis
  [sciunto]

- Look in multiarch paths in GNU platforms
  [pinotree]

- Add arch support for pcc64, s390, s390x, armv7l, aarch64
  [manisandro]

- Add arch support for ppc
  [wiredfool]

- Correctly quote file names for WindowsViewer command
  [cgohlke]

- Prefer homebrew freetype over X11 freetype (but still allow both)
  [dmckeone]
This commit is contained in:
obache 2014-04-18 13:00:49 +00:00
parent 6fbcc93eae
commit cfd3241c5e
4 changed files with 29 additions and 15 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.8 2014/04/12 09:10:19 obache Exp $ # $NetBSD: Makefile,v 1.9 2014/04/18 13:00:49 obache Exp $
DISTNAME= Pillow-2.3.1 DISTNAME= Pillow-2.4.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME} PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= graphics python CATEGORIES= graphics python
MASTER_SITES= https://pypi.python.org/packages/source/P/Pillow/ MASTER_SITES= https://pypi.python.org/packages/source/P/Pillow/
@ -18,15 +18,20 @@ SUBST_STAGE.fix-path= pre-configure
SUBST_FILES.fix-path= setup.py SUBST_FILES.fix-path= setup.py
SUBST_SED.fix-path= -e 's,/usr/pkg,${PREFIX},' SUBST_SED.fix-path= -e 's,/usr/pkg,${PREFIX},'
SUBST_SED.fix-path+= -e 's,JPEG_ROOT = None,JPEG_ROOT = _lib_include("${BUILDLINK_PREFIX.jpeg}"),' SUBST_SED.fix-path+= -e 's,JPEG_ROOT = None,JPEG_ROOT = _lib_include("${BUILDLINK_PREFIX.jpeg}"),'
SUBST_SED.fix-path+= -e 's,JPEG2K_ROOT = None,JPEG2K_ROOT = _lib_include("${BUILDLINK_PREFIX.openjpeg}"),'
SUBST_SED.fix-path+= -e 's,ZLIB_ROOT = None,ZLIB_ROOT = _lib_include("${BUILDLINK_PREFIX.zlib}"),' SUBST_SED.fix-path+= -e 's,ZLIB_ROOT = None,ZLIB_ROOT = _lib_include("${BUILDLINK_PREFIX.zlib}"),'
SUBST_SED.fix-path+= -e 's,TIFF_ROOT = None,TIFF_ROOT = _lib_include("${BUILDLINK_PREFIX.tiff}"),' SUBST_SED.fix-path+= -e 's,TIFF_ROOT = None,TIFF_ROOT = _lib_include("${BUILDLINK_PREFIX.tiff}"),'
SUBST_SED.fix-path+= -e 's,FREETYPE_ROOT = None,FREETYPE_ROOT = _lib_include("${BUILDLINK_PREFIX.freetype2}"),' SUBST_SED.fix-path+= -e 's,FREETYPE_ROOT = None,FREETYPE_ROOT = _lib_include("${BUILDLINK_PREFIX.freetype2}"),'
SUBST_SED.fix-path+= -e 's,LCMS_ROOT = None,LCMS_ROOT = _lib_include("${BUILDLINK_PREFIX.lcms2}"),' SUBST_SED.fix-path+= -e 's,LCMS_ROOT = None,LCMS_ROOT = _lib_include("${BUILDLINK_PREFIX.lcms2}"),'
do-test:
${RUN}cd ${WRKSRC};${PKGSRC_SETENV} ${TEST_ENV} ${PYTHONBIN} selftest.py
.include "../../devel/zlib/buildlink3.mk" .include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk" .include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/lcms2/buildlink3.mk" .include "../../graphics/lcms2/buildlink3.mk"
.include "../../graphics/libwebp/buildlink3.mk" .include "../../graphics/libwebp/buildlink3.mk"
.include "../../graphics/openjpeg/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk" .include "../../graphics/tiff/buildlink3.mk"
.include "../../lang/python/egg.mk" .include "../../lang/python/egg.mk"
.include "../../mk/jpeg.buildlink3.mk" .include "../../mk/jpeg.buildlink3.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2013/12/28 02:53:46 obache Exp $ @comment $NetBSD: PLIST,v 1.4 2014/04/18 13:00:49 obache Exp $
${PYSITELIB}/PIL/ArgImagePlugin.py ${PYSITELIB}/PIL/ArgImagePlugin.py
${PYSITELIB}/PIL/ArgImagePlugin.pyc ${PYSITELIB}/PIL/ArgImagePlugin.pyc
${PYSITELIB}/PIL/ArgImagePlugin.pyo ${PYSITELIB}/PIL/ArgImagePlugin.pyo
@ -146,6 +146,9 @@ ${PYSITELIB}/PIL/ImtImagePlugin.pyo
${PYSITELIB}/PIL/IptcImagePlugin.py ${PYSITELIB}/PIL/IptcImagePlugin.py
${PYSITELIB}/PIL/IptcImagePlugin.pyc ${PYSITELIB}/PIL/IptcImagePlugin.pyc
${PYSITELIB}/PIL/IptcImagePlugin.pyo ${PYSITELIB}/PIL/IptcImagePlugin.pyo
${PYSITELIB}/PIL/Jpeg2KImagePlugin.py
${PYSITELIB}/PIL/Jpeg2KImagePlugin.pyc
${PYSITELIB}/PIL/Jpeg2KImagePlugin.pyo
${PYSITELIB}/PIL/JpegImagePlugin.py ${PYSITELIB}/PIL/JpegImagePlugin.py
${PYSITELIB}/PIL/JpegImagePlugin.pyc ${PYSITELIB}/PIL/JpegImagePlugin.pyc
${PYSITELIB}/PIL/JpegImagePlugin.pyo ${PYSITELIB}/PIL/JpegImagePlugin.pyo
@ -164,6 +167,7 @@ ${PYSITELIB}/PIL/MpegImagePlugin.pyo
${PYSITELIB}/PIL/MspImagePlugin.py ${PYSITELIB}/PIL/MspImagePlugin.py
${PYSITELIB}/PIL/MspImagePlugin.pyc ${PYSITELIB}/PIL/MspImagePlugin.pyc
${PYSITELIB}/PIL/MspImagePlugin.pyo ${PYSITELIB}/PIL/MspImagePlugin.pyo
${PYSITELIB}/PIL/OleFileIO-README.md
${PYSITELIB}/PIL/OleFileIO.py ${PYSITELIB}/PIL/OleFileIO.py
${PYSITELIB}/PIL/OleFileIO.pyc ${PYSITELIB}/PIL/OleFileIO.pyc
${PYSITELIB}/PIL/OleFileIO.pyo ${PYSITELIB}/PIL/OleFileIO.pyo
@ -200,6 +204,9 @@ ${PYSITELIB}/PIL/PpmImagePlugin.pyo
${PYSITELIB}/PIL/PsdImagePlugin.py ${PYSITELIB}/PIL/PsdImagePlugin.py
${PYSITELIB}/PIL/PsdImagePlugin.pyc ${PYSITELIB}/PIL/PsdImagePlugin.pyc
${PYSITELIB}/PIL/PsdImagePlugin.pyo ${PYSITELIB}/PIL/PsdImagePlugin.pyo
${PYSITELIB}/PIL/PyAccess.py
${PYSITELIB}/PIL/PyAccess.pyc
${PYSITELIB}/PIL/PyAccess.pyo
${PYSITELIB}/PIL/SgiImagePlugin.py ${PYSITELIB}/PIL/SgiImagePlugin.py
${PYSITELIB}/PIL/SgiImagePlugin.pyc ${PYSITELIB}/PIL/SgiImagePlugin.pyc
${PYSITELIB}/PIL/SgiImagePlugin.pyo ${PYSITELIB}/PIL/SgiImagePlugin.pyo

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.4 2014/04/11 12:41:18 obache Exp $ $NetBSD: distinfo,v 1.5 2014/04/18 13:00:49 obache Exp $
SHA1 (Pillow-2.3.1.zip) = 956ceda1fc5427220c19f7e4be2e0b04c0c557ef SHA1 (Pillow-2.4.0.zip) = 43fcfb95a6190a86b56ec7c5872a5b4634a46c1d
RMD160 (Pillow-2.3.1.zip) = 2b7d757eda7366e16f975bf3102823103ef65884 RMD160 (Pillow-2.4.0.zip) = 2692fee280a9abc595ebbb8df6d6a73f5c83667a
Size (Pillow-2.3.1.zip) = 2421519 bytes Size (Pillow-2.4.0.zip) = 6519873 bytes
SHA1 (patch-setup.py) = b70e3bec9f5c266a4864404a3a69f2da7b5e05c7 SHA1 (patch-setup.py) = c7d2e6eddcc64369dc4605f806a360cc244dbcf0

View file

@ -1,22 +1,24 @@
$NetBSD: patch-setup.py,v 1.1 2013/12/28 02:53:47 obache Exp $ $NetBSD: patch-setup.py,v 1.2 2014/04/18 13:00:49 obache Exp $
* prevent to detect optional tkinter * Prevent to detect optional tkinter.
* Disable demo programs.
--- setup.py.orig 2013-10-02 04:07:08.000000000 +0000 --- setup.py.orig 2014-04-01 09:21:44.000000000 +0000
+++ setup.py +++ setup.py
@@ -75,10 +75,7 @@ def _lib_include(root): @@ -79,11 +79,7 @@ def _lib_include(root):
def _read(file): def _read(file):
return open(file, 'rb').read() return open(file, 'rb').read()
-try: -try:
- import _tkinter - import _tkinter
-except ImportError: -except (ImportError, OSError):
- # pypy emits an oserror
- _tkinter = None - _tkinter = None
+_tkinter = None +_tkinter = None
NAME = 'Pillow' NAME = 'Pillow'
@@ -432,7 +429,7 @@ class pil_build_ext(build_ext): @@ -507,7 +503,7 @@ class pil_build_ext(build_ext):
exts.append(Extension( exts.append(Extension(
"PIL._webp", ["_webp.c"], libraries=libs, define_macros=defs)) "PIL._webp", ["_webp.c"], libraries=libs, define_macros=defs))
@ -25,7 +27,7 @@ $NetBSD: patch-setup.py,v 1.1 2013/12/28 02:53:47 obache Exp $
# locate Tcl/Tk frameworks # locate Tcl/Tk frameworks
frameworks = [] frameworks = []
framework_roots = [ framework_roots = [
@@ -598,7 +595,7 @@ setup( @@ -673,7 +669,7 @@ setup(
ext_modules=[Extension("PIL._imaging", ["_imaging.c"])], ext_modules=[Extension("PIL._imaging", ["_imaging.c"])],
include_package_data=True, include_package_data=True,
packages=find_packages(), packages=find_packages(),