Fix build with SunOS and GCC 4.7.

This commit is contained in:
fhajny 2013-06-19 11:54:04 +00:00
parent e24d787e6d
commit cfe6b86778
2 changed files with 15 additions and 6 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.21 2013/06/14 21:28:42 wiz Exp $
$NetBSD: distinfo,v 1.22 2013/06/19 11:54:04 fhajny Exp $
SHA1 (opencv-2.4.5.tar.gz) = 9e25f821db9e25aa454a31976ba6b5a3a50b6fa4
RMD160 (opencv-2.4.5.tar.gz) = 3b7dc9da2e0b616a19e50ed5999ca0dd65c45d5f
@ -10,4 +10,4 @@ SHA1 (patch-modules_core_src_system.cpp) = 3b7ac545585a430d28c7077f360357079f127
SHA1 (patch-modules_flann_include_opencv2_flann_defines.h) = ab848e67c4e03219670598ac2d21071a617a5c33
SHA1 (patch-modules_legacy_src_dpstereo.cpp) = da9955fb6cc81054427b69efb97a58160b64f262
SHA1 (patch-modules_ts_include_opencv2_ts_ts__perf.hpp) = 8a7f08b176cedec85fd613e715d7b12d666a3e45
SHA1 (patch-modules_ts_src_ts.cpp) = c30482215db80285aa7a5ad039308cbfca033672
SHA1 (patch-modules_ts_src_ts.cpp) = 61e4ab59f2ca57f75212743bf869616dfc9e5f13

View file

@ -1,10 +1,10 @@
$NetBSD: patch-modules_ts_src_ts.cpp,v 1.1 2013/06/12 10:13:58 jperkin Exp $
$NetBSD: patch-modules_ts_src_ts.cpp,v 1.2 2013/06/19 11:54:04 fhajny Exp $
Avoid std::string conflict.
Avoid std::foo conflict.
--- modules/ts/src/ts.cpp.orig 2012-07-25 22:55:31.000000000 +0000
--- modules/ts/src/ts.cpp.orig 2013-04-05 09:00:20.000000000 +0000
+++ modules/ts/src/ts.cpp
@@ -557,7 +557,7 @@ void TS::vprintf( int streams, const cha
@@ -562,7 +562,7 @@ void TS::vprintf( int streams, const cha
for( int i = 0; i < MAX_IDX; i++ )
if( (streams & (1 << i)) )
{
@ -13,3 +13,12 @@ Avoid std::string conflict.
// in the new GTest-based framework we do not use
// any output files (except for the automatically generated xml report).
// if a test fails, all the buffers are printed, so we do not want to duplicate the information and
@@ -617,7 +617,7 @@ void smoothBorder(Mat& img, const Scalar
Scalar s;
uchar *p = NULL;
int n = 100/delta;
- int nR = std::min(n, (img.rows+1)/2), nC = std::min(n, (img.cols+1)/2);
+ int nR = ::std::min(n, (img.rows+1)/2), nC = ::std::min(n, (img.cols+1)/2);
int r, c, i;
for(r=0; r<nR; r++)