Support C++11. Bump revision.
This commit is contained in:
parent
358463efd2
commit
cfeba95992
4 changed files with 44 additions and 3 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.2 2013/08/27 22:28:05 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2013/08/30 10:19:37 joerg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= soci-3.2.1
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=soci/}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2013/08/27 22:28:05 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.3 2013/08/30 10:19:37 joerg Exp $
|
||||
|
||||
SHA1 (soci-3.2.1.tar.gz) = 38f602ec8d61c4563df8ea4d4ed318dc378e7096
|
||||
RMD160 (soci-3.2.1.tar.gz) = 3e98139aa904c62dbf7cc6a1fae5fc73042a6364
|
||||
|
@ -7,3 +7,5 @@ SHA1 (patch-CMakeLists.txt) = c66f0b8fd3ca0fedaebedd6943ae0471f7c6ba35
|
|||
SHA1 (patch-backends_postgresql_session.cpp) = d816ffc0c4981ef9b2bdcb28e9e4292b519d3e75
|
||||
SHA1 (patch-backends_postgresql_soci-postgresql.h) = 1c01ebdad82d4f641024b8e73a4c853f1c83b134
|
||||
SHA1 (patch-backends_sqlite3_soci-sqlite3.h) = 688260116f0e35f37f7de8d61366a3397259dc0c
|
||||
SHA1 (patch-core_once-temp-type.cpp) = 5d19aa72accd8d3883915283c1380df2ec4c7e5c
|
||||
SHA1 (patch-core_once-temp-type.h) = 5c08a4c0f5bba3729bfec2c6930b6145da5e864d
|
||||
|
|
13
databases/soci/patches/patch-core_once-temp-type.cpp
Normal file
13
databases/soci/patches/patch-core_once-temp-type.cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-core_once-temp-type.cpp,v 1.1 2013/08/30 10:19:37 joerg Exp $
|
||||
|
||||
--- core/once-temp-type.cpp.orig 2013-08-30 00:17:03.209692967 +0000
|
||||
+++ core/once-temp-type.cpp
|
||||
@@ -35,7 +35,7 @@ once_temp_type & once_temp_type::operato
|
||||
return *this;
|
||||
}
|
||||
|
||||
-once_temp_type::~once_temp_type()
|
||||
+once_temp_type::~once_temp_type() SOCI_ONCE_TEMP_TYPE_NOEXCEPT
|
||||
{
|
||||
rcst_->dec_ref();
|
||||
}
|
26
databases/soci/patches/patch-core_once-temp-type.h
Normal file
26
databases/soci/patches/patch-core_once-temp-type.h
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-core_once-temp-type.h,v 1.1 2013/08/30 10:19:37 joerg Exp $
|
||||
|
||||
--- core/once-temp-type.h.orig 2013-08-30 00:16:03.749693674 +0000
|
||||
+++ core/once-temp-type.h
|
||||
@@ -21,6 +21,12 @@ namespace details
|
||||
|
||||
class ref_counted_statement;
|
||||
|
||||
+#if __cplusplus >= 201103L
|
||||
+#define SOCI_ONCE_TEMP_TYPE_NOEXCEPT noexcept(false)
|
||||
+#else
|
||||
+#define SOCI_ONCE_TEMP_TYPE_NOEXCEPT
|
||||
+#endif
|
||||
+
|
||||
// this needs to be lightweight and copyable
|
||||
class SOCI_DECL once_temp_type
|
||||
{
|
||||
@@ -30,7 +36,7 @@ public:
|
||||
once_temp_type(once_temp_type const & o);
|
||||
once_temp_type & operator=(once_temp_type const & o);
|
||||
|
||||
- ~once_temp_type();
|
||||
+ ~once_temp_type() SOCI_ONCE_TEMP_TYPE_NOEXCEPT;
|
||||
|
||||
template <typename T>
|
||||
once_temp_type & operator<<(T const & t)
|
Loading…
Reference in a new issue