Update libntlm to 0.3.12.

* Version 0.3.12 (released 2006-08-24)

** Update of gnulib files.

** API and ABI modifications.
No changes since last version.

* Version 0.3.11 (released 2006-05-16)

** Fix buggy MD4 implementation on 64-bit platforms.

** Self tests are run under valgrind, if available.

** Updated gnulib files.

** API and ABI modifications.
No changes since last version.

* Version 0.3.10 (released 2006-03-24)

** The library is linked with -no-undefined, to enable building a Windows DLL.

** Add new APIs to access the SMBencrypt and SMBNTencrypt functions.
Suggested by Pavel Fedin <fedin@matek.ru>.

** API and ABI modifications.
ntlm_smb_encrypt: ADD
ntlm_smb_nt_encrypt: ADD

* Version 0.3.9 (released 2005-10-23)

** DES and MD4 functionality replaced with gnulib modules.
These modules also comes with self tests.

** API and ABI modifications.
No changes since last version.
This commit is contained in:
obache 2006-12-09 13:57:29 +00:00
parent c03fa99045
commit cffbefdc8a
6 changed files with 76 additions and 7 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.14 2006/03/04 21:29:17 jlam Exp $
# $NetBSD: Makefile,v 1.15 2006/12/09 13:57:29 obache Exp $
#
DISTNAME= libntlm-0.3.8
DISTNAME= libntlm-0.3.12
CATEGORIES= security
MASTER_SITES= http://josefsson.org/libntlm/releases/
@ -14,6 +14,6 @@ GNU_CONFIGURE= yes
USE_LIBTOOL= yes
TEST_TARGET= check
PKGCONFIG_OVERRIDE+= libntlm.pc.in
PKGCONFIG_OVERRIDE+= libntlm.pc.in
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,9 @@
$NetBSD: distinfo,v 1.6 2005/09/30 13:26:24 wiz Exp $
$NetBSD: distinfo,v 1.7 2006/12/09 13:57:29 obache Exp $
SHA1 (libntlm-0.3.8.tar.gz) = 3385b51ed5db489474cbabb568e8334e7ed8b261
RMD160 (libntlm-0.3.8.tar.gz) = c6f564a83848823e883ba1af45d3ec7b6277a27b
Size (libntlm-0.3.8.tar.gz) = 328409 bytes
SHA1 (libntlm-0.3.12.tar.gz) = 9817766086915304d307ed0a6bd644661bb76437
RMD160 (libntlm-0.3.12.tar.gz) = 55a9c9f7a6414360439f5c3087076f7c00966c75
Size (libntlm-0.3.12.tar.gz) = 393196 bytes
SHA1 (patch-aa) = 74091394db44717ded27fa77a92261f6e01523c6
SHA1 (patch-ab) = a483cc8d22392e52c5aebbcf34fffa39462463c5
SHA1 (patch-ac) = df45a385645029752a92ef3751a972f30161580f
SHA1 (patch-ad) = f1becbe91bb7aa990d78121d3307da7595b80546

View file

@ -0,0 +1,22 @@
$NetBSD: patch-aa,v 1.1 2006/12/09 13:57:29 obache Exp $
--- lib/des.c.orig 2006-05-16 14:05:25.000000000 +0000
+++ lib/des.c
@@ -532,7 +532,7 @@ des_key_schedule (const char * _rawkey,
}
void
-des_setkey (des_ctx *ctx, const char * key)
+ntlm_des_setkey (des_ctx *ctx, const char * key)
{
int i;
@@ -551,7 +551,7 @@ des_makekey (des_ctx *ctx, const char *
if (keylen != 8)
return false;
- des_setkey (ctx, key);
+ ntlm_des_setkey (ctx, key);
return !des_is_weak_key (key);
}

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2006/12/09 13:57:29 obache Exp $
--- lib/des.h.orig 2005-10-18 13:37:39.000000000 +0000
+++ lib/des.h
@@ -59,7 +59,7 @@ des_is_weak_key (const char * key);
* Does not check parity bits, but simply ignore them. Does not check
* for weak keys. */
extern void
-des_setkey (des_ctx *ctx, const char * key);
+ntlm_des_setkey (des_ctx *ctx, const char * key);
/* Fill a DES context CTX with subkeys calculated from 64bit KEY, with
* weak key checking. Does not check parity bits, but simply ignore

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1 2006/12/09 13:57:29 obache Exp $
--- smbencrypt.c.orig 2006-03-24 09:04:05.000000000 +0000
+++ smbencrypt.c
@@ -145,7 +145,7 @@ ntlm_convert_key (char *key_56, des_ctx
key[6] = ((to_uchar (key_56[5]) << 2) & 0xFF) | (to_uchar (key_56[6]) >> 6);
key[7] = (to_uchar (key_56[6]) << 1) & 0xFF;
- des_setkey (ks, key);
+ ntlm_des_setkey (ks, key);
memset (&key, 0, sizeof (key));
}

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ad,v 1.1 2006/12/09 13:57:29 obache Exp $
--- tests/test-des.c.orig 2005-10-23 16:03:36.000000000 +0000
+++ tests/test-des.c
@@ -44,10 +44,10 @@ main (int argc, char *argv[])
for (i = 0; i < 64; ++i)
{
- des_setkey (&des, key);
+ ntlm_des_setkey (&des, key);
des_ecb_encrypt (&des, input, temp1);
des_ecb_encrypt (&des, temp1, temp2);
- des_setkey (&des, temp2);
+ ntlm_des_setkey (&des, temp2);
des_ecb_decrypt (&des, temp1, temp3);
memcpy (key, temp3, 8);
memcpy (input, temp1, 8);