hplip: fix the build with the "sane" option
Tested on NetBSD/amd64.
This commit is contained in:
parent
c36f4f4ed7
commit
cffe3e140c
4 changed files with 72 additions and 6 deletions
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.42 2022/03/13 05:46:55 gutteridge Exp $
|
$NetBSD: distinfo,v 1.43 2022/08/26 03:08:27 khorben Exp $
|
||||||
|
|
||||||
BLAKE2s (hplip-3.19.12.tar.gz) = 24ea25e3ac4ab3c521ae65acb27a88a65a164f3d93b088e33f13f97ee8ad6eae
|
BLAKE2s (hplip-3.19.12.tar.gz) = 24ea25e3ac4ab3c521ae65acb27a88a65a164f3d93b088e33f13f97ee8ad6eae
|
||||||
SHA512 (hplip-3.19.12.tar.gz) = 5552cd717ae082ee55cdb77d79e8d035d8ecb7cf23c79d659fda43468d8ed414a33c4d869eab4ab83dee836f0d1cceb74c3c4a249e26f904a5ab2350e08a5677
|
SHA512 (hplip-3.19.12.tar.gz) = 5552cd717ae082ee55cdb77d79e8d035d8ecb7cf23c79d659fda43468d8ed414a33c4d869eab4ab83dee836f0d1cceb74c3c4a249e26f904a5ab2350e08a5677
|
||||||
|
@ -14,5 +14,7 @@ SHA1 (patch-prnt_hpijs_context2.cpp) = f81148c1c334a9074453b27ac055833cd1669bd0
|
||||||
SHA1 (patch-prnt_hpijs_foomatic-rip-hplip) = cfec38607572af9536e7c21cfe2e491d07d3838d
|
SHA1 (patch-prnt_hpijs_foomatic-rip-hplip) = cfec38607572af9536e7c21cfe2e491d07d3838d
|
||||||
SHA1 (patch-prnt_hpijs_hjzjscolor.cpp) = 5ca9c828ba4aff17a54a803d79c2dc169975d50c
|
SHA1 (patch-prnt_hpijs_hjzjscolor.cpp) = 5ca9c828ba4aff17a54a803d79c2dc169975d50c
|
||||||
SHA1 (patch-prnt_hpps_hppsfilter.c) = 5a3e7f3f5504fb88d58cf2b79fa138066859aa00
|
SHA1 (patch-prnt_hpps_hppsfilter.c) = 5a3e7f3f5504fb88d58cf2b79fa138066859aa00
|
||||||
SHA1 (patch-protocol_discovery_mdns.c) = e2ca43f6ab13fe2124a38bcc0eff292a57b34b06
|
SHA1 (patch-protocol_discovery_mdns.c) = 41427f6a381f6cdaa2f1d8f5c050d6b51eeb412e
|
||||||
SHA1 (patch-scan.py) = 3ca05c3569ec78b5752af364e4d0728900076c3c
|
SHA1 (patch-scan.py) = 3ca05c3569ec78b5752af364e4d0728900076c3c
|
||||||
|
SHA1 (patch-scan_sane_OrbliteScan_LinuxCommon.h) = 509ba919ce6c51f2e1247cad1ae5b66a707c21cd
|
||||||
|
SHA1 (patch-scan_sane_OrbliteScan_MacCommon.h) = 4a96cddccdaf8878c33f5523d9bf0ca4951a76dd
|
||||||
|
|
|
@ -1,10 +1,16 @@
|
||||||
$NetBSD: patch-protocol_discovery_mdns.c,v 1.2 2016/02/28 20:37:28 schnoebe Exp $
|
$NetBSD: patch-protocol_discovery_mdns.c,v 1.3 2022/08/26 03:08:28 khorben Exp $
|
||||||
|
|
||||||
Add <sys/time> to allow building on a wider variety of systems.
|
Add system headers to allow building on a wider variety of systems.
|
||||||
|
|
||||||
--- protocol/discovery/mdns.c.orig 2015-12-05 13:17:06.000000000 +0000
|
--- protocol/discovery/mdns.c.orig 2019-12-10 05:00:36.000000000 +0000
|
||||||
+++ protocol/discovery/mdns.c
|
+++ protocol/discovery/mdns.c
|
||||||
@@ -28,6 +28,7 @@
|
@@ -24,10 +24,12 @@
|
||||||
|
Author: Sanjay Kumar
|
||||||
|
\*****************************************************************************/
|
||||||
|
|
||||||
|
-//#include <stdio.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
+#include <stdio.h>
|
||||||
#include <string.h>
|
#include <string.h>
|
||||||
#include <syslog.h>
|
#include <syslog.h>
|
||||||
#include <sys/socket.h>
|
#include <sys/socket.h>
|
||||||
|
|
|
@ -0,0 +1,39 @@
|
||||||
|
$NetBSD: patch-scan_sane_OrbliteScan_LinuxCommon.h,v 1.1 2022/08/26 03:08:28 khorben Exp $
|
||||||
|
|
||||||
|
--- scan/sane/OrbliteScan/LinuxCommon.h.orig 2019-12-10 05:00:30.000000000 +0000
|
||||||
|
+++ scan/sane/OrbliteScan/LinuxCommon.h
|
||||||
|
@@ -2,6 +2,7 @@
|
||||||
|
#define H_LinuxCommon
|
||||||
|
|
||||||
|
#include <sys/types.h>
|
||||||
|
+#include <stdint.h>
|
||||||
|
|
||||||
|
/* Common typedefs for Linux */
|
||||||
|
|
||||||
|
@@ -9,19 +10,15 @@ typedef unsigned char * StringPtr;
|
||||||
|
typedef unsigned char Boolean;
|
||||||
|
typedef char * Ptr;
|
||||||
|
|
||||||
|
-typedef unsigned char UInt8;
|
||||||
|
+typedef uint8_t UInt8;
|
||||||
|
typedef UInt8* PUInt8;
|
||||||
|
-typedef signed char SInt8;
|
||||||
|
-typedef unsigned short UInt16;
|
||||||
|
-typedef signed short SInt16;
|
||||||
|
-typedef u_int32_t UInt32;
|
||||||
|
+typedef int8_t SInt8;
|
||||||
|
+typedef uint16_t UInt16;
|
||||||
|
+typedef int16_t SInt16;
|
||||||
|
+typedef uint32_t UInt32;
|
||||||
|
typedef int32_t SInt32;
|
||||||
|
-//typedef unsigned long UInt32;
|
||||||
|
-//typedef signed long SInt32;
|
||||||
|
-typedef __S64_TYPE SInt64;
|
||||||
|
-typedef __U64_TYPE UInt64;
|
||||||
|
-typedef __S64_TYPE int64_t;
|
||||||
|
-typedef __U64_TYPE uint64_t;
|
||||||
|
+typedef int64_t SInt64;
|
||||||
|
+typedef uint64_t UInt64;
|
||||||
|
|
||||||
|
//typedef unsigned long ULONG;
|
||||||
|
//typedef void* LPVOID;
|
19
print/hplip/patches/patch-scan_sane_OrbliteScan_MacCommon.h
Normal file
19
print/hplip/patches/patch-scan_sane_OrbliteScan_MacCommon.h
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
$NetBSD: patch-scan_sane_OrbliteScan_MacCommon.h,v 1.1 2022/08/26 03:08:28 khorben Exp $
|
||||||
|
|
||||||
|
--- scan/sane/OrbliteScan/MacCommon.h.orig 2019-12-10 05:00:30.000000000 +0000
|
||||||
|
+++ scan/sane/OrbliteScan/MacCommon.h
|
||||||
|
@@ -1,12 +1,10 @@
|
||||||
|
#ifndef H_MacCommon
|
||||||
|
#define H_MacCommon
|
||||||
|
|
||||||
|
-#ifndef __linux__
|
||||||
|
+#ifdef __APPLE__
|
||||||
|
#include <CoreFoundation/CFPlugInCOM.h>
|
||||||
|
#define __CFPlugInCOM_Included__
|
||||||
|
-#endif
|
||||||
|
-
|
||||||
|
-#ifdef __linux__
|
||||||
|
+#else
|
||||||
|
# include "LinuxCommon.h"
|
||||||
|
#endif
|
||||||
|
|
Loading…
Reference in a new issue