Work around automake failure that appeared recently.

This commit is contained in:
dholland 2012-04-08 02:37:36 +00:00
parent efd64482fe
commit d02334d084
2 changed files with 29 additions and 7 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2010/02/27 03:21:06 dmcmahill Exp $
$NetBSD: distinfo,v 1.7 2012/04/08 02:37:36 dholland Exp $
SHA1 (tnt-1.2.2.tar.gz) = bd089863ca2cd939009253e83f4ab75317191047
RMD160 (tnt-1.2.2.tar.gz) = 1a2ba68a93ee21590bb25a3eacf85d3773c3e77d
@ -14,7 +14,7 @@ SHA1 (patch-ah) = 97368422014ab65139ecc2cd77d89c4e3b2fa026
SHA1 (patch-ai) = 2ab6aa6bd4cd0883725c66bb7d4fa59e9e3172a4
SHA1 (patch-aj) = 7ec0c75d0e29c2adce2eea442e4b3309455965e7
SHA1 (patch-ak) = d17baa2b591126cda87c79768136a3d6086d229e
SHA1 (patch-al) = b7c2bf78d0d92bd51fb8de86d78d7a51a5b640d4
SHA1 (patch-al) = 63508931ae726264c0f2778fe9a1ad7088c866ad
SHA1 (patch-am) = d81174386963777cae26019183a73fed74f62970
SHA1 (patch-an) = a854330a07eb434d8d80352a323d1a29c875200f
SHA1 (patch-ao) = ff87ca35c176b0d47cbdd12d2edb5924b3916f3f

View file

@ -1,20 +1,41 @@
$NetBSD: patch-al,v 1.1 2008/03/18 11:48:25 dmcmahill Exp $
$NetBSD: patch-al,v 1.2 2012/04/08 02:37:36 dholland Exp $
The automake manual clearly specifies that if we mix fortran sources
in with c or c++ sources then we need to use the AC_F77_LIBRARY_LDFLAGS
autoconf macro and then add $(FLIBS) to either LDADD for a program or
LIBADD for a library.
--- bem/Makefile.am.orig 2004-04-22 20:07:12.000000000 +0000
+++ bem/Makefile.am 2008-03-16 03:44:18.000000000 +0000
@@ -27,5 +27,5 @@
Automake prohibits scripts in the "pkglib" dir for some reason, so
work around it by calling the dir "blahlib".
--- bem/Makefile.am.orig 2012-04-08 02:41:28.000000000 +0000
+++ bem/Makefile.am
@@ -26,12 +26,12 @@
# autoconf, and automake for the first time, you'll need to
# supply command line switches --add-missing --copy.
#----------------------------------------------------------------
-AUTOMAKE_OPTIONS = foreign subdir-objects
+AUTOMAKE_OPTIONS = foreign
#---------------------------------------------------------------
@@ -72,7 +72,9 @@
# tcl/tk scripts that may need to be installed.
#---------------------------------------------------------------
-pkglib_SCRIPTS = \
+blahlib_SCRIPTS = \
lib/bem.tcl \
lib/bem_gpge.itcl \
lib/bem_graphs.itcl \
@@ -46,7 +46,7 @@ pkglib_SCRIPTS = \
# Define an installation directory that includes
# the version number (from AC_INIT) like "bltmath1.0"
#---------------------------------------------------------------
-pkglibdir = $(libdir)/$(PACKAGE)$(PACKAGE_VERSION)
+blahlibdir = $(libdir)/$(PACKAGE)$(PACKAGE_VERSION)
#----------------------------------------------------------------
# nmmtl is our main target
@@ -71,9 +71,11 @@ bem_TESTS = tests/test_bem.tcl
#----------------------------------------------------------------
bem_SOURCES = $(cpp_SOURCES) $(fortran_SOURCES) \
src/nmmtl_parse_xsctn.cpp
+bem_LDADD = $(FLIBS)
@ -24,3 +45,4 @@ LIBADD for a library.
+nmmtl_LDADD = $(FLIBS)
#----------------------------------------------------------------