Make this work with -current's krb5 stuff.

This commit is contained in:
explorer 1999-11-30 09:08:44 +00:00
parent 07809e760d
commit d0c4e63e89
5 changed files with 36 additions and 14 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.64 1999/11/12 16:34:29 abs Exp $
# $NetBSD: Makefile,v 1.65 1999/11/30 09:08:44 explorer Exp $
# FreeBSD Id: Makefile,v 1.47 1997/11/10 22:04:42 dima Exp
#
@ -87,9 +87,9 @@ DISTFILES+= ssh-1.2.27-afs-kerberos.patch-1
.if defined(KERBEROS) && ${KERBEROS} == 5
USE_KERBEROS= yes
CONFIGURE_ARGS+=--with-krb5
CONFIGURE_ARGS+=--with-kerberos5=/usr
.else
CONFIGURE_ARGS+=--without-krb5
CONFIGURE_ARGS+=--without-kerberos5
.endif
# Find X11 libraries with xpkgwedge

View file

@ -1,12 +1,12 @@
$NetBSD: patch-sum,v 1.9 1999/11/13 17:32:20 sommerfeld Exp $
# $NetBSD: patch-sum,v 1.10 1999/11/30 09:08:45 explorer Exp $
MD5 (patch-aa) = 39a4c82d2b89aae61df69a50f7aaa813
MD5 (patch-ab) = 9807586f0bcbc7e92045d40be272d585
MD5 (patch-ab) = c94c6aa280b0904bbce66c822ef071ba
MD5 (patch-ac) = 6ca9c5c5300c27a541928a2c2bc44388
MD5 (patch-ad) = 60483c735ff0e3c47e640002be0cee75
MD5 (patch-ae) = e654824aa0394aa47d474011902411a9
MD5 (patch-af) = 577e03bb92268c10b74ae3e60caf9147
MD5 (patch-aj) = f6d02ebe8508202660d77c04b7aeeba2
MD5 (patch-aj) = 775013bab6d1b7d878335db99cbfbd2d
MD5 (patch-al) = 0cb4bff88a26d1a09e0669b5879b91f7
MD5 (patch-am) = fd4e766e57c58645714fdab8ed55da5d
MD5 (patch-an) = 135b09a36c66aaf25a476dcb659efcf7

View file

@ -1,12 +1,12 @@
$NetBSD: patch-sum-v6,v 1.5 1999/11/13 17:32:20 sommerfeld Exp $
# $NetBSD: patch-sum-v6,v 1.6 1999/11/30 09:08:46 explorer Exp $
MD5 (patch-aa) = 39a4c82d2b89aae61df69a50f7aaa813
MD5 (patch-ab) = 9807586f0bcbc7e92045d40be272d585
MD5 (patch-ab) = c94c6aa280b0904bbce66c822ef071ba
MD5 (patch-ac) = 6ca9c5c5300c27a541928a2c2bc44388
MD5 (patch-ad) = 60483c735ff0e3c47e640002be0cee75
MD5 (patch-ae) = e654824aa0394aa47d474011902411a9
MD5 (patch-af) = 577e03bb92268c10b74ae3e60caf9147
MD5 (patch-aj) = f6d02ebe8508202660d77c04b7aeeba2
MD5 (patch-aj) = 775013bab6d1b7d878335db99cbfbd2d
MD5 (patch-al) = 0cb4bff88a26d1a09e0669b5879b91f7
MD5 (patch-am) = fd4e766e57c58645714fdab8ed55da5d
MD5 (patch-an) = 135b09a36c66aaf25a476dcb659efcf7

View file

@ -1,7 +1,6 @@
$NetBSD: patch-ab,v 1.7 1999/09/18 21:08:20 kim Exp $
--- configure.in.orig Wed May 12 07:20:02 1999
+++ configure.in Sat Sep 18 16:59:35 1999
# $NetBSD: patch-ab,v 1.8 1999/11/30 09:08:46 explorer Exp $
--- configure.in.orig Wed May 12 04:20:02 1999
+++ configure.in Mon Nov 29 16:04:28 1999
@@ -311,9 +311,9 @@
export CFLAGS CC
@ -26,6 +25,17 @@ $NetBSD: patch-ab,v 1.7 1999/09/18 21:08:20 kim Exp $
AC_MSG_WARN(Remember to read README.TIS. The connection between sshd and TIS authentication
server is clear text!)
;;
@@ -931,8 +931,8 @@
AC_DEFINE(KERBEROS)
AC_DEFINE(KRB5)
KERBEROS_ROOT="$with_kerberos5"
- KERBEROS_INCS="-I${KERBEROS_ROOT}/include"
- KERBEROS_LIBS="-L${KERBEROS_ROOT}/lib -lgssapi_krb5 -lkrb5 -lcrypto -lcom_err"
+ KERBEROS_INCS="-I${KERBEROS_ROOT}/include/krb5"
+ KERBEROS_LIBS="-L${KERBEROS_ROOT}/lib -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err"
AC_CHECK_LIB(ndbm, dbm_open, KERBEROS_LIBS="$KERBEROS_LIBS -lndbm")
KERBEROS_OBJS="auth-kerberos.o"
;;
@@ -1227,14 +1227,14 @@
[ case "$enableval" in
no)

View file

@ -1,5 +1,6 @@
# $NetBSD: patch-aj,v 1.8 1999/11/30 09:08:46 explorer Exp $
--- configure.orig Wed May 12 04:20:06 1999
+++ configure Thu Jun 3 23:59:18 1999
+++ configure Mon Nov 29 16:04:16 1999
@@ -1989,12 +1989,6 @@
export CFLAGS CC
@ -33,6 +34,17 @@
echo "configure: warning: Remember to read README.TIS. The connection between sshd and TIS authentication
server is clear text!" 1>&2
;;
@@ -6646,8 +6640,8 @@
EOF
KERBEROS_ROOT="$with_kerberos5"
- KERBEROS_INCS="-I${KERBEROS_ROOT}/include"
- KERBEROS_LIBS="-L${KERBEROS_ROOT}/lib -lgssapi_krb5 -lkrb5 -lcrypto -lcom_err"
+ KERBEROS_INCS="-I${KERBEROS_ROOT}/include/krb5"
+ KERBEROS_LIBS="-L${KERBEROS_ROOT}/lib -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err"
echo $ac_n "checking for dbm_open in -lndbm""... $ac_c" 1>&6
echo "configure:6653: checking for dbm_open in -lndbm" >&5
ac_lib_var=`echo ndbm'_'dbm_open | sed 'y%./+-%__p_%'`
@@ -7295,15 +7289,15 @@
case "$enableval" in
no)