Pick output name that is going to work. Make signal handler test more
resilient.
This commit is contained in:
parent
58f1497d41
commit
d1090b339c
2 changed files with 29 additions and 4 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.14 2011/11/26 23:53:10 sbd Exp $
|
||||
$NetBSD: distinfo,v 1.15 2013/05/28 19:03:49 joerg Exp $
|
||||
|
||||
SHA1 (tf-40s1-mccp-patch.gz) = 9a8d12ef8a6e0b6c315e6ae83efcbd179a930a6a
|
||||
RMD160 (tf-40s1-mccp-patch.gz) = af0d27a8b3585c8cc61669c79f26a8382c272424
|
||||
|
@ -8,6 +8,6 @@ RMD160 (tf-40s1.tar.gz) = 2852daa3363bb134f29cc25d3177e9599ecacc1f
|
|||
Size (tf-40s1.tar.gz) = 349239 bytes
|
||||
SHA1 (patch-aa) = 8e6d68c7017ab4f4294451bd0d808f48e413f9b6
|
||||
SHA1 (patch-ab) = 7716f7cb3bd352824ff77e8f678416561e68bacf
|
||||
SHA1 (patch-ac) = d6cba3c8b7ce7e43759983d70cefd2358ad919a0
|
||||
SHA1 (patch-ac) = 01dd3c54d7246b3769ceb1976f0e2272fb15d750
|
||||
SHA1 (patch-ad) = 4ff9f85b0b05857560b00e354496a9ed2a01e6e2
|
||||
SHA1 (patch-ae) = 4c85ea1953f24548d0dee107b645c32c91e5bc5d
|
||||
|
|
|
@ -1,11 +1,20 @@
|
|||
$NetBSD: patch-ac,v 1.5 2011/08/18 05:03:10 dholland Exp $
|
||||
$NetBSD: patch-ac,v 1.6 2013/05/28 19:03:49 joerg Exp $
|
||||
|
||||
Config for pkgsrc.
|
||||
DESTDIR support.
|
||||
Make the SYMLINK relative.
|
||||
|
||||
--- unix/tfconfig.orig 2011-08-18 04:45:11.000000000 +0000
|
||||
--- unix/tfconfig.orig 2013-05-28 16:51:21.000000000 +0000
|
||||
+++ unix/tfconfig
|
||||
@@ -35,7 +35,7 @@ echo "Configuring $TFVERSION"; echo
|
||||
|
||||
### Initialize variables, just in case they're already defined.
|
||||
|
||||
-AOUT=tfconfig.out
|
||||
+AOUT=`pwd`/tfconfig.out
|
||||
BINDIR=''
|
||||
# CC='' ;# Use the value from the environment if there is one.
|
||||
CCFLAGS=${TFDEV_CCFLAGS-'-O'}
|
||||
@@ -168,18 +168,18 @@ fi
|
||||
# The cd;pwd is needed to normalize the directory name in case of links, etc.
|
||||
|
||||
|
@ -69,3 +78,19 @@ Make the SYMLINK relative.
|
|||
echo "LIBDIR = ${LIBDIR}" >&5
|
||||
echo "MAILDIR = ${MAILDIR}" >&5
|
||||
echo "MANPAGE = ${MANPAGE}" >&5
|
||||
@@ -654,11 +656,13 @@ echo "Testing type of signal handlers...
|
||||
cat >test.c <<EOF
|
||||
#include <sys/types.h>
|
||||
#include <signal.h>
|
||||
+#include <stdlib.h>
|
||||
#undef signal
|
||||
-extern void (*signal())();
|
||||
+typedef void (*my_sighandler_t)(int);
|
||||
+extern my_sighandler_t signal(int, my_sighandler_t);
|
||||
main() { exit(0); }
|
||||
EOF
|
||||
-if ${CC} ${CCFLAGS} -c test.c -o ${AOUT}>/dev/null 2>&1; then
|
||||
+if ${CC} ${CCFLAGS} -c test.c -o ${AOUT}; then
|
||||
echo "Signal handlers return void, as they should."
|
||||
echo '#define RETSIG void' >&4
|
||||
else
|
||||
|
|
Loading…
Reference in a new issue