Fix template look up. Don't declare constants with non-default
constructor.
This commit is contained in:
parent
9927d30623
commit
d1262b44af
6 changed files with 113 additions and 1 deletions
|
@ -1,9 +1,14 @@
|
|||
$NetBSD: distinfo,v 1.5 2012/04/17 17:46:30 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.6 2012/12/22 02:29:36 joerg Exp $
|
||||
|
||||
SHA1 (cryptopp552.zip) = 18efe451b3c682f40db75dc2b09cb448a835e7d6
|
||||
RMD160 (cryptopp552.zip) = 8929795b654d7186b2b38714d22a57ea01862dbd
|
||||
Size (cryptopp552.zip) = 992073 bytes
|
||||
SHA1 (patch-aa) = 777f0cec232cf696ea1a9dd04fa626f3e76442c1
|
||||
SHA1 (patch-algebra.cpp) = c2f915338c8fff332611d060a0fa38e1410c9e68
|
||||
SHA1 (patch-cryptlib.cpp) = 870d877c49e2e166046ede37855451c7094b5bb4
|
||||
SHA1 (patch-cryptlib.h) = 805d0404695f8ccde13eeeaf6a638f3611ef6650
|
||||
SHA1 (patch-eccrypto.cpp) = 5a35804b58b99d0d811e92f01c2350a6723443e1
|
||||
SHA1 (patch-eccrypto.h) = 8d2fe42a1cc1b4731fcd821b0b3a8a6ee59b1a32
|
||||
SHA1 (patch-panama.cpp) = 483b7153d3b5433b34981d7eb4895e37c7d9a1b7
|
||||
SHA1 (patch-secblock.h) = 5e0e3c5b48424e4232a88efc2244a9bd5df0fc5a
|
||||
SHA1 (patch-simple.h) = 1a268509a6bc96dcaa61e83cc2fcb7ed1f7eb180
|
||||
|
|
13
security/crypto++/patches/patch-algebra.cpp
Normal file
13
security/crypto++/patches/patch-algebra.cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-algebra.cpp,v 1.1 2012/12/22 02:29:36 joerg Exp $
|
||||
|
||||
--- algebra.cpp.orig 2012-12-21 21:43:47.000000000 +0000
|
||||
+++ algebra.cpp
|
||||
@@ -58,7 +58,7 @@ template <class T> const T& AbstractEucl
|
||||
Element g[3]={b, a};
|
||||
unsigned int i0=0, i1=1, i2=2;
|
||||
|
||||
- while (!Equal(g[i1], this->Identity()))
|
||||
+ while (!this->Equal(g[i1], this->Identity()))
|
||||
{
|
||||
g[i2] = Mod(g[i0], g[i1]);
|
||||
unsigned int t = i0; i0 = i1; i1 = i2; i2 = t;
|
13
security/crypto++/patches/patch-cryptlib.cpp
Normal file
13
security/crypto++/patches/patch-cryptlib.cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-cryptlib.cpp,v 1.1 2012/12/22 02:29:36 joerg Exp $
|
||||
|
||||
--- cryptlib.cpp.orig 2012-12-21 21:38:50.000000000 +0000
|
||||
+++ cryptlib.cpp
|
||||
@@ -29,7 +29,7 @@ CRYPTOPP_COMPILE_ASSERT(sizeof(dword) ==
|
||||
#endif
|
||||
|
||||
const std::string BufferedTransformation::NULL_CHANNEL;
|
||||
-const NullNameValuePairs g_nullNameValuePairs;
|
||||
+NullNameValuePairs g_nullNameValuePairs;
|
||||
|
||||
BufferedTransformation & TheBitBucket()
|
||||
{
|
13
security/crypto++/patches/patch-cryptlib.h
Normal file
13
security/crypto++/patches/patch-cryptlib.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-cryptlib.h,v 1.1 2012/12/22 02:29:36 joerg Exp $
|
||||
|
||||
--- cryptlib.h.orig 2012-12-21 21:38:45.000000000 +0000
|
||||
+++ cryptlib.h
|
||||
@@ -323,7 +323,7 @@ public:
|
||||
};
|
||||
|
||||
//! _
|
||||
-extern CRYPTOPP_DLL const NullNameValuePairs g_nullNameValuePairs;
|
||||
+extern CRYPTOPP_DLL NullNameValuePairs g_nullNameValuePairs;
|
||||
|
||||
// ********************************************************
|
||||
|
31
security/crypto++/patches/patch-eccrypto.cpp
Normal file
31
security/crypto++/patches/patch-eccrypto.cpp
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-eccrypto.cpp,v 1.1 2012/12/22 02:29:36 joerg Exp $
|
||||
|
||||
--- eccrypto.cpp.orig 2012-12-21 21:44:36.000000000 +0000
|
||||
+++ eccrypto.cpp
|
||||
@@ -389,7 +389,7 @@ template <class EC> void DL_GroupParamet
|
||||
StringSource ssG(param.g, true, new HexDecoder);
|
||||
Element G;
|
||||
bool result = GetCurve().DecodePoint(G, ssG, (size_t)ssG.MaxRetrievable());
|
||||
- SetSubgroupGenerator(G);
|
||||
+ this->SetSubgroupGenerator(G);
|
||||
assert(result);
|
||||
|
||||
StringSource ssN(param.n, true, new HexDecoder);
|
||||
@@ -545,7 +545,7 @@ bool DL_GroupParameters_EC<EC>::Validate
|
||||
if (level >= 2 && pass)
|
||||
{
|
||||
const Integer &q = GetSubgroupOrder();
|
||||
- Element gq = gpc ? gpc->Exponentiate(this->GetGroupPrecomputation(), q) : ExponentiateElement(g, q);
|
||||
+ Element gq = gpc ? gpc->Exponentiate(this->GetGroupPrecomputation(), q) : this->ExponentiateElement(g, q);
|
||||
pass = pass && IsIdentity(gq);
|
||||
}
|
||||
return pass;
|
||||
@@ -583,7 +583,7 @@ void DL_PublicKey_EC<EC>::BERDecodePubli
|
||||
typename EC::Point P;
|
||||
if (!this->GetGroupParameters().GetCurve().DecodePoint(P, bt, size))
|
||||
BERDecodeError();
|
||||
- SetPublicElement(P);
|
||||
+ this->SetPublicElement(P);
|
||||
}
|
||||
|
||||
template <class EC>
|
37
security/crypto++/patches/patch-eccrypto.h
Normal file
37
security/crypto++/patches/patch-eccrypto.h
Normal file
|
@ -0,0 +1,37 @@
|
|||
$NetBSD: patch-eccrypto.h,v 1.1 2012/12/22 02:29:36 joerg Exp $
|
||||
|
||||
--- eccrypto.h.orig 2012-12-21 21:44:16.000000000 +0000
|
||||
+++ eccrypto.h
|
||||
@@ -43,7 +43,7 @@ public:
|
||||
void Initialize(const EllipticCurve &ec, const Point &G, const Integer &n, const Integer &k = Integer::Zero())
|
||||
{
|
||||
this->m_groupPrecomputation.SetCurve(ec);
|
||||
- SetSubgroupGenerator(G);
|
||||
+ this->SetSubgroupGenerator(G);
|
||||
m_n = n;
|
||||
m_k = k;
|
||||
}
|
||||
@@ -145,9 +145,9 @@ public:
|
||||
typedef typename EC::Point Element;
|
||||
|
||||
void Initialize(const DL_GroupParameters_EC<EC> ¶ms, const Element &Q)
|
||||
- {this->AccessGroupParameters() = params; SetPublicElement(Q);}
|
||||
+ {this->AccessGroupParameters() = params; this->SetPublicElement(Q);}
|
||||
void Initialize(const EC &ec, const Element &G, const Integer &n, const Element &Q)
|
||||
- {this->AccessGroupParameters().Initialize(ec, G, n); SetPublicElement(Q);}
|
||||
+ {this->AccessGroupParameters().Initialize(ec, G, n); this->SetPublicElement(Q);}
|
||||
|
||||
// X509PublicKey
|
||||
void BERDecodePublicKey(BufferedTransformation &bt, bool parametersPresent, size_t size);
|
||||
@@ -166,9 +166,9 @@ public:
|
||||
void Initialize(const EC &ec, const Element &G, const Integer &n, const Integer &x)
|
||||
{this->AccessGroupParameters().Initialize(ec, G, n); this->SetPrivateExponent(x);}
|
||||
void Initialize(RandomNumberGenerator &rng, const DL_GroupParameters_EC<EC> ¶ms)
|
||||
- {GenerateRandom(rng, params);}
|
||||
+ {this->GenerateRandom(rng, params);}
|
||||
void Initialize(RandomNumberGenerator &rng, const EC &ec, const Element &G, const Integer &n)
|
||||
- {GenerateRandom(rng, DL_GroupParameters_EC<EC>(ec, G, n));}
|
||||
+ {this->GenerateRandom(rng, DL_GroupParameters_EC<EC>(ec, G, n));}
|
||||
|
||||
// PKCS8PrivateKey
|
||||
void BERDecodePrivateKey(BufferedTransformation &bt, bool parametersPresent, size_t size);
|
Loading…
Reference in a new issue