Fix previous commit. Don't use undefined variable.

This commit is contained in:
hira 2004-10-04 12:25:59 +00:00
parent 6c0c193081
commit d12698a1e0
2 changed files with 34 additions and 8 deletions

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2004/09/06 20:38:36 danw Exp $
$NetBSD: distinfo,v 1.3 2004/10/04 12:25:59 hira Exp $
SHA1 (libcfg+-0.6.2.tar.gz) = 856d647bb06e37d3c6e48d356a3e11796ebed35b
Size (libcfg+-0.6.2.tar.gz) = 169482 bytes
SHA1 (patch-aa) = ba63ccc5c031a893b111caac1ba9ddf13c18b4fc
SHA1 (patch-ab) = 5498fc24215d058feaed62be8a16d25be8a9961f
SHA1 (patch-ab) = 6de1bbf8c5eefcfb07bc6bfa087c3c89d42d3a06

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.1 2004/09/06 20:38:36 danw Exp $
$NetBSD: patch-ab,v 1.2 2004/10/04 12:25:59 hira Exp $
--- src/Makefile.in.orig Tue Feb 17 11:37:47 2004
+++ src/Makefile.in
@@ -60,16 +60,16 @@ SOURCES = $(srcdir)/cfg+.c \
--- src/Makefile.in.orig 2004-02-18 01:37:47.000000000 +0900
+++ src/Makefile.in 2004-09-29 00:32:45.000000000 +0900
@@ -60,16 +60,16 @@
$(srcdir)/platon/str/strdyn.c \
$(srcdir)/platon/str/dynfgets.c
@ -29,7 +29,7 @@ $NetBSD: patch-ab,v 1.1 2004/09/06 20:38:36 danw Exp $
# SunOS 4 make does not allow multiple makefiles to be specified in one ­include directive.
DEP_FILES = $(top_builddir)/src/.deps/cfg+.P \
@@ -97,8 +97,7 @@ noinst_HEADERS = cfgfile.h \
@@ -97,8 +97,7 @@
platon/str/strplus.h
LIBSTATIC = $(PACKAGE).a
@ -39,7 +39,7 @@ $NetBSD: patch-ab,v 1.1 2004/09/06 20:38:36 danw Exp $
install_LIB = $(LIBSTATIC) $(LIBDYNAMICV)
@@ -166,7 +165,7 @@ install-lib: $(install_LIB)
@@ -166,7 +165,7 @@
@list='$(install_LIB)'; for p in $$list; do \
if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
echo " Installing file $(DESTDIR)$(libdir)/$$p"; \
@ -48,3 +48,29 @@ $NetBSD: patch-ab,v 1.1 2004/09/06 20:38:36 danw Exp $
done
uninstall-lib:
@$(NORMAL_UNINSTALL)
@@ -217,11 +216,7 @@
cd platon && $(LN_S) $$p $(include_SYMLINK); \
); \
cd $$here; \
- done; \
- cd $(DESTDIR)$(libdir) && ( \
- echo " Creating symlink $(DESTDIR)$(libdir)/$(LIBDYNAMIC)"; \
- $(LN_S) $(LIBDYNAMICV) $(LIBDYNAMIC); \
- );
+ done;
uninstall-symlinks:
@$(NORMAL_UNINSTALL)
-@list='$(include_SYMLINK)'; for p in $$list; do \
@@ -229,11 +224,7 @@
rm -f $(DESTDIR)$(includedir)/$$p; \
echo " rm -f $(DESTDIR)$(includedir_platon)/$$p"; \
rm -f $(DESTDIR)$(includedir_platon)/$$p; \
- done; \
- cd $(DESTDIR)$(libdir) && ( \
- echo " rm -f $(DESTDIR)$(libdir)/$(LIBDYNAMIC)"; \
- rm -f $(LIBDYNAMIC); \
- );
+ done;
uninstall-dirs:
@$(NORMAL_UNINSTALL)