Revive MASTER_SITES.
Update net/sdist to version 1.9: - Add configuration file (sdist.conf). - Change the default netgroup to dist-os-rel-arch and add options to not use the release (-norel) and/or architecture (-noarch).
This commit is contained in:
parent
434e8dc6e2
commit
d1362325a1
4 changed files with 44 additions and 17 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.16 2012/10/23 17:19:08 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.17 2013/03/14 15:49:10 kim Exp $
|
||||
#
|
||||
|
||||
DISTNAME= sdist-1.7
|
||||
PKGREVISION= 1
|
||||
DISTNAME= sdist-1.9
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= # ftp://ftp.gw.com/pub/people/kim/
|
||||
MASTER_SITES= http://oss.gw.com/people/kim/
|
||||
|
||||
MAINTAINER= kim@tac.nyc.ny.us
|
||||
COMMENT= Invoke rdist to distribute files to a set of hosts
|
||||
|
@ -20,14 +19,15 @@ SDIST_PAWD?= pwd
|
|||
|
||||
BUILD_DEFS+= SDIST_PAWD
|
||||
|
||||
INSTALLATION_DIRS= sbin ${PKGMANDIR}/man8
|
||||
NO_CONFIGURE= yes
|
||||
BUILD_MAKE_FLAGS+= PREFIX=${PREFIX} PAWD=${SDIST_PAWD}
|
||||
INSTALL_MAKE_FLAGS+= PREFIX=${DESTDIR}${PREFIX}
|
||||
EGDIR= share/examples/${PKGBASE}
|
||||
|
||||
SUBST_CLASSES+= manpath
|
||||
SUBST_STAGE.manpath= post-extract
|
||||
SUBST_FILES.manpath= Makefile
|
||||
SUBST_SED.manpath= -e 's,/man/,/${PKGMANDIR}/,'
|
||||
CONF_FILES= ${PREFIX}/${EGDIR}/sdist.conf \
|
||||
${PKG_SYSCONFDIR}/sdist.conf
|
||||
|
||||
INSTALLATION_DIRS= sbin ${PKGMANDIR}/man8 ${EGDIR}
|
||||
NO_CONFIGURE= yes
|
||||
BUILD_MAKE_FLAGS+= PAWD=${SDIST_PAWD}
|
||||
INSTALL_MAKE_FLAGS+= EGDIR=${EGDIR}
|
||||
MAKE_FLAGS+= PREFIX=${PREFIX}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2007/12/24 08:07:42 obache Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2013/03/14 15:49:10 kim Exp $
|
||||
man/man8/sdist.8
|
||||
sbin/sdist
|
||||
share/examples/sdist/sdist.conf
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.5 2006/06/04 07:58:36 kim Exp $
|
||||
$NetBSD: distinfo,v 1.6 2013/03/14 15:49:10 kim Exp $
|
||||
|
||||
SHA1 (sdist-1.7.tar.gz) = 661e6061f23a0b93fbb3f594f320fad6a0d08795
|
||||
RMD160 (sdist-1.7.tar.gz) = ce2bc68d5db77bc724d9b4ffa42d410742b411f9
|
||||
Size (sdist-1.7.tar.gz) = 2879 bytes
|
||||
SHA1 (sdist-1.9.tar.gz) = ccbbffc7debac08be5164603df5645ad01859156
|
||||
RMD160 (sdist-1.9.tar.gz) = 8491ed4f23a750a80372779f5903ac038e50659c
|
||||
Size (sdist-1.9.tar.gz) = 5947 bytes
|
||||
SHA1 (patch-aa) = 03b8ce66b8930ee04487754bdb822790896b9998
|
||||
|
|
25
net/sdist/patches/patch-aa
Normal file
25
net/sdist/patches/patch-aa
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-aa,v 1.3 2013/03/14 15:49:10 kim Exp $
|
||||
|
||||
--- Makefile.orig 2011-09-02 17:44:12.000000000 +0300
|
||||
+++ Makefile 2013-03-14 17:18:21.000000000 +0200
|
||||
@@ -24,16 +24,16 @@
|
||||
chmod a+rx $@
|
||||
|
||||
.PHONY: install
|
||||
-install: install-bin install-man
|
||||
+install: install-bin install-conf install-man
|
||||
|
||||
install-bin: ${CMD}
|
||||
- install -c -m 755 ${CMD} ${PREFIX}/${BIN}/${CMD}
|
||||
+ ${BSD_INSTALL_SCRIPT} $(CMD) ${DESTDIR}${PREFIX}/${BIN}/$(CMD)
|
||||
|
||||
install-conf:
|
||||
- install -c -m 644 ${CMD}.conf ${PREFIX}/etc/${CMD}.conf
|
||||
+ ${BSD_INSTALL_DATA} ${CMD}.conf ${DESTDIR}${PREFIX}/${EGDIR}/${CMD}.conf
|
||||
|
||||
install-man:
|
||||
- install -c -m 444 ${CMD}.man ${PREFIX}/man/man${MAN}/${CMD}.${MAN}
|
||||
+ ${BSD_INSTALL_MAN} $(CMD).man ${DESTDIR}${PREFIX}/${PKGMANDIR}/man${MAN}/$(CMD).${MAN}
|
||||
|
||||
clean:
|
||||
rm -f ${CMD}
|
Loading…
Reference in a new issue