Respect PKG_SYSCONFDIR ! :)

This commit is contained in:
zuntum 2001-11-25 22:55:04 +00:00
parent aebbc6914f
commit d14905f88d
4 changed files with 14 additions and 43 deletions

View file

@ -1,12 +0,0 @@
# $NetBSD: DEINSTALL,v 1.1 2001/11/01 01:01:36 zuntum Exp $
if [ "$2" != "POST-DEINSTALL" ]; then
exit 0
fi
echo ===========================================================================
echo
echo If you won\'t be using ${PKGNAME} any longer, you may want to remove
echo /etc/teapop.passwd
echo
echo ===========================================================================

View file

@ -1,7 +0,0 @@
======================================================================
$NetBSD: MESSAGE,v 1.1 2001/11/01 01:01:36 zuntum Exp $
teapop.password file is expected in /etc, you may want to install
one from ${PREFIX}/share/examples/teapop
======================================================================

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.4 2001/08/31 21:27:49 zuntum Exp $
# $NetBSD: Makefile,v 1.5 2001/11/25 22:55:04 zuntum Exp $
DISTNAME= teapop-0.3.2
CATEGORIES= mail
@ -13,7 +13,10 @@ USE_BUILDLINK_ONLY= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS+= --enable-flock
CONFIGURE_ARGS+= --sysconfdir=/etc
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
EGDIR= ${PREFIX}/share/examples/teapop
CONF_FILES= ${EGDIR}/teapop.passwd ${PKG_SYSCONFDIR}/teapop.passwd
.include "../../mk/bsd.prefs.mk"
@ -25,4 +28,13 @@ CONFIGURE_ARGS+=--disable-apop
CONFIGURE_ARGS+=--disable-vpop
.endif
pre-install:
PKG_PREFIX=${PREFIX} ${SH} ${INSTALL_FILE} ${PKGNAME} PRE-INSTALL
post-install:
${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/etc/teapop.passwd ${EGDIR}
PKG_PREFIX=${PREFIX} ${SH} ${INSTALL_FILE} ${PKGNAME} POST-INSTALL
.include "../../mk/bsd.pkg.install.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,22 +0,0 @@
$NetBSD: patch-aa,v 1.3 2001/08/31 21:27:49 zuntum Exp $
--- etc/Makefile.in.orig Tue Aug 28 22:40:21 2001
+++ etc/Makefile.in
@@ -23,15 +23,8 @@
fi
install: build
- @ echo Checking for existing teapop.passwd; \
- if [ -f ${sysconfdir}/teapop.passwd ]; then \
- echo "Exists...NOT installing teapop.passwd"; \
- else \
- echo "Not found, installing teapop.passwd"; \
- ${INSTALL} -d ${sysconfdir}; \
- ${INSTALL} teapop.passwd ${sysconfdir}; \
- ${CHMOD} 0644 ${sysconfdir}/teapop.passwd; \
- fi
+ ${BSD_INSTALL_DATA_DIR} ${prefix}/share/examples/teapop
+ ${BSD_INSTALL_DATA} teapop.passwd ${prefix}/share/examples/teapop
makefile: ../config/timestamp
@ echo Updating Makefile