Update mksh to R48b.

Changes:

R48b is a minor bugfix update:

[tg] Fix display issue with multi-line prompts and SIGWINCH

R48 is a small but important bugfix update:

[tg] dot.mkshrc: unbreak hd(1) function in UTF-8 mode
[Jens Staal, tg] Improve buildability on Plan 9 and support kencc
[tg] Clean up and improve build process and testsuite
[Michael Langguth] Add multi-layer ICO file from mksh/Win32
[tg, Steffen Daode Nurpmeso] Fix interactive shell exiting on ^C or
syntax error when the EXIT pseudo-signal trap was set (to anything)
[tg, Daode] Display longer command excerpts in job control
[tg] Rewrite Emacs mode display window sliding calculation code
[tg] dot.mkshrc: “doch” now keeps standard input
[tg] Reduce memory usage and improve comments and documentation

R47 is a bugfix everyone must upgrade to:

[tg] Do not accidentally remove lksh.1 for in-srcdir builds
[tg] Fix post-build non-‘-Q’ output for lksh
[tg] Silence some configure-time warnings for clang-3.2 and GCC
[tg] Prevent recursion loops for namerefs; found by ormaaj
[tg] Replace wcwidth code by mine based on Unicode 6.2.0
[tg, Alexander Polakov] Fix quoting in word part of ${var+word} etc.
when the expression is in a quoted brace or a here document
[tg] Fix some compiler warnings; improve sig{,handler}_t detection
[tg] Keep SIGCHLD blocked in some more semi-critical code paths
[tg] Fix uninitialised variable causing random nōn-numerical input to be
accepted and acted upon in the select built-in command
[tg] No longer chown(2)/chmod(2) the -T tty(4) argument
[tg] Don’t fork(2) if the -T tty(4) argument begins with ‘!’; eliminates
the need for things like oneit_line/cttyhack/etc. on Linux
[jca] Fix “for var in; do” to not be interpreted as “for var; do”
[tg] Use %zu for printing size_t (ipv %lu with casting around)
[tg] use ${SIZE-size} for lewellyn’s cross
[fgsch, espie, millert, tg] Write more testcases
[millert] POSIX specifies that for && and || lists, only the exit status
of the last command matters for “set -e”; fix and document
[millert] check.pl: Add -T flag to set the tmpdir; use mkstemp(3) and
mkdtemp(3) instead of $$ in /tmp for tempfiles
[jca] Make $(<nonexistent) behave like $(cat nonexistent)
[tg] Let shf_open return an errno; display why file wasn’t read
[tg] Finally decide on regression-39 desired outcome (sync with AT&T
ksh93 and GNU bash --posix as well as mksh behaviour)
[tg] Fix post{in,de}crement in not evaluated side of e.g. ternary operator (LP#1187729)
[tg] Fix “set -x” problems; add “set +o inherit-xtrace” (LP#1179287)
[tg] Simplify some code
[tg] Fix segfault related to mixing funsub/valsub and comsub

R46 delivers these changes:

[tg] dot.mkshrc: prevent lksh from running it
[tg] Add the lksh manual page to the mksh distribution
[tg] Make both lksh and mksh interpret numbers with a leading digit zero
(‘0’) as octal precisely iff “set -o posix” is active
[tg] Point out the octal digit and the integer arithmetic differences
from POSuX verbosely in the manual pages (point people who need octals
to “set -o posix” and who need longs to lksh) and elaborate on the
horrors of ISO C Undefined Behaviour which is allowed to delete all your
data
[tg] Unbreak “set -o” (list flags) in lksh on LP64 machines
[tg] Implement Emacs mode PgUp as Vi insert mode Cur↑ for Yofuh
[tg] Allow setting both “set -o sh” and “set -o posix”, if done in the
same command; shuffle around compatibility levels (mksh/lksh, with -o
sh, with -o posix) again; permit a /bin/sh to set either or both
[tg] Sync lksh manual page with the exact code ifdefs
[tg] Change more use of signed integer to use unsigned instead
[tg] Implement “set -o pipefail” like AT&T ksh93 and GNU bash do
[tg] dot.mkshrc: provide hd(1) in Pure mksh™ for fallback
[tg] Implement VALSUBs (value substitutions): ${|REPLY=foo;}
This commit is contained in:
bsiegert 2013-08-18 10:00:12 +00:00
parent 6640ae303e
commit d14aaec565
3 changed files with 18 additions and 28 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.24 2013/05/31 12:41:58 wiz Exp $
# $NetBSD: Makefile,v 1.25 2013/08/18 10:00:12 bsiegert Exp $
DISTNAME= mksh-R45
DISTNAME= mksh-R48b
PKGNAME= ${DISTNAME:S/-R/-/}
PKGREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://www.mirbsd.org/MirOS/dist/mir/mksh/ \
http://pub.allbsd.org/MirOS/dist/mir/mksh/

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.22 2013/04/30 17:58:44 bsiegert Exp $
$NetBSD: distinfo,v 1.23 2013/08/18 10:00:12 bsiegert Exp $
SHA1 (mksh-R45.tgz) = 1a870bfb9278be3eb40b39b69829fe905f0ca812
RMD160 (mksh-R45.tgz) = b376357d4aacade3fa888f78b6257ec76affb608
Size (mksh-R45.tgz) = 346164 bytes
SHA1 (patch-mksh.1) = c6b3e16c0c4d32377f52f508f0b6632dc201173d
SHA1 (mksh-R48b.tgz) = 118ac3e920e6b440907b2879eff6017d7e23bbab
RMD160 (mksh-R48b.tgz) = f88dda7604198bb17a5b23081e5b95921cf22d94
Size (mksh-R48b.tgz) = 362969 bytes
SHA1 (patch-mksh.1) = a8c03c29b41a48f731012c4612e44ce61a27675b

View file

@ -1,12 +1,13 @@
$NetBSD: patch-mksh.1,v 1.3 2013/04/30 17:58:44 bsiegert Exp $
$NetBSD: patch-mksh.1,v 1.4 2013/08/18 10:00:12 bsiegert Exp $
Kill the .Dt override and restore installation a normal man page.
--- mksh.1.orig 2013-04-26 21:23:12.000000000 +0000
--- mksh.1.orig 2013-08-10 14:12:04.000000000 +0000
+++ mksh.1
@@ -60,31 +60,11 @@
@@ -59,22 +59,7 @@
. ds ha ^
. ds en \(em
.\}
.\"
-.\"
-.\" Implement .Dd with the Mdocdate RCS keyword
-.\"
-.rn Dd xD
@ -17,22 +18,12 @@ Kill the .Dt override and restore installation a normal man page.
-.el .xD \\$1 \\$2 \\$3 \\$4 \\$5 \\$6 \\$7 \\$8
-..
-.\"
.\" .Dd must come before definition of .Mx, because when called
.\" with -mandoc, it might implement .Mx itself, but we want to
.\" use our own definition. And .Dd must come *first*, always.
.\"
-.Dd $Mdocdate: April 26 2013 $
-.\" .Dd must come before definition of .Mx, because when called
-.\" with -mandoc, it might implement .Mx itself, but we want to
-.\" use our own definition. And .Dd must come *first*, always.
-.\"
-.\" Check which macro package we use, and do other -mdoc setup.
-.\"
-.ie \n(.g \{\
-. if \*[.T]utf8 .tr \[la]\*(Lt
-. if \*[.T]utf8 .tr \[ra]\*(Gt
-. ie d volume-ds-1 .ds tT gnu
-. el .ds tT bsd
-.\}
-.el .ds tT ucb
+.Dd April 26, 2013
-.Dd $Mdocdate: August 10 2013 $
+.Dd August 10 2013
.\"
.\" Implement .Mx (MirBSD)
.\" Check which macro package we use, and do other -mdoc setup.
.\"