Initial import of xdkcal version 0.9d:

X Desktop Calendar (xdkcal) is a calendar for the X Window System: it simply
draws a calendar on your desktop.  You can customize its fontset, its color
and/or its drawing style.  This application is completely internationalized,
so that it reads the locale database and draws locale specific strings, such
as the name of months or weeks.

Package provided by Mike M. Volokhov in pkgsrc-wip.
This commit is contained in:
jmmv 2004-07-13 10:58:28 +00:00
parent ea88535db7
commit d1512f1789
5 changed files with 63 additions and 0 deletions

5
time/xdkcal/DESCR Normal file
View file

@ -0,0 +1,5 @@
X Desktop Calendar (xdkcal) is a calendar for the X Window System: it simply
draws a calendar on your desktop. You can customize its fontset, its color
and/or its drawing style. This application is completely internationalized,
so that it reads the locale database and draws locale specific strings, such
as the name of months or weeks.

24
time/xdkcal/Makefile Normal file
View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/07/13 10:58:28 jmmv Exp $
#
DISTNAME= xdkcal-0.9d
CATEGORIES= time
MASTER_SITES= http://www.shiratori.riec.tohoku.ac.jp/~jir/linux/products/xdkcal/
MAINTAINER= mishka@apk.od.ua
HOMEPAGE= http://www.shiratori.riec.tohoku.ac.jp/~jir/linux/products/xdkcal/index-e.html
COMMENT= X Desktop Calendar
PKG_INSTALLATION_TYPES= overwrite pkgviews
GNU_CONFIGURE= yes
USE_BUILDLINK3= yes
USE_X11= yes
INSTALLATION_DIRS= bin man/man1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xdkcal ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xdkcal.1x ${PREFIX}/man/man1/xdkcal.1
.include "../../mk/bsd.pkg.mk"

3
time/xdkcal/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/07/13 10:58:28 jmmv Exp $
bin/xdkcal
man/man1/xdkcal.1

5
time/xdkcal/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/07/13 10:58:28 jmmv Exp $
SHA1 (xdkcal-0.9d.tar.gz) = 8ac5a63170b90d77f22569eecb5592177c06365e
Size (xdkcal-0.9d.tar.gz) = 48533 bytes
SHA1 (patch-aa) = d497a13d636b54ad779ad1aceb2a3e97a3ac5b61

View file

@ -0,0 +1,26 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/07/13 10:58:29 jmmv Exp $
--- xdkcal.c.orig 2000-02-24 14:11:20.000000000 +0200
+++ xdkcal.c
@@ -218,9 +218,9 @@ int read_property()
void short_usage()
{
fprintf(stderr,
-"Usage: %s [-h][-x window_x][-y window_y][-f fontset][-C default_color]
- [-H holiday_color][-T today_color][-M month_color][-t on/off]
- [-p padding][-s style_num][-m on/off][-y on/off]
+"Usage: %s [-h][-x window_x][-y window_y][-f fontset][-C default_color]\n\
+ [-H holiday_color][-T today_color][-M month_color][-t on/off]\n\
+ [-p padding][-s style_num][-m on/off][-y on/off]\n\
[-n num_week] [month [year]]\n",PACKAGE);
}
@@ -283,7 +283,7 @@ void init_args(int argc, char *argv[])
while(1)
{
- c = getopt_long_only(argc,argv,
+ c = getopt_long(argc,argv,
"hx:y:f:C:H:S:T:M:t:p:s:m:w:n:Nv",
long_opts,&opt_index);
if(c == -1)