Fix inline use.

This commit is contained in:
joerg 2013-02-26 11:10:28 +00:00
parent ac89b8007e
commit d153a79744
6 changed files with 135 additions and 4 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2005/02/25 18:15:30 drochner Exp $
$NetBSD: distinfo,v 1.2 2013/02/26 11:12:19 joerg Exp $
SHA1 (gimp2-wideangle-1.0/wideangle.c) = efd544d6925cddd27cfe8d36f5ceaa5864a52c8d
RMD160 (gimp2-wideangle-1.0/wideangle.c) = 058bfdaab0b6c9f7ec19aafd8ba538827671e16a
Size (gimp2-wideangle-1.0/wideangle.c) = 33758 bytes
SHA1 (patch-wideangle.c) = e6b50038f9b1cf43c4b060b9a04bef3278db65e4

View file

@ -0,0 +1,13 @@
$NetBSD: patch-wideangle.c,v 1.1 2013/02/26 11:12:19 joerg Exp $
--- wideangle.c.orig 2013-02-25 18:05:56.000000000 +0000
+++ wideangle.c
@@ -469,7 +469,7 @@ pixelAccessDelete(PixelAccess* pa)
g_free(pa);
}
-inline guchar*
+static inline guchar*
pixelAccessAddress(PixelAccess* pa, int i, int j)
{
return pa->buffer[0] + pa->depth * (pa->width * (j + 1 - pa->tileMinY[0]) + (i + 1 - pa->tileMinX[0]));

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.3 2012/10/06 14:11:18 asau Exp $
# $NetBSD: Makefile,v 1.4 2013/02/26 11:10:28 joerg Exp $
#
DISTNAME= quesoglc-0.7.1-free
PKGNAME= ${DISTNAME:S/-free$//}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=quesoglc/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2009/02/15 16:03:46 jmcneill Exp $
$NetBSD: distinfo,v 1.2 2013/02/26 11:10:28 joerg Exp $
SHA1 (quesoglc-0.7.1-free.tar.bz2) = b8a30d69816612d19a968772f528d512ad0947f5
RMD160 (quesoglc-0.7.1-free.tar.bz2) = d9405e0d57ee5c2bfb7f9b256ea1d47bd2f767c0
Size (quesoglc-0.7.1-free.tar.bz2) = 641475 bytes
SHA1 (patch-src_ofont.c) = 5e3b4604c327fe186c02144d6c831253beadce7f
SHA1 (patch-src_ofont.h) = c8ff08d3bc4fb13a44ab7e2534689d05ef668c06

View file

@ -0,0 +1,67 @@
$NetBSD: patch-src_ofont.c,v 1.1 2013/02/26 11:10:28 joerg Exp $
--- src/ofont.c.orig 2013-02-25 16:31:40.000000000 +0000
+++ src/ofont.c
@@ -284,7 +284,7 @@ GLboolean __glcFontFace(__GLCfont* This,
#ifndef GLC_FT_CACHE
/* Open the font file */
-inline void* __glcFontOpen(__GLCfont* This, __GLCcontext* inContext)
+void* __glcFontOpen(__GLCfont* This, __GLCcontext* inContext)
{
return __glcFaceDescOpen(This->faceDesc, inContext);
}
@@ -292,7 +292,7 @@ inline void* __glcFontOpen(__GLCfont* Th
/* Close the font file */
-inline void __glcFontClose(__GLCfont* This)
+void __glcFontClose(__GLCfont* This)
{
__glcFaceDescClose(This->faceDesc);
}
@@ -321,7 +321,7 @@ GLboolean __glcFontPrepareGlyph(__GLCfon
/* Get the size of the bitmap in which the glyph will be rendered */
-inline GLboolean __glcFontGetBitmapSize(__GLCfont* This, GLint* outWidth,
+GLboolean __glcFontGetBitmapSize(__GLCfont* This, GLint* outWidth,
GLint *outHeight, GLint* outBoundingBox,
GLfloat inScaleX, GLfloat inScaleY,
int inFactor, __GLCcontext* inContext)
@@ -336,7 +336,7 @@ inline GLboolean __glcFontGetBitmapSize(
/* Get the maximum metrics of a face that is the bounding box that encloses
* every glyph of the face, and the maximum advance of the face.
*/
-inline GLfloat* __glcFontGetMaxMetric(__GLCfont* This, GLfloat* outVec,
+GLfloat* __glcFontGetMaxMetric(__GLCfont* This, GLfloat* outVec,
__GLCcontext* inContext)
{
return __glcFaceDescGetMaxMetric(This->faceDesc, outVec, inContext);
@@ -345,7 +345,7 @@ inline GLfloat* __glcFontGetMaxMetric(__
/* Decompose the outline of a glyph */
-inline GLboolean __glcFontOutlineDecompose(__GLCfont* This,
+GLboolean __glcFontOutlineDecompose(__GLCfont* This,
__GLCrendererData* inData,
__GLCcontext* inContext)
{
@@ -355,7 +355,7 @@ inline GLboolean __glcFontOutlineDecompo
/* Render the glyph in a bitmap */
-inline GLboolean __glcFontGetBitmap(__GLCfont* This, GLint inWidth,
+GLboolean __glcFontGetBitmap(__GLCfont* This, GLint inWidth,
GLint inHeight, void* inBuffer,
__GLCcontext* inContext)
{
@@ -368,7 +368,7 @@ inline GLboolean __glcFontGetBitmap(__GL
/* Chek if the outline of the glyph is empty (which means it is a spacing
* character).
*/
-inline GLboolean __glcFontOutlineEmpty(__GLCfont* This, __GLCcontext* inContext)
+GLboolean __glcFontOutlineEmpty(__GLCfont* This, __GLCcontext* inContext)
{
return __glcFaceDescOutlineEmpty(This->faceDesc, inContext);
}

View file

@ -0,0 +1,48 @@
$NetBSD: patch-src_ofont.h,v 1.1 2013/02/26 11:10:28 joerg Exp $
--- src/ofont.h.orig 2013-02-25 16:31:17.000000000 +0000
+++ src/ofont.h
@@ -27,11 +27,6 @@
#include "ofacedesc.h"
-/* It seems that Visual C++ does not recognize the inline keyword !?! */
-#ifdef _MSC_VER
-#define inline
-#endif
-
struct __GLCfontRec {
GLint id;
__GLCfaceDescriptor* faceDesc;
@@ -54,24 +49,24 @@ GLfloat* __glcFontGetKerning(__GLCfont*
GLfloat* outVec, __GLCcontext* inContext,
GLfloat inScaleX, GLfloat inScaleY);
#ifndef GLC_FT_CACHE
-inline void* __glcFontOpen(__GLCfont* This, __GLCcontext* inContext);
-inline void __glcFontClose(__GLCfont* This);
+void* __glcFontOpen(__GLCfont* This, __GLCcontext* inContext);
+void __glcFontClose(__GLCfont* This);
#endif
GLboolean __glcFontPrepareGlyph(__GLCfont* This, __GLCcontext* inContext,
GLfloat inScaleX, GLfloat inScaleY,
GLCulong inGlyphIndex);
-inline GLboolean __glcFontGetBitmapSize(__GLCfont* This, GLint* outWidth,
+GLboolean __glcFontGetBitmapSize(__GLCfont* This, GLint* outWidth,
GLint *outHeight, GLint* outBoundingBox,
GLfloat inScaleX, GLfloat inScaleY,
int inFactor, __GLCcontext* inContext);
-inline GLfloat* __glcFontGetMaxMetric(__GLCfont* This, GLfloat* outVec,
+GLfloat* __glcFontGetMaxMetric(__GLCfont* This, GLfloat* outVec,
__GLCcontext* inContext);
-inline GLboolean __glcFontOutlineDecompose(__GLCfont* This,
+GLboolean __glcFontOutlineDecompose(__GLCfont* This,
__GLCrendererData* inData,
__GLCcontext* inContext);
-inline GLboolean __glcFontGetBitmap(__GLCfont* This, GLint inWidth,
+GLboolean __glcFontGetBitmap(__GLCfont* This, GLint inWidth,
GLint inHeight, void* inBuffer,
__GLCcontext* inContext);
-inline GLboolean __glcFontOutlineEmpty(__GLCfont* This,
+GLboolean __glcFontOutlineEmpty(__GLCfont* This,
__GLCcontext* inContext);
#endif /* __glc_ofont_h */