Update from version 3.0.8nb1 to 3.0.8nb2.
Pkgsrc changes: o Add portability to the various mips-based NetBSD ports. The self-tests even complete without any unexpected failures.
This commit is contained in:
parent
a74f460e57
commit
d184389d51
6 changed files with 82 additions and 6 deletions
|
@ -1,14 +1,15 @@
|
|||
# $NetBSD: Makefile,v 1.10 2009/04/17 22:45:52 rh Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2009/05/26 12:27:12 he Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libffi-3.0.8
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://sourceware.org/pub/libffi/
|
||||
|
||||
MAINTAINER= asau@inbox.ru
|
||||
HOMEPAGE= http://sources.redhat.com/libffi/
|
||||
COMMENT= Foreign function interface
|
||||
LICENSE= mit
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
|
|
|
@ -1,8 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.11 2009/04/17 22:45:52 rh Exp $
|
||||
$NetBSD: distinfo,v 1.12 2009/05/26 12:27:12 he Exp $
|
||||
|
||||
SHA1 (libffi-3.0.8.tar.gz) = ce44d10c39d9a37479c8777e206cac0f36c48712
|
||||
RMD160 (libffi-3.0.8.tar.gz) = 4144f64e79ebf95161a6afd58ceaeef8372b5e57
|
||||
Size (libffi-3.0.8.tar.gz) = 722834 bytes
|
||||
SHA1 (patch-aa) = c15f4b7838ff7f4838de2981a5f3681a43a99503
|
||||
SHA1 (patch-aa) = 6020adaf5c9ab0f6de94f930214fa1d726fe8717
|
||||
SHA1 (patch-ac) = 307c08e8e3df5f079c0b2f63da58bb59fc089d30
|
||||
SHA1 (patch-ad) = 8901a00abe25422e3e35f321a5fb89311185fc0b
|
||||
SHA1 (patch-ae) = d3cbb4e3e00e0b7ced9cd50198da0772f6c73111
|
||||
SHA1 (patch-af) = daa640516b837ffeb925b2b3b97a5d75d5156165
|
||||
SHA1 (patch-ag) = 6333317170f6e92f89db966315276dcd8e3484f2
|
||||
|
|
|
@ -1,7 +1,18 @@
|
|||
$NetBSD: patch-aa,v 1.7 2009/04/17 22:45:52 rh Exp $
|
||||
$NetBSD: patch-aa,v 1.8 2009/05/26 12:27:12 he Exp $
|
||||
|
||||
--- configure.orig 2008-12-20 02:12:45.000000000 +1000
|
||||
Extend which ports we accept to deal with.
|
||||
|
||||
--- configure.orig 2008-12-19 17:12:45.000000000 +0100
|
||||
+++ configure
|
||||
@@ -21017,7 +21017,7 @@ case "$host" in
|
||||
mips-sgi-irix5.* | mips-sgi-irix6.*)
|
||||
TARGET=MIPS; TARGETDIR=mips
|
||||
;;
|
||||
- mips*-*-linux*)
|
||||
+ mips*-*-linux* | mips*-*-netbsd*)
|
||||
TARGET=MIPS; TARGETDIR=mips
|
||||
;;
|
||||
|
||||
@@ -21033,7 +21033,7 @@ case "$host" in
|
||||
powerpc-*-aix* | rs6000-*-aix*)
|
||||
TARGET=POWERPC_AIX; TARGETDIR=powerpc
|
||||
|
|
18
devel/libffi/patches/patch-ae
Normal file
18
devel/libffi/patches/patch-ae
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-ae,v 1.1 2009/05/26 12:27:12 he Exp $
|
||||
|
||||
Make a minimal adjustment to support the various NetBSD mips ports.
|
||||
|
||||
--- src/mips/ffitarget.h.orig 2008-02-15 19:43:40.000000000 +0100
|
||||
+++ src/mips/ffitarget.h
|
||||
@@ -39,6 +39,11 @@
|
||||
# define _ABIO32 _MIPS_SIM_ABI32
|
||||
# endif
|
||||
#endif
|
||||
+#ifdef __NetBSD__
|
||||
+/* Let's cheat a bit... */
|
||||
+# define _ABIO32 1
|
||||
+# define _MIPS_SIM _ABIO32
|
||||
+#endif
|
||||
|
||||
#if !defined(_MIPS_SIM)
|
||||
-- something is very wrong --
|
28
devel/libffi/patches/patch-af
Normal file
28
devel/libffi/patches/patch-af
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-af,v 1.1 2009/05/26 12:27:12 he Exp $
|
||||
|
||||
Fixes to support the various NetBSD mips ports.
|
||||
|
||||
--- src/mips/ffi.c.orig 2008-02-26 18:34:36.000000000 +0100
|
||||
+++ src/mips/ffi.c
|
||||
@@ -32,12 +32,19 @@
|
||||
|
||||
#ifdef __GNUC__
|
||||
# if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 3))
|
||||
-# define USE__BUILTIN___CLEAR_CACHE 1
|
||||
+# if !defined(__NetBSD__)
|
||||
+# define USE__BUILTIN___CLEAR_CACHE 1
|
||||
+# endif
|
||||
# endif
|
||||
#endif
|
||||
|
||||
#ifndef USE__BUILTIN___CLEAR_CACHE
|
||||
-#include <sys/cachectl.h>
|
||||
+# if !defined(__NetBSD__)
|
||||
+# include <sys/cachectl.h>
|
||||
+# else
|
||||
+# include <mips/cachectl.h>
|
||||
+# define cacheflush _cacheflush
|
||||
+# endif
|
||||
#endif
|
||||
|
||||
#ifdef FFI_DEBUG
|
15
devel/libffi/patches/patch-ag
Normal file
15
devel/libffi/patches/patch-ag
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ag,v 1.1 2009/05/26 12:27:12 he Exp $
|
||||
|
||||
The %Lf printf format expects "long double", so cast args accordingly.
|
||||
|
||||
--- testsuite/libffi.call/float2.c.orig 2008-01-29 16:15:20.000000000 +0100
|
||||
+++ testsuite/libffi.call/float2.c
|
||||
@@ -44,7 +44,7 @@ int main (void)
|
||||
/* This is ifdef'd out for now. long double support under SunOS/gcc
|
||||
is pretty much non-existent. You'll get the odd bus error in library
|
||||
routines like printf(). */
|
||||
- printf ("%Lf, %Lf, %Lf, %Lf\n", ld, ldblit(f), ld - ldblit(f), LDBL_EPSILON);
|
||||
+ printf ("%Lf, %Lf, %Lf, %Lf\n", (long double)ld, (long double)ldblit(f), (long double)(ld - ldblit(f)), (long double)LDBL_EPSILON);
|
||||
#endif
|
||||
|
||||
/* These are not always the same!! Check for a reasonable delta */
|
Loading…
Reference in a new issue