OpenDKIM is an open source implementation of the DKIM (Domain Keys Identified

Mail) sender authentication system proposed by the E-mail Signing Technology
Group (ESTG), now standardized by the IETF (RFC4871). It also includes
implementations of the Author Domain Signing Practises (ADSP, RFC5617) and
Vouch By Reference (VBR, RFC5518) proposed standards.

The project started from a code fork of version 2.8.3 of the open source
dkim-milter package developed and maintained by Sendmail, Inc.
This commit is contained in:
pettai 2010-10-19 23:11:42 +00:00
parent 4bc357d9c1
commit d1d0e59c74
10 changed files with 314 additions and 0 deletions

8
mail/opendkim/DESCR Normal file
View file

@ -0,0 +1,8 @@
OpenDKIM is an open source implementation of the DKIM (Domain Keys Identified
Mail) sender authentication system proposed by the E-mail Signing Technology
Group (ESTG), now standardized by the IETF (RFC4871). It also includes
implementations of the Author Domain Signing Practises (ADSP, RFC5617) and
Vouch By Reference (VBR, RFC5518) proposed standards.
The project started from a code fork of version 2.8.3 of the open source
dkim-milter package developed and maintained by Sendmail, Inc.

45
mail/opendkim/Makefile Normal file
View file

@ -0,0 +1,45 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/10/19 23:11:42 pettai Exp $
#
DISTNAME= opendkim-2.1.3
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=opendkim/}
MAINTAINER= pettai@NetBSD.org
HOMEPAGE= http://opendkim.org/
COMMENT= Open source DKIM library, MTA filter implementation and tools
LICENSE= sendmail-open-source-license
PKG_DESTDIR_SUPPORT= user-destdir
USE_TOOLS+= pkg-config
USE_LIBTOOL= yes
FILES_SUBST+= DKIM_USER=${DKIM_USER:Q} DKIM_GROUP=${DKIM_GROUP:Q}
BUILD_DEFS+= VARBASE DKIM_USER DKIM_GROUP
DKIM_USER?= opendkim
DKIM_GROUP?= opendkim
PKG_GROUPS= ${DKIM_USER}
PKG_USERS= ${DKIM_USER}:${DKIM_GROUP}
PKG_GROUPS_VARS+= DKIM_GROUP
PKG_USERS_VARS+= DKIM_USER
OWN_DIRS_PERMS+= ${VARBASE}/run/opendkim \
${DKIM_USER} ${DKIM_GROUP} 0750
PKGCONFIG_OVERRIDE+= libar/ar.pc.in
PKGCONFIG_OVERRIDE+= libopendkim/opendkim.pc.in
PKGCONFIG_OVERRIDE+= libvbr/vbr.pc.in
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
.include "options.mk"
PLIST_SRC+= ${PKGDIR}/PLIST
BUILDLINK_API_DEPENDS.openssl+= openssl>=0.9.8
.include "../../security/openssl/buildlink3.mk"
BUILDLINK_API_DEPENDS.libmilter+= libmilter>=8.13.0
.include "../../mail/libmilter/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

128
mail/opendkim/PLIST Normal file
View file

@ -0,0 +1,128 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/10/19 23:11:42 pettai Exp $
include/opendkim/dkim.h
lib/libopendkim.la
lib/pkgconfig/opendkim.pc
man/man8/opendkim-genkey.8
man/man8/opendkim-genzone.8
man/man8/opendkim-testadsp.8
man/man8/opendkim-testkey.8
sbin/opendkim-genkey.sh
sbin/opendkim-genzone
sbin/opendkim-testadsp
sbin/opendkim-testkey
share/doc/opendkim/FEATURES
share/doc/opendkim/KNOWNBUGS
share/doc/opendkim/LICENSE
share/doc/opendkim/LICENSE.Sendmail
share/doc/opendkim/README
share/doc/opendkim/RELEASE_NOTES.Sendmail
share/doc/opendkim/authheaders-check-setup-hook.lua
share/doc/opendkim/convert_keylist.sh
share/doc/opendkim/dkim.html
share/doc/opendkim/dkim_alg_t.html
share/doc/opendkim/dkim_body.html
share/doc/opendkim/dkim_canon_t.html
share/doc/opendkim/dkim_cbstat.html
share/doc/opendkim/dkim_chunk.html
share/doc/opendkim/dkim_close.html
share/doc/opendkim/dkim_diffheaders.html
share/doc/opendkim/dkim_dnssec.html
share/doc/opendkim/dkim_eoh.html
share/doc/opendkim/dkim_eom.html
share/doc/opendkim/dkim_flush_cache.html
share/doc/opendkim/dkim_free.html
share/doc/opendkim/dkim_get_msgdate.html
share/doc/opendkim/dkim_get_reputation.html
share/doc/opendkim/dkim_get_sigsubstring.html
share/doc/opendkim/dkim_get_user_context.html
share/doc/opendkim/dkim_getcachestats.html
share/doc/opendkim/dkim_getdomain.html
share/doc/opendkim/dkim_geterror.html
share/doc/opendkim/dkim_getmode.html
share/doc/opendkim/dkim_getpartial.html
share/doc/opendkim/dkim_getpolicystr.html
share/doc/opendkim/dkim_getpresult.html
share/doc/opendkim/dkim_getpresultstr.html
share/doc/opendkim/dkim_getresultstr.html
share/doc/opendkim/dkim_getsighdr.html
share/doc/opendkim/dkim_getsighdr_d.html
share/doc/opendkim/dkim_getsiglist.html
share/doc/opendkim/dkim_getsignature.html
share/doc/opendkim/dkim_header.html
share/doc/opendkim/dkim_init.html
share/doc/opendkim/dkim_key_syntax.html
share/doc/opendkim/dkim_lib.html
share/doc/opendkim/dkim_libfeature.html
share/doc/opendkim/dkim_libversion.html
share/doc/opendkim/dkim_mail_parse.html
share/doc/opendkim/dkim_minbody.html
share/doc/opendkim/dkim_ohdrs.html
share/doc/opendkim/dkim_options.html
share/doc/opendkim/dkim_param_t.html
share/doc/opendkim/dkim_policy.html
share/doc/opendkim/dkim_policy_getdnssec.html
share/doc/opendkim/dkim_policy_getreportinfo.html
share/doc/opendkim/dkim_policy_syntax.html
share/doc/opendkim/dkim_policy_t.html
share/doc/opendkim/dkim_presult.html
share/doc/opendkim/dkim_pstate.html
share/doc/opendkim/dkim_query_t.html
share/doc/opendkim/dkim_resign.html
share/doc/opendkim/dkim_set_dns_callback.html
share/doc/opendkim/dkim_set_final.html
share/doc/opendkim/dkim_set_key_lookup.html
share/doc/opendkim/dkim_set_margin.html
share/doc/opendkim/dkim_set_policy_lookup.html
share/doc/opendkim/dkim_set_prescreen.html
share/doc/opendkim/dkim_set_signature_handle.html
share/doc/opendkim/dkim_set_signature_handle_free.html
share/doc/opendkim/dkim_set_signature_tagvalues.html
share/doc/opendkim/dkim_set_signer.html
share/doc/opendkim/dkim_set_trust_anchor.html
share/doc/opendkim/dkim_set_user_context.html
share/doc/opendkim/dkim_setpartial.html
share/doc/opendkim/dkim_sig_getbh.html
share/doc/opendkim/dkim_sig_getcanonlen.html
share/doc/opendkim/dkim_sig_getcanons.html
share/doc/opendkim/dkim_sig_getcontext.html
share/doc/opendkim/dkim_sig_getdnssec.html
share/doc/opendkim/dkim_sig_getdomain.html
share/doc/opendkim/dkim_sig_geterror.html
share/doc/opendkim/dkim_sig_geterrorstr.html
share/doc/opendkim/dkim_sig_getflags.html
share/doc/opendkim/dkim_sig_getidentity.html
share/doc/opendkim/dkim_sig_getkeysize.html
share/doc/opendkim/dkim_sig_getreportinfo.html
share/doc/opendkim/dkim_sig_getselector.html
share/doc/opendkim/dkim_sig_getsignalg.html
share/doc/opendkim/dkim_sig_getsigntime.html
share/doc/opendkim/dkim_sig_gettagvalue.html
share/doc/opendkim/dkim_sig_hdrsigned.html
share/doc/opendkim/dkim_sig_ignore.html
share/doc/opendkim/dkim_sig_process.html
share/doc/opendkim/dkim_sig_syntax.html
share/doc/opendkim/dkim_sigerror.html
share/doc/opendkim/dkim_siginfo.html
share/doc/opendkim/dkim_sigkey_t.html
share/doc/opendkim/dkim_sign.html
share/doc/opendkim/dkim_ssl_version.html
share/doc/opendkim/dkim_stat.html
share/doc/opendkim/dkim_verify.html
share/doc/opendkim/draft-ietf-dkim-mailinglists-00.txt
share/doc/opendkim/draft-ietf-marf-base-06.txt
share/doc/opendkim/draft-ietf-marf-dkim-reporting-00.txt
share/doc/opendkim/draft-kucherawy-authres-header-b-04.txt
share/doc/opendkim/index.html
share/doc/opendkim/opendkim.init
share/doc/opendkim/opendkim.spec
share/doc/opendkim/overview.html
share/doc/opendkim/rfc4686.txt
share/doc/opendkim/rfc4871.txt
share/doc/opendkim/rfc5016.txt
share/doc/opendkim/rfc5451.txt
share/doc/opendkim/rfc5518.txt
share/doc/opendkim/rfc5585.txt
share/doc/opendkim/rfc5617.txt
share/doc/opendkim/rfc5672.txt
share/doc/opendkim/rfc5863.txt
share/examples/opendkim/opendkim.conf.sample

View file

@ -0,0 +1,5 @@
@comment $NetBSD: PLIST.filter,v 1.1.1.1 2010/10/19 23:11:42 pettai Exp $
man/man5/opendkim.conf.5
man/man8/opendkim.8
sbin/opendkim
share/examples/rc.d/opendkim

View file

@ -0,0 +1,6 @@
@comment $NetBSD: PLIST.stats,v 1.1.1.1 2010/10/19 23:11:42 pettai Exp $
man/man8/opendkim-importstats.8
man/man8/opendkim-stats.8
sbin/opendkim-importstats.sh
sbin/opendkim-stats
share/doc/opendkim/mkdb.mysql

4
mail/opendkim/PLIST.vbr Normal file
View file

@ -0,0 +1,4 @@
@comment $NetBSD: PLIST.vbr,v 1.1.1.1 2010/10/19 23:11:42 pettai Exp $
include/vbr/vbr.h
lib/libvbr.la
lib/pkgconfig/vbr.pc

6
mail/opendkim/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2010/10/19 23:11:42 pettai Exp $
SHA1 (opendkim-2.1.3.tar.gz) = 81911d2a2ff15f49c039b0c90d6209e5ec7f76a3
RMD160 (opendkim-2.1.3.tar.gz) = 09a215481eda0dee4f5248b1f1981ccf17f800f2
Size (opendkim-2.1.3.tar.gz) = 1011019 bytes
SHA1 (patch-aa) = 892ba5e6d7f40bf095e97d8538d63e598579f82c

View file

@ -0,0 +1,40 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: opendkim.sh,v 1.1.1.1 2010/10/19 23:11:42 pettai Exp $
#
# PROVIDE: opendkim
# REQUIRE: DAEMON
# BEFORE: mail
if [ -f /etc/rc.subr ]; then
. /etc/rc.subr
fi
name="opendkim"
rcvar=$name
command="@PREFIX@/sbin/opendkim"
pidfile="@VARBASE@/run/${name}.pid"
command_args="-P ${pidfile} -l -x @PKG_SYSCONFDIR@/opendkim.conf -u @DKIM_USER@:@DKIM_GROUP@"
required_files="@PKG_SYSCONFDIR@/opendkim.conf"
start_precmd="dkimfilter_precmd"
dkimfilter_precmd()
{
if [ ! -d @VARBASE@/run/opendkim ]; then
@MKDIR@ @VARBASE@/run/opendkim
@CHMOD@ 0750 @VARBASE@/run/opendkim
@CHOWN@ @DKIM_USER@:@DKIM_GROUP@ @VARBASE@/run/opendkim
fi
if [ -f @VARBASE@/run/opendkim/${name}.sock ]; then
@RM@ -f @VARBASE@/run/opendkim/${name}.sock
fi
}
if [ -f /etc/rc.subr ]; then
load_rc_config $name
run_rc_command "$1"
else
echo -n " ${name}"
${command} ${dkimfilter_flags} ${command_args}
fi

59
mail/opendkim/options.mk Normal file
View file

@ -0,0 +1,59 @@
# $NetBSD: options.mk,v 1.1.1.1 2010/10/19 23:11:42 pettai Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.opendkim
PKG_SUPPORTED_OPTIONS= filter debug dkim-stats vbr
PKG_SUGGESTED_OPTIONS= filter
.include "../../mk/bsd.options.mk"
###
### Debug support
###
.if !empty(PKG_OPTIONS:Mdebug)
CONFIGURE_ARGS+= --enable-debug
.else
CONFIGURE_ARGS+= --disable-debug
.endif
###
### Install filter (milter) plugin
###
.if !empty(PKG_OPTIONS:Mfilter)
EGDIR= ${PREFIX}/share/examples/opendkim
RCD_SCRIPTS= opendkim
CONFIGURE_ARGS+= --enable-filter
CONFIGURE_ARGS+= --with-milter=${PREFIX}
SUBST_CLASSES+= conf
SUBST_STAGE.conf= pre-configure
SUBST_FILES.conf= opendkim/Makefile.in
SUBST_SED.conf+= -e 's|@EGDIR@|${EGDIR}|g'
CONF_FILES= ${EGDIR}/opendkim.conf.sample \
${PKG_SYSCONFDIR}/opendkim.conf
PLIST_SRC+= ${PKGDIR}/PLIST.filter
.else
CONFIGURE_ARGS+= --disable-filter
.endif
###
### Build with VBR support
###
.if !empty(PKG_OPTIONS:Mvbr)
CONFIGURE_ARGS+= --enable-vbr
PLIST_SRC+= ${PKGDIR}/PLIST.vbr
.else
CONFIGURE_ARGS+= --disable-vbr
.endif
###
### Install stats which outputs opendkim statistics
###
.if !empty(PKG_OPTIONS:Mdkim-stats)
#.include "../../mk/db1.builtin.mk"
CONFIGURE_ARGS+= --enable-stats
PLIST_SRC+= ${PKGDIR}/PLIST.stats
.else
CONFIGURE_ARGS+= --disable-stats
.endif

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/10/19 23:11:42 pettai Exp $
--- opendkim/Makefile.in.orig 2010-10-18 11:31:04.000000000 +0000
+++ opendkim/Makefile.in
@@ -410,7 +410,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
@DEBUG_TRUE@AM_CFLAGS = -g
dist_sbin_SCRIPTS = opendkim-genkey.sh
-exampledir = $(docdir)
+exampledir = @EGDIR@
dist_example_DATA = opendkim.conf.sample
@BUILD_FILTER_TRUE@opendkim_SOURCES = opendkim.c opendkim.h opendkim-ar.c opendkim-ar.h opendkim-arf.c opendkim-arf.h opendkim-config.h opendkim-crypto.c opendkim-crypto.h opendkim-db.c opendkim-db.h opendkim-lua.c opendkim-lua.h config.c config.h stats.c stats.h test.c test.h util.c util.h
@BUILD_FILTER_TRUE@opendkim_CC = $(PTHREAD_CC)