Fix build on OS X 10.6.8, from <https://trac.macports.org/ticket/38588>.
This commit is contained in:
parent
fa4a4ac3d1
commit
d1df19989c
2 changed files with 30 additions and 1 deletions
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.20 2013/04/02 10:59:50 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.21 2013/04/07 04:00:39 schmonz Exp $
|
||||
|
||||
SHA1 (tmux-1.8.tar.gz) = 08677ea914e1973ce605b0008919717184cbd033
|
||||
RMD160 (tmux-1.8.tar.gz) = b267ab54f6f55292fa1fa9cd0e892bfd5fd27cfb
|
||||
Size (tmux-1.8.tar.gz) = 417537 bytes
|
||||
SHA1 (patch-client.c) = e37053d721bd26d31783af883a7d1f6870095325
|
||||
SHA1 (patch-osdep-darwin.c) = 259230c4437364fc3c956f2ab1429316e697d228
|
||||
SHA1 (patch-server-client.c) = 6c8dd82e2dc1965b8c8f9a8808a262366c80d6b4
|
||||
|
|
28
misc/tmux/patches/patch-osdep-darwin.c
Normal file
28
misc/tmux/patches/patch-osdep-darwin.c
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-osdep-darwin.c,v 1.1 2013/04/07 04:00:40 schmonz Exp $
|
||||
|
||||
Fix build on OS X 10.6.8, from <https://trac.macports.org/ticket/38588>.
|
||||
|
||||
--- osdep-darwin.c.orig 2013-02-24 12:42:49.000000000 +0000
|
||||
+++ osdep-darwin.c
|
||||
@@ -33,17 +33,17 @@ struct event_base *osdep_event_init(void
|
||||
char *
|
||||
osdep_get_name(int fd, unused char *tty)
|
||||
{
|
||||
- struct proc_bsdshortinfo bsdinfo;
|
||||
+ struct proc_bsdinfo bsdinfo;
|
||||
pid_t pgrp;
|
||||
int ret;
|
||||
|
||||
if ((pgrp = tcgetpgrp(fd)) == -1)
|
||||
return (NULL);
|
||||
|
||||
- ret = proc_pidinfo(pgrp, PROC_PIDT_SHORTBSDINFO, 0,
|
||||
+ ret = proc_pidinfo(pgrp, PROC_PIDTBSDINFO, 0,
|
||||
&bsdinfo, sizeof bsdinfo);
|
||||
- if (ret == sizeof bsdinfo && *bsdinfo.pbsi_comm != '\0')
|
||||
- return (strdup(bsdinfo.pbsi_comm));
|
||||
+ if (ret == sizeof bsdinfo && *bsdinfo.pbi_comm != '\0')
|
||||
+ return (strdup(bsdinfo.pbi_comm));
|
||||
return (NULL);
|
||||
}
|
||||
|
Loading…
Reference in a new issue