the -L and -P options to mkisofs are deprecated and have been removed,

add patch-ae to use the new names.

bump the PKG_REVISION

the previous version of cdrtools supported the new option names so no
change in dependency is needed.

update distinfo
This commit is contained in:
plunky 2007-08-15 18:34:59 +00:00
parent 67aa3c712f
commit d1ecfb2951
3 changed files with 26 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.46 2006/04/17 13:46:49 wiz Exp $
# $NetBSD: Makefile,v 1.47 2007/08/15 18:34:59 plunky Exp $
DISTNAME= xcdroast-${DIST_VER}
PKGNAME= xcdroast-${DIST_VER:S/alpha/a/}
PKGREVISION= 7
PKGREVISION= 8
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xcdroast/}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.14 2005/10/20 18:12:29 wiz Exp $
$NetBSD: distinfo,v 1.15 2007/08/15 18:34:59 plunky Exp $
SHA1 (xcdroast-0.98alpha15.tar.gz) = f354ea9ffe918c4ec11312d5537e6e245730fecc
RMD160 (xcdroast-0.98alpha15.tar.gz) = 9198f67659023ce8f508fa2c331df9d9c8b81a8f
@ -6,3 +6,4 @@ Size (xcdroast-0.98alpha15.tar.gz) = 3282794 bytes
SHA1 (patch-aa) = 0beee32a5550646cd360459d90281cb0ec9a826a
SHA1 (patch-ab) = 085da3b440ba1d6a0e305626e1ac3fba49d2f546
SHA1 (patch-ad) = 417a82344e14ae2a9f602254b152337c33afae4a
SHA1 (patch-ae) = 773d1a5b2b2ce5ef0a947cb5d7f67f83985b6e5e

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ae,v 1.5 2007/08/15 18:34:59 plunky Exp $
--- src/io.c.orig 2007-08-15 17:45:55.000000000 +0100
+++ src/io.c 2007-08-15 17:45:16.000000000 +0100
@@ -9026,7 +9026,7 @@
strcat(tmp2,"-D ");
}
if (masterparam.opt[7]) {
- strcat(tmp2,"-L ");
+ strcat(tmp2,"-allow-leading-dots ");
}
if (masterparam.opt[8]) {
strcat(tmp2,"-d ");
@@ -9160,7 +9160,7 @@
}
if (masterparam.publisher) {
strcpy(tmptmp, masterparam.publisher);
- g_snprintf(tmp5,MAXLINE,"-P \"%s\" ",
+ g_snprintf(tmp5,MAXLINE,"-publisher \"%s\" ",
convert_escape(tmptmp));
strcat(tmp4,tmp5);
}