Update gnapster to 1.3.10. Changes since 1.3.10:
* Browse server file syntax changed, old server files must be removed * Fixed new user creation bug and cleaned up the bind handling to not cause 100% cpu usage when something bad happened * Updated remotely queued code to better handle queued downloads * Switched over to using the XText widget from XChat * Implemented new opennap browse numeric support, will no longer get disconnected for browsing * Removed -O2 from Makefile due to GTK problems caused by older gcc versions (prevented / commands from working on certain systems) * Many minor UI changes and bug fixes
This commit is contained in:
parent
3e5370a3e7
commit
d1f631d183
7 changed files with 31 additions and 88 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.7 2000/05/26 15:34:37 hubertf Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2000/08/10 21:07:34 jlam Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gnapster-1.3.10
|
||||
DISTNAME= gnapster-1.3.11
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.faradic.net/~jasta/files/
|
||||
|
||||
|
@ -10,8 +10,13 @@ HOMEPAGE= http://www.faradic.net/~jasta/programs.html
|
|||
|
||||
DEPENDS+= gnome-core-*:../../x11/gnome-core
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_X11BASE= YES
|
||||
USE_GMAKE= YES
|
||||
USE_X11BASE= # defined
|
||||
USE_GMAKE= # defined
|
||||
|
||||
GNU_CONFIGURE= # defined
|
||||
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include # libintl.h
|
||||
CPPFLAGS+= -DUSE_IMLIB=1
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.7 2000/05/26 15:34:38 hubertf Exp $
|
||||
$NetBSD: md5,v 1.8 2000/08/10 21:07:35 jlam Exp $
|
||||
|
||||
MD5 (gnapster-1.3.10.tar.gz) = 111a58e306a2d3cf126b17ffd34c96c9
|
||||
MD5 (gnapster-1.3.11.tar.gz) = d1e0a09685ae7b766d4c78664a7ac30c
|
||||
|
|
|
@ -1,5 +1,4 @@
|
|||
$NetBSD: patch-sum,v 1.5 2000/03/16 01:36:06 wiz Exp $
|
||||
$NetBSD: patch-sum,v 1.6 2000/08/10 21:07:35 jlam Exp $
|
||||
|
||||
MD5 (patch-aa) = df5bb3daa1712bcd7d182262c5470179
|
||||
MD5 (patch-ac) = 0d3a4183419dda5a212357bb53f9d312
|
||||
MD5 (patch-ad) = 50f4fa40d35e563bb37b328d8b9b0ca9
|
||||
MD5 (patch-aa) = 56f13be0dc0854e5caab56cf6652fac0
|
||||
MD5 (patch-ab) = d2eb4059beb11922ace5551169fede34
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.4 2000/03/16 00:56:32 wiz Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2000/08/10 21:07:35 jlam Exp $
|
||||
|
||||
--- po/Makefile.in.in.orig Sun Feb 13 07:38:19 2000
|
||||
+++ po/Makefile.in.in Thu Mar 16 01:48:17 2000
|
||||
--- po/Makefile.in.in.orig Sun Feb 13 01:38:19 2000
|
||||
+++ po/Makefile.in.in Thu Aug 10 16:48:33 2000
|
||||
@@ -19,7 +19,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
|
|
13
net/gnapster/patches/patch-ab
Normal file
13
net/gnapster/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.4 2000/08/10 21:07:35 jlam Exp $
|
||||
|
||||
--- Makefile.in.orig Wed Aug 9 22:49:13 2000
|
||||
+++ Makefile.in Thu Aug 10 16:56:52 2000
|
||||
@@ -380,7 +380,7 @@
|
||||
@$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
|
||||
install: install-recursive
|
||||
@echo "*** Warning: backing up old shared file"
|
||||
- @mv -f $(HOME)/.gnapster/servers $(HOME)/.gnapster/servers.old
|
||||
+ @-mv -f $(HOME)/.gnapster/servers $(HOME)/.gnapster/servers.old
|
||||
uninstall-am: uninstall-ApplicationsDATA
|
||||
uninstall: uninstall-recursive
|
||||
all-am: Makefile $(DATA) config.h
|
|
@ -1,52 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2000/03/16 01:36:08 wiz Exp $
|
||||
|
||||
--- configure.orig Wed Feb 16 03:35:34 2000
|
||||
+++ configure Mon Feb 28 06:34:14 2000
|
||||
@@ -3658,36 +3658,8 @@
|
||||
nls_cv_header_libgt=
|
||||
CATOBJEXT=NONE
|
||||
|
||||
- ac_safe=`echo "libintl.h" | sed 'y%./+-%__p_%'`
|
||||
-echo $ac_n "checking for libintl.h""... $ac_c" 1>&6
|
||||
-echo "configure:3664: checking for libintl.h" >&5
|
||||
-if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
|
||||
- echo $ac_n "(cached) $ac_c" 1>&6
|
||||
-else
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 3669 "configure"
|
||||
-#include "confdefs.h"
|
||||
-#include <libintl.h>
|
||||
-EOF
|
||||
-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
-{ (eval echo configure:3674: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
-ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
||||
-if test -z "$ac_err"; then
|
||||
- rm -rf conftest*
|
||||
- eval "ac_cv_header_$ac_safe=yes"
|
||||
-else
|
||||
- echo "$ac_err" >&5
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- eval "ac_cv_header_$ac_safe=no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
-fi
|
||||
-if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
|
||||
- echo "$ac_t""yes" 1>&6
|
||||
- echo $ac_n "checking for gettext in libc""... $ac_c" 1>&6
|
||||
-echo "configure:3691: checking for gettext in libc" >&5
|
||||
+ echo $ac_n "checking for gettext in libc""... $ac_c" 1>&6
|
||||
+echo "configure:3663: checking for gettext in libc" >&5
|
||||
if eval "test \"`echo '$''{'gt_cv_func_gettext_libc'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
@@ -4000,8 +3972,3 @@
|
||||
INTLLIBS=-lintl
|
||||
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
|
||||
fi
|
||||
-
|
||||
-else
|
||||
- echo "$ac_t""no" 1>&6
|
||||
-fi
|
||||
-
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2000/03/16 01:36:08 wiz Exp $
|
||||
|
||||
--- aclocal.m4.orig Sun Feb 13 07:38:19 2000
|
||||
+++ aclocal.m4 Mon Feb 28 06:34:09 2000
|
||||
@@ -1230,8 +1230,7 @@
|
||||
nls_cv_header_libgt=
|
||||
CATOBJEXT=NONE
|
||||
|
||||
- AC_CHECK_HEADER(libintl.h,
|
||||
- [AC_CACHE_CHECK([for gettext in libc], gt_cv_func_gettext_libc,
|
||||
+ AC_CACHE_CHECK([for gettext in libc], gt_cv_func_gettext_libc,
|
||||
[AC_TRY_LINK([#include <libintl.h>], [return (int) gettext ("")],
|
||||
gt_cv_func_gettext_libc=yes, gt_cv_func_gettext_libc=no)])
|
||||
|
||||
@@ -1271,7 +1270,6 @@
|
||||
INTLLIBS=-lintl
|
||||
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
|
||||
fi
|
||||
- ])
|
||||
|
||||
if test "$CATOBJEXT" = "NONE"; then
|
||||
AC_MSG_CHECKING([whether catgets can be used])
|
Loading…
Reference in a new issue