Update to grap-1.41. Summary of changes:
1.41: fix gcc-4.1/4.2 builds problems (this should include PR pkg/34378) 1.40: fixes regressions from 1.38 1.39: gcc-4.1 fixes 1.38: DESTDIR support (also enbled in pkgsrc) 1.37: fixes an EOF bug 1.36: grammar fixes 1.35: lex fixes 1.32: fixes parsing of color modifiers
This commit is contained in:
parent
124723b3de
commit
d244221946
4 changed files with 18 additions and 32 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.14 2006/12/10 04:53:24 smb Exp $
|
||||
# $NetBSD: Makefile,v 1.15 2007/12/22 19:42:01 tnn Exp $
|
||||
|
||||
DISTNAME= grap-1.30
|
||||
PKGREVISION= 2
|
||||
DISTNAME= grap-1.41
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.lunabase.org/~faber/Vault/software/grap/
|
||||
|
||||
|
@ -10,6 +9,7 @@ HOMEPAGE= http://www.lunabase.org/~faber/Vault/software/grap/
|
|||
COMMENT= Language for typesetting graphs
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.10 2006/12/10 04:53:24 smb Exp $
|
||||
$NetBSD: distinfo,v 1.11 2007/12/22 19:42:01 tnn Exp $
|
||||
|
||||
SHA1 (grap-1.30.tar.gz) = d8083d75cc4ca7bbfcca1a0958e1da10e54f1c88
|
||||
RMD160 (grap-1.30.tar.gz) = 54c80386ad15f18a0b7e848adcb0eaa06861451b
|
||||
Size (grap-1.30.tar.gz) = 167462 bytes
|
||||
SHA1 (patch-aa) = a1663c1f761c21983b38f74a150fcc2c28ebc177
|
||||
SHA1 (grap-1.41.tar.gz) = 16225879a1a2e85abe53483254143b45f5ca92d4
|
||||
RMD160 (grap-1.41.tar.gz) = 02f683385af226f743bff074fcf2063a596f937b
|
||||
Size (grap-1.41.tar.gz) = 183947 bytes
|
||||
SHA1 (patch-aa) = 79ee9c5514fe8eb332630922336a927f2bbb88be
|
||||
SHA1 (patch-ab) = 20fca93edd15d4c1220b642671fb66fa2c40c2fe
|
||||
SHA1 (patch-ac) = abd8fef7dd04e58c5a408cc8dc73f43debe84f37
|
||||
SHA1 (patch-ad) = fdafc8d4e3a4ac2887b7cfcecddd7b9c2c4577c9
|
||||
SHA1 (patch-ae) = a6a11d1fc53385e0085b380485986bc317176b3b
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.3 2003/07/14 07:12:14 jtb Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2007/12/22 19:42:01 tnn Exp $
|
||||
|
||||
--- Makefile.in.orig 2003-07-14 07:47:06.000000000 +0100
|
||||
+++ Makefile.in 2003-07-14 07:48:40.000000000 +0100
|
||||
@@ -31,7 +31,8 @@
|
||||
--- Makefile.in.orig 2007-12-18 07:20:38.000000000 +0100
|
||||
+++ Makefile.in
|
||||
@@ -38,7 +38,8 @@ MKDEPFLAGS=@MKDEPFLAGS@;
|
||||
SOURCES=grap.cc grap_lex.cc *.cc
|
||||
DISTDIR=@PACKAGE_TARNAME@-@PACKAGE_VERSION@
|
||||
|
||||
|
@ -12,7 +12,7 @@ $NetBSD: patch-aa,v 1.3 2003/07/14 07:12:14 jtb Exp $
|
|||
|
||||
# To suppress optimization of certain files under g++ where
|
||||
# optimization is costly at compilation time and of minimial use at
|
||||
@@ -48,7 +49,7 @@
|
||||
@@ -55,7 +56,7 @@ SPOTLESSFILES=grap.1 grap.ps grap.man
|
||||
include Makefile.common
|
||||
|
||||
grap: ${OBJS}
|
||||
|
@ -21,7 +21,7 @@ $NetBSD: patch-aa,v 1.3 2003/07/14 07:12:14 jtb Exp $
|
|||
|
||||
.l.cc:
|
||||
${LEX} -o$@ $<
|
||||
@@ -67,7 +68,7 @@
|
||||
@@ -74,7 +75,7 @@ grap_lex.cc: grap_lex.l y.tab.h
|
||||
# that file under g++ by default. If --optimize-grap_tokenizer is
|
||||
# given to configure, no attempt to suppress optimization is made.
|
||||
grap_tokenizer.o: grap_tokenizer.cc
|
||||
|
@ -30,11 +30,11 @@ $NetBSD: patch-aa,v 1.3 2003/07/14 07:12:14 jtb Exp $
|
|||
|
||||
# flex defines an unused static function. This rule supresses that
|
||||
# warning under g++.
|
||||
@@ -89,7 +90,6 @@
|
||||
@@ -98,7 +99,6 @@ grap.1: grap.doc
|
||||
# The || true lines allow make to continue on systems where install -d
|
||||
# fails on existing directories.
|
||||
install: @INSTALL_DEPS@
|
||||
- strip grap || true
|
||||
${INSTALL} -d ${BINDIR} || true
|
||||
${INSTALL} -d ${MANDIR} || true
|
||||
${INSTALL} -d ${DEFINESDIR} || true
|
||||
${INSTALL} -d ${DESTDIR}${BINDIR} || true
|
||||
${INSTALL} -d ${DESTDIR}${MANDIR} || true
|
||||
${INSTALL} -d ${DESTDIR}${DEFINESDIR} || true
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1 2006/12/10 04:53:24 smb Exp $
|
||||
|
||||
--- grap_draw.h.orig 2006-12-09 23:47:30.000000000 -0500
|
||||
+++ grap_draw.h 2006-12-09 23:47:39.000000000 -0500
|
||||
@@ -239,7 +239,7 @@
|
||||
int yautoscale; // True if the user has not given an explicit y range
|
||||
string name; // Name of the coordinate system, if any
|
||||
|
||||
- void coord::newpt(double x, double y) {
|
||||
+ void newpt(double x, double y) {
|
||||
newx(x); newy(y);
|
||||
}
|
||||
void newx(double);
|
Loading…
Reference in a new issue