Convert to use buildlink.mk files and mark as USE_BUILDLINK_ONLY.

This commit is contained in:
jlam 2001-09-12 04:56:06 +00:00
parent 7d860ec6ee
commit d26ccfa60d
3 changed files with 8 additions and 39 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.3 2001/04/14 02:45:53 jtb Exp $
# $NetBSD: Makefile,v 1.4 2001/09/12 04:56:06 jlam Exp $
DISTNAME= mgv-3.1.5
CATEGORIES= print
@ -11,16 +11,17 @@ COMMENT= Motif/LessTif user interface for Ghostscript
DEPENDS+= ghostscript-[6-9]*:../../print/ghostscript
GNU_CONFIGURE= yes
USE_X11= yes
USE_MOTIF= yes
USE_XPM= yes
USE_BUILDLINK_ONLY= yes
CONFIGURE_ARGS+= --with-motif-includes=${MOTIFBASE}/include
CONFIGURE_ARGS+= --with-motif-libs=${MOTIFBASE}/lib
CONFIGURE_ARGS+= --with-motif-includes=${BUILDLINK_DIR}/include
CONFIGURE_ARGS+= --with-motif-libs=${BUILDLINK_DIR}/lib
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/*.gif ${PREFIX}/share/mgv/3.1.5/help
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/html
${LN} -fs ${PREFIX}/share/mgv/3.1.5/help ${PREFIX}/share/doc/html/mgv
.include "../../graphics/xpm/buildlink.mk"
.include "../../mk/motif.buildlink.mk"
.include "../../mk/x11.buildlink.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.2 2001/04/20 12:41:52 agc Exp $
$NetBSD: distinfo,v 1.3 2001/09/12 04:56:06 jlam Exp $
SHA1 (mgv-3.1.5.tar.gz) = 5500221347dabed04effea78b4ca5bf7c8ecc35a
Size (mgv-3.1.5.tar.gz) = 740150 bytes
SHA1 (patch-aa) = ecbc6b70f8ae07013a23b4db2decfe9e23204539
SHA1 (patch-ab) = 430fcefb48fbb1f432af4c32f4703787a27a48df
SHA1 (patch-ac) = edd2d6a0443dff4a5c225d0242ef16e73a32d243
SHA1 (patch-ad) = e067c1be2c4b0885f29a5230643e84fd08998e38

View file

@ -1,31 +0,0 @@
$NetBSD: patch-ac,v 1.1.1.1 2001/04/14 00:51:17 jtb Exp $
--- configure.orig Fri Apr 13 23:50:10 2001
+++ configure
@@ -1451,7 +1451,7 @@
# It would also be nice to do this for all -L options, not just this one.
if test -n "$x_libraries"; then
- X_LIBS="$X_LIBS -L$x_libraries"
+ X_LIBS="$X_LIBS -R$x_libraries -L$x_libraries"
# For Solaris; some versions of Sun CC require a space after -R and
# others require no space. Words are not sufficient . . . .
case "`(uname -sr) 2>/dev/null`" in
@@ -1986,7 +1986,7 @@
# Check for libraries that X11R6 Xt/Xaw programs need.
ac_save_LDFLAGS="$LDFLAGS"
- test -n "$x_libraries" && LDFLAGS="$LDFLAGS -L$x_libraries"
+ test -n "$x_libraries" && LDFLAGS="$LDFLAGS -R$x_libraries -L$x_libraries"
# SM needs ICE to (dynamically) link under SunOS 4.x (so we have to
# check for ICE first), but we must link in the order -lSM -lICE or
# we get undefined symbols. So assume we have SM if we have ICE.
@@ -2220,7 +2220,7 @@
if test "$motif_libraries" != "" && test "$motif_libraries" != "$x_libraries" && test "$motif_libraries" != "no"
then
case "$X_LIBS" in
- *-R\ *) X_LIBS="-L$motif_libraries -R $motif_libraries $X_LIBS";;
+ *-R\ *) X_LIBS="-L$motif_libraries -R$motif_libraries $X_LIBS";;
*-R*) X_LIBS="-L$motif_libraries -R$motif_libraries $X_LIBS";;
*) X_LIBS="-L$motif_libraries $X_LIBS";;
esac