Update to 2.1.4:

2.1.4 - December 12th, 2007 :
=============================
    * Added support of pictures in Ogg Vorbis and Speex files (with Ogg Vorbis
      tags),
    * Added support of pictures in FLAC files (with FLAC Vorbis tags).
    * The code for handling FLAC files was also fully rewritten,
    * Added view of tag fields in the main list of files,
    * Added a button on the main window to select a directory to browse for file
      (useful when the tree is hidden),
    * Fixed compilation problem with mpeg4ip 1.6 (thanks to Götz Waschk),
    * Fixed messages boxes to use the stock buttons and labels of GTK,
    * Fixed file easytag.desktop (thanks to Doruk Fisek and Götz Waschk),
    * Fixed problem with dates and EUC-JP locale when displaying lines on the
      log window (thanks to Misty Haiku),
    * Fixed problem with the Cddb manual search when using a proxy,
    * Fixed detection of Roman numerals before a coma and dot characters in the
      scanner window,
    * Settings to write ID3v1.x tags : the option "//TRANSLIT" was enabled by
      default to avoid an error message with UTF-8 strings. This was the setting
      used before using libid3tag instead of id3lib,
    * Fixed problem when reading tag with some languages as Turkish (patch from
      Doruk Fisek),
    * New Chinese (Taiwan) translation (thanks to Jose Sun),
    * Hungarian translation updated (thanks to Mészáros Csaba),
    * Chinese (Simplified) translation updated (thanks to Yang Jinsong),
    * German translation updated (thanks to Götz Waschk),
    * French translation updated.
This commit is contained in:
wiz 2008-01-13 15:28:32 +00:00
parent ffd1cd3b4c
commit d27762d445
5 changed files with 35 additions and 34 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.5 2007/11/22 19:23:23 drochner Exp $
# $NetBSD: Makefile,v 1.6 2008/01/13 15:28:32 wiz Exp $
#
DISTNAME= easytag-2.1.3
PKGREVISION= 1
DISTNAME= easytag-2.1.4
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=easytag/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2007/10/17 20:45:13 wiz Exp $
@comment $NetBSD: PLIST,v 1.3 2008/01/13 15:28:32 wiz Exp $
bin/easytag
man/man1/easytag.1
share/applications/easytag.desktop
@ -25,6 +25,7 @@ share/locale/sr@Latn/LC_MESSAGES/easytag.mo
share/locale/sv/LC_MESSAGES/easytag.mo
share/locale/uk/LC_MESSAGES/easytag.mo
share/locale/zh_CN/LC_MESSAGES/easytag.mo
share/locale/zh_TW/LC_MESSAGES/easytag.mo
share/pixmaps/EasyTAG_icon.xpm
@comment in xdg-dirs: @dirrm share/pixmaps
@dirrm share/easytag

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.5 2008/01/11 13:13:50 drochner Exp $
$NetBSD: distinfo,v 1.6 2008/01/13 15:28:32 wiz Exp $
SHA1 (easytag-2.1.3.tar.bz2) = 8be1f0f84fed9b9f3fe0f1f9770315744005905e
RMD160 (easytag-2.1.3.tar.bz2) = b6c0d4b204ff637c310775f174d6663ce1fe51bd
Size (easytag-2.1.3.tar.bz2) = 3101510 bytes
SHA1 (patch-aa) = bfb67a2d37317243f197f6a497fff67adf38df0b
SHA1 (patch-ab) = 90194dc5552d77cdcd1f86ff9775b75933008389
SHA1 (easytag-2.1.4.tar.bz2) = 1987839c8e3c141891d04143903e92bc788a26e8
RMD160 (easytag-2.1.4.tar.bz2) = 500f83026e8d9d064abe14f29dfd056c03f445c5
Size (easytag-2.1.4.tar.bz2) = 3242736 bytes
SHA1 (patch-aa) = f45888315aa3abdaa97009835cd1dce670f4cf6c
SHA1 (patch-ab) = ac5d8788da64080b358cba953111af99974ad9b4

View file

@ -1,13 +1,12 @@
$NetBSD: patch-aa,v 1.3 2007/11/21 21:40:25 drochner Exp $
$NetBSD: patch-aa,v 1.4 2008/01/13 15:28:32 wiz Exp $
--- src/mp4_tag.c.orig 2007-11-19 19:27:42.000000000 +0100
+++ src/mp4_tag.c
@@ -185,7 +185,7 @@ gboolean Mp4tag_Read_File_Tag (gchar *fi
* Picture *
***********/
// There is only one picture!
- if ( MP4GetMetadataCoverArt( mp4file, &coverArt, &coverSize ) )
+ if ( MP4GetMetadataCoverArt( mp4file, &coverArt, &coverSize, 0 ) )
{
Picture *pic = Picture_Allocate();
pic->size = coverSize;
--- src/et_core.c.orig 2007-12-05 20:03:34.000000000 +0000
+++ src/et_core.c
@@ -22,6 +22,7 @@
#include <gtk/gtk.h>
#include <glib/gi18n-lib.h>
+#include <locale.h>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

View file

@ -1,13 +1,15 @@
$NetBSD: patch-ab,v 1.1 2008/01/11 13:13:50 drochner Exp $
$NetBSD: patch-ab,v 1.2 2008/01/13 15:28:33 wiz Exp $
--- easytag.desktop.orig 2008-01-10 21:51:48.000000000 +0100
+++ easytag.desktop
@@ -16,7 +16,7 @@ Comment[ru]=EasyTAG -- ЩРН ОПНЦП
Comment[sv]=EasyTAG är ett verktyg för att undersöka, editera och skriva taggar för dina MP3-, MP2-, FLAC- och Ogg Vorbis-filer, och använder ett enkelt och trevligt GTK+-gränssnitt.
Comment[uk]=EasyTAG - утиліта для перегляду, редагування та запису тегів у файли MP3, MP2, FLAC, Ogg Vorbis, MusePack та Monkey's Audio. Простий та приємний інтерфейс GTK+ допоможе процесу запису тегів.
Exec=easytag %F
-Icon=EasyTAG.xpm
+Icon=EasyTAG_icon.xpm
Terminal=false
Type=Application
Encoding=UTF-8
--- src/mp4_tag.c.orig 2007-12-02 16:39:49.000000000 +0000
+++ src/mp4_tag.c
@@ -85,6 +85,10 @@ gboolean Mp4tag_Read_File_Tag (gchar *fi
u_int8_t *coverArt;
u_int32_t coverSize;
Picture *prev_pic = NULL;
+#ifdef NEWMP4
+ int i;
+#endif
+
if (!filename || !FileTag)
return FALSE;