Rename preconv and roff.7 to have a 'mandoc-' prefix. This removes the
conflicts with textproc/groff and allows both packages to co-exist, paving the way for mdocml to be used in the tools infrastructure as an nroff replacement. Bump PKGREVISION.
This commit is contained in:
parent
ea73376087
commit
d2973dada3
6 changed files with 94 additions and 9 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.34 2012/12/24 13:40:18 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.35 2013/09/12 10:33:29 jperkin Exp $
|
||||
|
||||
DISTNAME= mdocml-1.12.0
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= textproc devel
|
||||
MASTER_SITES= http://mdocml.bsd.lv/snapshots/
|
||||
|
||||
|
@ -10,9 +10,15 @@ HOMEPAGE= http://mdocml.bsd.lv/
|
|||
COMMENT= Man page tool (mdoc macro compiler)
|
||||
LICENSE= 2-clause-bsd # not exactly, but near enough
|
||||
|
||||
MAKE_FLAGS+= PREFIX=${PREFIX} DBLIB=${BDB_LIBS:Q}
|
||||
MAKE_FLAGS+= PREFIX=${PREFIX} DBLIB=${BDB_LIBS:Q}
|
||||
|
||||
CONFLICTS= man-pages-[0-9]* groff-[0-9]*
|
||||
CONFLICTS= man-pages-[0-9]*
|
||||
|
||||
SUBST_CLASSES+= roff
|
||||
SUBST_STAGE.roff= pre-build
|
||||
SUBST_FILES.roff= mandoc.1 mandoc.3
|
||||
SUBST_FILES.roff+= eqn.7 man.7 mdoc.7 tbl.7
|
||||
SUBST_SED.roff= -e 's,Xr roff,Xr mandoc-roff,g'
|
||||
|
||||
.include "../../mk/bdb.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,19 +1,19 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2011/09/06 09:49:01 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2013/09/12 10:33:29 jperkin Exp $
|
||||
bin/demandoc
|
||||
bin/mandoc
|
||||
bin/preconv
|
||||
bin/mandoc-preconv
|
||||
include/mandoc/man.h
|
||||
include/mandoc/mandoc.h
|
||||
include/mandoc/mdoc.h
|
||||
lib/mandoc/libmandoc.a
|
||||
man/man1/demandoc.1
|
||||
man/man1/mandoc.1
|
||||
man/man1/preconv.1
|
||||
man/man1/mandoc-preconv.1
|
||||
man/man3/mandoc.3
|
||||
man/man7/eqn.7
|
||||
man/man7/man.7
|
||||
man/man7/mandoc_char.7
|
||||
man/man7/mdoc.7
|
||||
man/man7/roff.7
|
||||
man/man7/mandoc-roff.7
|
||||
man/man7/tbl.7
|
||||
share/examples/mandoc/example.style.css
|
||||
|
|
|
@ -1,7 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.26 2012/12/24 13:40:18 jperkin Exp $
|
||||
$NetBSD: distinfo,v 1.27 2013/09/12 10:33:29 jperkin Exp $
|
||||
|
||||
SHA1 (mdocml-1.12.0.tar.gz) = 7c2c1a23c0bba61d9fc4ee7dc5b47a0a07e0b981
|
||||
RMD160 (mdocml-1.12.0.tar.gz) = 3ea04c4b4639ae63ae924db3645f1712f149ec5b
|
||||
Size (mdocml-1.12.0.tar.gz) = 236717 bytes
|
||||
SHA1 (patch-Makefile) = 8bd03c7514c4c27635c0af93ce94a8310b3b824f
|
||||
SHA1 (patch-apropos.c) = 7f87b36a20a6682a922e1c1ee7ca144be7f020ab
|
||||
SHA1 (patch-mandocdb.c) = 2a0d1aacd3d8c2411e7d067df08151d57afae7ab
|
||||
SHA1 (patch-preconv.1) = d2826262f96d89c3465246eab230b3a5d1f9dda2
|
||||
SHA1 (patch-roff.7) = d8479f3fd95146088af0bf5955aa3563ef50d160
|
||||
|
|
25
textproc/mdocml/patches/patch-Makefile
Normal file
25
textproc/mdocml/patches/patch-Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-Makefile,v 1.4 2013/09/12 10:33:29 jperkin Exp $
|
||||
|
||||
Install preconv and roff with 'mandoc-' prefix to avoid conflict with groff.
|
||||
|
||||
--- Makefile.orig 2011-10-08 20:07:21.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -392,12 +392,15 @@ install: all
|
||||
mkdir -p $(DESTDIR)$(MANDIR)/man3
|
||||
mkdir -p $(DESTDIR)$(MANDIR)/man7
|
||||
mkdir -p $(DESTDIR)$(MANDIR)/man8
|
||||
- $(INSTALL_PROGRAM) mandoc preconv demandoc $(DESTDIR)$(BINDIR)
|
||||
+ $(INSTALL_PROGRAM) mandoc demandoc $(DESTDIR)$(BINDIR)
|
||||
+ $(INSTALL_PROGRAM) preconv $(DESTDIR)$(BINDIR)/mandoc-preconv
|
||||
$(INSTALL_LIB) libmandoc.a $(DESTDIR)$(LIBDIR)
|
||||
$(INSTALL_LIB) man.h mdoc.h mandoc.h $(DESTDIR)$(INCLUDEDIR)
|
||||
- $(INSTALL_MAN) mandoc.1 preconv.1 demandoc.1 $(DESTDIR)$(MANDIR)/man1
|
||||
+ $(INSTALL_MAN) mandoc.1 demandoc.1 $(DESTDIR)$(MANDIR)/man1
|
||||
+ $(INSTALL_MAN) preconv.1 $(DESTDIR)$(MANDIR)/man1/mandoc-preconv.1
|
||||
$(INSTALL_MAN) mandoc.3 $(DESTDIR)$(MANDIR)/man3
|
||||
- $(INSTALL_MAN) man.7 mdoc.7 roff.7 eqn.7 tbl.7 mandoc_char.7 $(DESTDIR)$(MANDIR)/man7
|
||||
+ $(INSTALL_MAN) man.7 mdoc.7 eqn.7 tbl.7 mandoc_char.7 $(DESTDIR)$(MANDIR)/man7
|
||||
+ $(INSTALL_MAN) roff.7 $(DESTDIR)$(MANDIR)/man7/mandoc-roff.7
|
||||
$(INSTALL_DATA) example.style.css $(DESTDIR)$(EXAMPLEDIR)
|
||||
|
||||
installwww: www
|
32
textproc/mdocml/patches/patch-preconv.1
Normal file
32
textproc/mdocml/patches/patch-preconv.1
Normal file
|
@ -0,0 +1,32 @@
|
|||
$NetBSD: patch-preconv.1,v 1.1 2013/09/12 10:33:29 jperkin Exp $
|
||||
|
||||
Install preconv and roff with 'mandoc-' prefix to avoid conflict with groff.
|
||||
|
||||
--- preconv.1.orig 2011-10-08 20:07:22.000000000 +0000
|
||||
+++ preconv.1
|
||||
@@ -15,13 +15,13 @@
|
||||
.\" OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
.\"
|
||||
.Dd $Mdocdate: August 18 2011 $
|
||||
-.Dt PRECONV 1
|
||||
+.Dt MANDOC-PRECONV 1
|
||||
.Os
|
||||
.Sh NAME
|
||||
-.Nm preconv
|
||||
+.Nm mandoc-preconv
|
||||
.Nd recode multibyte UNIX manuals
|
||||
.Sh SYNOPSIS
|
||||
-.Nm preconv
|
||||
+.Nm mandoc-preconv
|
||||
.Op Fl D Ar enc
|
||||
.Op Fl e Ar enc
|
||||
.Op Ar file
|
||||
@@ -126,7 +126,7 @@ Explicitly page a UTF\-8 manual
|
||||
.Pa foo.1
|
||||
in the current locale:
|
||||
.Pp
|
||||
-.Dl $ preconv \-e utf\-8 foo.1 | mandoc -Tlocale | less
|
||||
+.Dl $ mandoc-preconv \-e utf\-8 foo.1 | mandoc -Tlocale | less
|
||||
.\" .Sh DIAGNOSTICS
|
||||
.\" For sections 1, 4, 6, 7, & 8 only.
|
||||
.\" .Sh ERRORS
|
19
textproc/mdocml/patches/patch-roff.7
Normal file
19
textproc/mdocml/patches/patch-roff.7
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-roff.7,v 1.1 2013/09/12 10:33:29 jperkin Exp $
|
||||
|
||||
Install preconv and roff with 'mandoc-' prefix to avoid conflict with groff.
|
||||
|
||||
--- roff.7.orig 2011-10-08 20:07:22.000000000 +0000
|
||||
+++ roff.7
|
||||
@@ -16,10 +16,10 @@
|
||||
.\" OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
.\"
|
||||
.Dd $Mdocdate: September 26 2011 $
|
||||
-.Dt ROFF 7
|
||||
+.Dt MANDOC-ROFF 7
|
||||
.Os
|
||||
.Sh NAME
|
||||
-.Nm roff
|
||||
+.Nm mandoc-roff
|
||||
.Nd roff language reference for mandoc
|
||||
.Sh DESCRIPTION
|
||||
The
|
Loading…
Reference in a new issue