Changes 2004g:

* Bug fix: quoted string handling in the mailbox name parsing routine

Changes 2004f:
* Bug fix: TCP code
* New SSL/TLS routines
This commit is contained in:
adam 2006-01-12 20:53:50 +00:00
parent 3960c7b1d2
commit d29c67b2e1
4 changed files with 13 additions and 32 deletions

View file

@ -1,12 +1,11 @@
# $NetBSD: Makefile,v 1.106 2005/12/05 20:50:31 rillig Exp $
# $NetBSD: Makefile,v 1.107 2006/01/12 20:53:50 adam Exp $
#
# ATTENTION:
# The Kerberos support in this software is known to be problematic. If you
# upgrade this package you *must* test it on a system with Kerberos libraries
# but not running Kerberos before committing the changes.
DISTNAME= imap-2004e
PKGREVISION= 2
DISTNAME= imap-2004g
PKGNAME= ${DISTNAME:S/-/-uw-/}
CATEGORIES= mail
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/
@ -54,7 +53,7 @@ CCLIENT_INCS= c-client.h env.h env_unix.h flocksim.h flstring.h \
CCLIENT_LIB= libc-client.la
CCLIENT_PICLIB= libc-client_pic.a
CCLIENT_MAJOR= 4
CCLIENT_MINOR= 2
CCLIENT_MINOR= 3
CCLIENT_MFILES= src/imapd/Makefile \
src/ipopd/Makefile \
src/mtest/Makefile \

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.26 2005/12/03 00:52:54 joerg Exp $
$NetBSD: distinfo,v 1.27 2006/01/12 20:53:50 adam Exp $
SHA1 (imap-2004e.tar.Z) = 3c5cf83489dd8ac4c2cfd43370fcec85db7bc372
RMD160 (imap-2004e.tar.Z) = 76c8596fe1a9a830bbd60fdafafb13f9bac42cd9
Size (imap-2004e.tar.Z) = 2219840 bytes
SHA1 (patch-aa) = f9ce776164fe55aeb08ec0e87bbc6ac80b97d439
SHA1 (imap-2004g.tar.Z) = 791a8bb247ca51ce0a4c32e814a2f736c2bcf066
RMD160 (imap-2004g.tar.Z) = a016a06ba073e879d2574a6395ce1074ea74c687
Size (imap-2004g.tar.Z) = 2246713 bytes
SHA1 (patch-aa) = 6ea304a31bb501921600e40e480854f2f30a46cf
SHA1 (patch-ab) = 5c134608a2a611c1b1bbb345f26b4743ad7dd538
SHA1 (patch-ac) = 8b4ea8c15929c65eda1b3444c68fdbf70fa68b6a
SHA1 (patch-ad) = 3404de4e4acb456e3c7b34ca80b31b80b465b3e1
@ -16,7 +16,6 @@ SHA1 (patch-aj) = 0a728d3b5271c048275a4d41002877e86ac275b2
SHA1 (patch-ak) = c798b2aad17091526c667a552839cfe1ec0e23c9
SHA1 (patch-al) = b746d36cb324114468d07d1aba7d22c5bd5b23b2
SHA1 (patch-am) = 891de03bbc24de9eaf70d74c69b5b66d0b6b94b4
SHA1 (patch-an) = f3c9e23406b5f6ae32ce51a81b1f2aab46d8394d
SHA1 (patch-ao) = 777b30793ea2e1f33be14e34d837f1f0cc5d0d67
SHA1 (patch-ap) = ce224812b0744a699e5e07916ca04510bf62da25
SHA1 (patch-aq) = 7cf038fcb8e072fa46604ac0ac8c02c0d6d3608e

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.15 2005/08/01 20:34:31 tron Exp $
$NetBSD: patch-aa,v 1.16 2006/01/12 20:53:51 adam Exp $
--- Makefile.orig 2004-12-25 19:05:25.000000000 +0000
+++ Makefile 2005-08-01 19:27:56.000000000 +0100
@@ -180,7 +180,7 @@
--- Makefile.orig 2005-04-30 22:50:20.000000000 +0200
+++ Makefile
@@ -180,7 +180,7 @@ SSLTYPE=nopwd
# 4 (default) IPv4 support only
# 6 IPv6 and IPv4 support
@ -11,7 +11,7 @@ $NetBSD: patch-aa,v 1.15 2005/08/01 20:34:31 tron Exp $
# The following extra compilation flags are defined. None of these flags are
@@ -461,9 +461,9 @@
@@ -474,9 +474,9 @@ sslunix sslsco:
@echo + In order to rectify this problem, you MUST build with:
@echo ++ SSLTYPE=$(SSLTYPE).nopwd
@echo +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

View file

@ -1,17 +0,0 @@
$NetBSD: patch-an,v 1.1 2005/10/05 15:49:44 salo Exp $
Security fix for CAN-2005-2933, from 2004g.
--- src/c-client/mail.c.orig 2005-03-17 01:12:17.000000000 +0100
+++ src/c-client/mail.c 2005-10-05 17:37:13.000000000 +0200
@@ -691,8 +691,10 @@
if (c == '=') { /* parse switches which take arguments */
if (*t == '"') { /* quoted string? */
for (v = arg,i = 0,++t; (c = *t++) != '"';) {
+ if (!c) return NIL; /* unterminated string */
/* quote next character */
if (c == '\\') c = *t++;
+ if (!c) return NIL; /* can't quote NUL either */
arg[i++] = c;
}
c = *t++; /* remember delimiter for later */