Make this compile on sparc64 with gcc 4.
(Need to cast to something at least as wide as "void *" - e.g. "long".) OK wiz@, joerg@.
This commit is contained in:
parent
711c71414a
commit
d2a3b6384c
2 changed files with 19 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.42 2006/07/05 20:12:06 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.43 2006/09/24 17:09:13 jdc Exp $
|
||||
|
||||
SHA1 (cups-1.1.23-source.tar.bz2) = 32d5bfb44c4edc1b54ccb014b5a44499295c6c5c
|
||||
RMD160 (cups-1.1.23-source.tar.bz2) = 255ec4c22422b14f2367d69f3ec7e590dc46bea5
|
||||
|
@ -15,6 +15,7 @@ SHA1 (patch-ai) = f1b60cec40426e158801a24e043bc41fee199d1b
|
|||
SHA1 (patch-aj) = 248c7ae93fd81154d703a56c0149463d6a73a6f6
|
||||
SHA1 (patch-ak) = fe0a5317cf70f49fe3b386177b7a12b2df306ed1
|
||||
SHA1 (patch-al) = dcec693d824305cce6e31c07fb96be4759a55f81
|
||||
SHA1 (patch-am) = 660bdcd7717f68453fbb3e8b6aa81a4205ef08a1
|
||||
SHA1 (patch-an) = 8eb0f80067839d3d112d93e08cb8ad6854fa2b4c
|
||||
SHA1 (patch-ao) = c4c8f833cf4a09a686a338df6c209cebec36c6ef
|
||||
SHA1 (patch-ap) = 2351844f81a561d69cd02a1e83e30f3c9ee33f5f
|
||||
|
|
17
print/cups/patches/patch-am
Normal file
17
print/cups/patches/patch-am
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-am,v 1.7 2006/09/24 17:09:13 jdc Exp $
|
||||
|
||||
--- pdftops/GfxFont.cxx.dist 2004-02-02 22:41:09.000000000 +0000
|
||||
+++ pdftops/GfxFont.cxx 2006-09-24 16:12:03.000000000 +0100
|
||||
@@ -969,7 +969,11 @@
|
||||
if ((nameToGID = ff->getNameToGID())) {
|
||||
for (i = 0; i < 256; ++i) {
|
||||
if (!map[i] && (charName = enc[i])) {
|
||||
- map[i] = (Gushort)(int)nameToGID->lookup(charName);
|
||||
+ /*
|
||||
+ * Note that we are casting from "void *" here.
|
||||
+ * So, we must first cast to something at least as wide.
|
||||
+ */
|
||||
+ map[i] = (Gushort)(long)nameToGID->lookup(charName);
|
||||
}
|
||||
}
|
||||
delete nameToGID;
|
Loading…
Reference in a new issue