Remove pnet packages. This project only ever existed because of the
FSF's not-invented-here reflex, never went anywhere, and has been dead upstream for a long time.
This commit is contained in:
parent
db8d6705cc
commit
d2daa7030b
19 changed files with 1 additions and 652 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.337 2012/12/11 14:52:11 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.338 2012/12/29 19:41:17 dholland Exp $
|
||||
#
|
||||
|
||||
COMMENT= Programming languages
|
||||
|
@ -135,10 +135,6 @@ SUBDIR+= php53
|
|||
SUBDIR+= php54
|
||||
SUBDIR+= picoc
|
||||
SUBDIR+= pict
|
||||
SUBDIR+= pnet
|
||||
SUBDIR+= pnetC
|
||||
SUBDIR+= pnetlib
|
||||
SUBDIR+= pnetlib-nox11
|
||||
SUBDIR+= polyml
|
||||
SUBDIR+= py-basicproperty
|
||||
SUBDIR+= py-cxfreeze
|
||||
|
|
|
@ -1,3 +0,0 @@
|
|||
The goal of this project is to build a suite of Free Software tools
|
||||
to build and execute .NET applications, including a C# compiler,
|
||||
assembler, disassembler, and runtime engine.
|
|
@ -1,37 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.27 2012/10/02 20:11:49 asau Exp $
|
||||
|
||||
DISTNAME= pnet-0.8.0
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://download.savannah.gnu.org/releases/dotgnu-pnet/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.dotgnu.org/
|
||||
COMMENT= DotGNU Portable.NET (development tools)
|
||||
|
||||
BUILD_DEPENDS+= treecc>=0.2.6:../../devel/treecc
|
||||
|
||||
CONFLICTS= mono-[0-9]*
|
||||
CONFLICTS+= libffi-[0-9]*
|
||||
CONFLICTS+= boehm-gc-[0-9]*
|
||||
|
||||
# Unsupported by internal libffi
|
||||
NOT_FOR_PLATFORM= NetBSD-*-x86_64
|
||||
NOT_FOR_PLATFORM+= DragonFly-*-*
|
||||
|
||||
MAKE_JOBS_SAFE= no
|
||||
|
||||
USE_TOOLS+= gmake lex makeinfo
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
INFO_FILES= # PLIST
|
||||
|
||||
PTHREAD_OPTS+= require native
|
||||
|
||||
CONFIGURE_ARGS+= --enable-threads=posix
|
||||
|
||||
.include "../../mk/termcap.buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
166
lang/pnet/PLIST
166
lang/pnet/PLIST
|
@ -1,166 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.9 2009/06/14 18:03:38 joerg Exp $
|
||||
bin/al
|
||||
bin/cli-unknown-ar
|
||||
bin/cli-unknown-cpp
|
||||
bin/cli-unknown-gcc
|
||||
bin/cli-unknown-ranlib
|
||||
bin/cli-unknown-size
|
||||
bin/cli-unknown-strip
|
||||
bin/clrwrap
|
||||
bin/csant
|
||||
bin/cscc
|
||||
bin/cscc-cpp
|
||||
bin/csdoc
|
||||
bin/csdoc2hier
|
||||
bin/csdoc2html
|
||||
bin/csdoc2texi
|
||||
bin/cssrc2html
|
||||
bin/ilalink
|
||||
bin/ilasm
|
||||
bin/ildasm
|
||||
bin/ildd
|
||||
bin/ilfind
|
||||
bin/ilgac
|
||||
bin/ilheader
|
||||
bin/ilnative
|
||||
bin/ilranlib
|
||||
bin/ilrun
|
||||
bin/ilsize
|
||||
bin/ilstrip
|
||||
bin/ilverify
|
||||
bin/resgen
|
||||
include/ffi.h
|
||||
include/ffitarget.h
|
||||
include/gc.h
|
||||
include/gc/gc.h
|
||||
include/gc/gc_alloc.h
|
||||
include/gc/gc_allocator.h
|
||||
include/gc/gc_amiga_redirects.h
|
||||
include/gc/gc_backptr.h
|
||||
include/gc/gc_config_macros.h
|
||||
include/gc/gc_cpp.h
|
||||
include/gc/gc_gcj.h
|
||||
include/gc/gc_inl.h
|
||||
include/gc/gc_inline.h
|
||||
include/gc/gc_local_alloc.h
|
||||
include/gc/gc_mark.h
|
||||
include/gc/gc_pthread_redirects.h
|
||||
include/gc/gc_typed.h
|
||||
include/gc/leak_detector.h
|
||||
include/gc/new_gc_alloc.h
|
||||
include/gc/weakpointer.h
|
||||
include/gc_config_macros.h
|
||||
include/gc_local_alloc.h
|
||||
include/gc_pthread_redirects.h
|
||||
include/gc_typed.h
|
||||
include/leak_detector.h
|
||||
include/pnet/il_align.h
|
||||
include/pnet/il_bignum.h
|
||||
include/pnet/il_coder.h
|
||||
include/pnet/il_config.h
|
||||
include/pnet/il_console.h
|
||||
include/pnet/il_crypt.h
|
||||
include/pnet/il_debug.h
|
||||
include/pnet/il_debugger.h
|
||||
include/pnet/il_decimal.h
|
||||
include/pnet/il_dumpasm.h
|
||||
include/pnet/il_engine.h
|
||||
include/pnet/il_errno.h
|
||||
include/pnet/il_gc.h
|
||||
include/pnet/il_image.h
|
||||
include/pnet/il_jopcodes.h
|
||||
include/pnet/il_linker.h
|
||||
include/pnet/il_meta.h
|
||||
include/pnet/il_opcodes.h
|
||||
include/pnet/il_profile.h
|
||||
include/pnet/il_program.h
|
||||
include/pnet/il_regex.h
|
||||
include/pnet/il_serial.h
|
||||
include/pnet/il_serialize.h
|
||||
include/pnet/il_sysio.h
|
||||
include/pnet/il_system.h
|
||||
include/pnet/il_thread.h
|
||||
include/pnet/il_types.h
|
||||
include/pnet/il_utils.h
|
||||
include/pnet/il_values.h
|
||||
include/pnet/il_writer.h
|
||||
include/pnet/il_xml.h
|
||||
info/pnettools.info
|
||||
lib/cscc/plugins/cscc-b
|
||||
lib/cscc/plugins/cscc-bf
|
||||
lib/cscc/plugins/cscc-c-s
|
||||
lib/cscc/plugins/cscc-cs
|
||||
lib/cscc/plugins/cscc-csharp
|
||||
lib/cscc/plugins/cscc-java
|
||||
lib/cscc/plugins/cscc-vb
|
||||
lib/libILAsm.a
|
||||
lib/libILCodeGen.a
|
||||
lib/libILDumpAsm.a
|
||||
lib/libILEngine.a
|
||||
lib/libILImage.a
|
||||
lib/libILLink.a
|
||||
lib/libILSupport.a
|
||||
lib/libffi.la
|
||||
lib/libgc.la
|
||||
man/man1/al.1
|
||||
man/man1/cli-unknown-ar.1
|
||||
man/man1/cli-unknown-cpp.1
|
||||
man/man1/cli-unknown-gcc.1
|
||||
man/man1/cli-unknown-ranlib.1
|
||||
man/man1/cli-unknown-size.1
|
||||
man/man1/cli-unknown-strip.1
|
||||
man/man1/clrwrap.1
|
||||
man/man1/csant.1
|
||||
man/man1/cscc-cpp.1
|
||||
man/man1/cscc.1
|
||||
man/man1/csdoc.1
|
||||
man/man1/csdoc2hier.1
|
||||
man/man1/csdoc2html.1
|
||||
man/man1/csdoc2texi.1
|
||||
man/man1/cssrc2html.1
|
||||
man/man1/ilalink.1
|
||||
man/man1/ilasm.1
|
||||
man/man1/ildasm.1
|
||||
man/man1/ildd.1
|
||||
man/man1/ilfind.1
|
||||
man/man1/ilgac.1
|
||||
man/man1/ilheader.1
|
||||
man/man1/ilnative.1
|
||||
man/man1/ilranlib.1
|
||||
man/man1/ilrun.1
|
||||
man/man1/ilsize.1
|
||||
man/man1/ilstrip.1
|
||||
man/man1/ilverify.1
|
||||
man/man1/resgen.1
|
||||
share/gc/README
|
||||
share/gc/README.DGUX386
|
||||
share/gc/README.Mac
|
||||
share/gc/README.MacOSX
|
||||
share/gc/README.OS2
|
||||
share/gc/README.amiga
|
||||
share/gc/README.arm.cross
|
||||
share/gc/README.autoconf
|
||||
share/gc/README.changes
|
||||
share/gc/README.contributors
|
||||
share/gc/README.cords
|
||||
share/gc/README.darwin
|
||||
share/gc/README.dj
|
||||
share/gc/README.environment
|
||||
share/gc/README.ews4800
|
||||
share/gc/README.hp
|
||||
share/gc/README.linux
|
||||
share/gc/README.macros
|
||||
share/gc/README.rs6000
|
||||
share/gc/README.sgi
|
||||
share/gc/README.solaris2
|
||||
share/gc/README.uts
|
||||
share/gc/README.win32
|
||||
share/gc/barrett_diagram
|
||||
share/gc/debugging.html
|
||||
share/gc/gc.man
|
||||
share/gc/gcdescr.html
|
||||
share/gc/gcinterface.html
|
||||
share/gc/leak.html
|
||||
share/gc/scale.html
|
||||
share/gc/simple_example.html
|
||||
share/gc/tree.html
|
|
@ -1,14 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.13 2009/03/20 19:24:51 joerg Exp $
|
||||
|
||||
BUILDLINK_TREE+= pnet
|
||||
|
||||
.if !defined(PNET_BUILDLINK3_MK)
|
||||
PNET_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.pnet+= pnet>=0.8.0
|
||||
BUILDLINK_PKGSRCDIR.pnet?= ../../lang/pnet
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.endif # PNET_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -pnet
|
|
@ -1,7 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.9 2012/01/27 08:59:48 sbd Exp $
|
||||
|
||||
SHA1 (pnet-0.8.0.tar.gz) = 3d048cbef0476f21cbdd86f81c1706f52b7a7218
|
||||
RMD160 (pnet-0.8.0.tar.gz) = 232f96fb92be2cab4109ab03845bafa84c3d0259
|
||||
Size (pnet-0.8.0.tar.gz) = 4510420 bytes
|
||||
SHA1 (patch-aa) = 4bc78118a597754b029fa231e4c58dcd0f160f88
|
||||
SHA1 (patch-ab) = 2df077f95643791d32cff2e4a82b0bc5cd67a01b
|
|
@ -1,33 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.5 2012/01/27 08:59:49 sbd Exp $
|
||||
|
||||
--- libffi/configure.orig 2007-03-01 18:57:59.000000000 +0000
|
||||
+++ libffi/configure
|
||||
@@ -20700,6 +20700,7 @@ i*86-*-solaris2.1[0-9]*) TARGET=X86_64;
|
||||
i*86-*-solaris*) TARGET=X86; TARGETDIR=x86;;
|
||||
i*86-*-beos*) TARGET=X86; TARGETDIR=x86;;
|
||||
i*86-*-freebsd* | i*86-*-kfreebsd*-gnu) TARGET=X86; TARGETDIR=x86;;
|
||||
+i*86-*-dragonfly*) TARGET=X86; TARGETDIR=x86;;
|
||||
i*86-*-netbsdelf* | i*86-*-knetbsd*-gnu) TARGET=X86; TARGETDIR=x86;;
|
||||
i*86-*-rtems*) TARGET=X86; TARGETDIR=x86;;
|
||||
i*86-*-win32*) TARGET=X86_WIN32; TARGETDIR=x86;;
|
||||
@@ -20731,7 +20732,7 @@ arm*-*-rtems*) TARGET=ARM; TARGETDIR=arm
|
||||
cris-*-*) TARGET=LIBFFI_CRIS; TARGETDIR=cris;;
|
||||
s390-*-linux-*) TARGET=S390; TARGETDIR=s390;;
|
||||
s390x-*-linux-*) TARGET=S390; TARGETDIR=s390;;
|
||||
-x86_64-*-linux* | x86_64-*-freebsd* | x86_64-*-kfreebsd*-gnu) TARGET=X86_64; TARGETDIR=x86;;
|
||||
+x86_64-*-linux* | x86_64-*-freebsd* | x86_64-*-kfreebsd*-gnu | x86_64-*-dragonfly*) TARGET=X86_64; TARGETDIR=x86;;
|
||||
sh-*-linux* | sh[34]*-*-linux*) TARGET=SH; TARGETDIR=sh;;
|
||||
sh-*-rtems*) TARGET=SH; TARGETDIR=sh;;
|
||||
sh64-*-linux* | sh5*-*-linux*) TARGET=SH64; TARGETDIR=sh64;;
|
||||
@@ -23270,11 +23271,6 @@ else
|
||||
toolexecdir='$(libdir)/gcc-lib/$(target_alias)'
|
||||
toolexeclibdir='$(libdir)'
|
||||
fi
|
||||
-multi_os_directory=`$CC -print-multi-os-directory`
|
||||
-case $multi_os_directory in
|
||||
- .) ;; # Avoid trailing /.
|
||||
- *) toolexeclibdir=$toolexeclibdir/$multi_os_directory ;;
|
||||
-esac
|
||||
|
||||
|
||||
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2009/06/02 18:39:20 hasso Exp $
|
||||
|
||||
--- libgc/configure.orig 2009-06-02 16:41:38 +0300
|
||||
+++ libgc/configure 2009-06-02 16:43:54 +0300
|
||||
@@ -4754,6 +4754,14 @@ _ACEOF
|
||||
INCLUDES="$INCLUDES -pthread"
|
||||
THREADDLLIBS=-pthread
|
||||
;;
|
||||
+ *-*-dragonfly*)
|
||||
+ cat >>confdefs.h <<\_ACEOF
|
||||
+#define GC_FREEBSD_THREADS 1
|
||||
+_ACEOF
|
||||
+
|
||||
+ INCLUDES="$INCLUDES -pthread"
|
||||
+ THREADDLLIBS=-pthread
|
||||
+ ;;
|
||||
*-*-kfreebsd*-gnu)
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define GC_FREEBSD_THREADS 1
|
|
@ -1,3 +0,0 @@
|
|||
This is the "pnetC" project. The goal of the project is to create
|
||||
an ANSI-compatible C library, that can be compiled down to IL using
|
||||
DotGNU Portable.NET's "cscc" compiler.
|
|
@ -1,22 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.13 2012/08/14 17:07:57 asau Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pnetC-0.6.6
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=dotgnu/pnet/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.dotgnu.org/
|
||||
COMMENT= C language binding for DotGNU Portable .NET
|
||||
|
||||
PKG_DESTDIR_SUPPORT= none
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_TOOLS+= gmake
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
.include "../../lang/pnet/buildlink3.mk"
|
||||
.include "../../lang/pnetlib/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
121
lang/pnetC/PLIST
121
lang/pnetC/PLIST
|
@ -1,121 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2009/06/14 18:03:38 joerg Exp $
|
||||
lib/cscc/lib/1.2.3400.0/libc.dll
|
||||
lib/cscc/lib/1.2.3400.0/libm.dll
|
||||
lib/cscc/lib/1.2.3400.0/libpthread.dll
|
||||
lib/cscc/lib/libc.dll
|
||||
lib/cscc/lib/libm.dll
|
||||
lib/cscc/lib/libpthread.dll
|
||||
share/cscc/include/alloca.h
|
||||
share/cscc/include/arpa/inet.h
|
||||
share/cscc/include/arpa/nameser.h
|
||||
share/cscc/include/assembly/Accessibility.h
|
||||
share/cscc/include/assembly/Commons.Xml.Relaxng.h
|
||||
share/cscc/include/assembly/Custommarshalers.h
|
||||
share/cscc/include/assembly/DotGNU.Images.h
|
||||
share/cscc/include/assembly/DotGNU.SSL.h
|
||||
share/cscc/include/assembly/DotGNU.Terminal.h
|
||||
share/cscc/include/assembly/ICSharpCode.SharpZipLib.h
|
||||
share/cscc/include/assembly/ISymWrapper.h
|
||||
share/cscc/include/assembly/Microsoft.JScript.h
|
||||
share/cscc/include/assembly/Microsoft.VisualBasic.h
|
||||
share/cscc/include/assembly/Microsoft.VisualC.h
|
||||
share/cscc/include/assembly/Microsoft.Vsa.h
|
||||
share/cscc/include/assembly/Microsoft.Web.Services.h
|
||||
share/cscc/include/assembly/OpenSystem.C.h
|
||||
share/cscc/include/assembly/OpenSystem.Platform.h
|
||||
share/cscc/include/assembly/PEAPI.h
|
||||
share/cscc/include/assembly/System.Configuration.Install.h
|
||||
share/cscc/include/assembly/System.Data.ObjectSpaces.h
|
||||
share/cscc/include/assembly/System.Data.OracleClient.h
|
||||
share/cscc/include/assembly/System.Data.SqlXml.h
|
||||
share/cscc/include/assembly/System.Data.h
|
||||
share/cscc/include/assembly/System.Design.h
|
||||
share/cscc/include/assembly/System.DirectoryServices.h
|
||||
share/cscc/include/assembly/System.Drawing.Design.h
|
||||
share/cscc/include/assembly/System.Drawing.h
|
||||
share/cscc/include/assembly/System.EnterpriseServices.h
|
||||
share/cscc/include/assembly/System.Management.h
|
||||
share/cscc/include/assembly/System.Messaging.h
|
||||
share/cscc/include/assembly/System.Net.IrDA.h
|
||||
share/cscc/include/assembly/System.Runtime.Remoting.h
|
||||
share/cscc/include/assembly/System.Runtime.Serialization.Formatters.Soap.h
|
||||
share/cscc/include/assembly/System.Security.h
|
||||
share/cscc/include/assembly/System.ServiceProcess.h
|
||||
share/cscc/include/assembly/System.Web.Mobile.h
|
||||
share/cscc/include/assembly/System.Web.Services.h
|
||||
share/cscc/include/assembly/System.Web.h
|
||||
share/cscc/include/assembly/System.Windows.Forms.h
|
||||
share/cscc/include/assembly/System.Xml.h
|
||||
share/cscc/include/assembly/System.h
|
||||
share/cscc/include/assembly/Xsharp.h
|
||||
share/cscc/include/assembly/cscompmgd.h
|
||||
share/cscc/include/assembly/mscorlib.h
|
||||
share/cscc/include/assert.h
|
||||
share/cscc/include/bits/in.h
|
||||
share/cscc/include/bits/libc-lock.h
|
||||
share/cscc/include/bits/local_lim.h
|
||||
share/cscc/include/bits/mman.h
|
||||
share/cscc/include/bits/netdb.h
|
||||
share/cscc/include/bits/posix1_lim.h
|
||||
share/cscc/include/bits/posix2_lim.h
|
||||
share/cscc/include/bits/sockaddr.h
|
||||
share/cscc/include/bits/socket.h
|
||||
share/cscc/include/bits/stat.h
|
||||
share/cscc/include/bits/stdio_lim.h
|
||||
share/cscc/include/bits/types.h
|
||||
share/cscc/include/bits/uio.h
|
||||
share/cscc/include/bits/waitflags.h
|
||||
share/cscc/include/bits/waitstatus.h
|
||||
share/cscc/include/bits/wchar.h
|
||||
share/cscc/include/bits/wordsize.h
|
||||
share/cscc/include/bits/xopen_lim.h
|
||||
share/cscc/include/csharp.h
|
||||
share/cscc/include/ctype.h
|
||||
share/cscc/include/dirent.h
|
||||
share/cscc/include/errno.h
|
||||
share/cscc/include/fcntl.h
|
||||
share/cscc/include/features.h
|
||||
share/cscc/include/gmp-mparam.h
|
||||
share/cscc/include/gmp.h
|
||||
share/cscc/include/gnu/stubs.h
|
||||
share/cscc/include/grp.h
|
||||
share/cscc/include/ieee754.h
|
||||
share/cscc/include/inttypes.h
|
||||
share/cscc/include/langinfo.h
|
||||
share/cscc/include/limits.h
|
||||
share/cscc/include/locale.h
|
||||
share/cscc/include/malloc.h
|
||||
share/cscc/include/math.h
|
||||
share/cscc/include/netdb.h
|
||||
share/cscc/include/netinet/in.h
|
||||
share/cscc/include/pthread.h
|
||||
share/cscc/include/pwd.h
|
||||
share/cscc/include/semaphore.h
|
||||
share/cscc/include/setjmp.h
|
||||
share/cscc/include/signal.h
|
||||
share/cscc/include/stdarg.h
|
||||
share/cscc/include/stdbool.h
|
||||
share/cscc/include/stddef.h
|
||||
share/cscc/include/stdint.h
|
||||
share/cscc/include/stdio.h
|
||||
share/cscc/include/stdio_ext.h
|
||||
share/cscc/include/stdlib.h
|
||||
share/cscc/include/string.h
|
||||
share/cscc/include/strings.h
|
||||
share/cscc/include/sys/cdefs.h
|
||||
share/cscc/include/sys/errno.h
|
||||
share/cscc/include/sys/mman.h
|
||||
share/cscc/include/sys/param.h
|
||||
share/cscc/include/sys/select.h
|
||||
share/cscc/include/sys/socket.h
|
||||
share/cscc/include/sys/stat.h
|
||||
share/cscc/include/sys/sysmacros.h
|
||||
share/cscc/include/sys/time.h
|
||||
share/cscc/include/sys/types.h
|
||||
share/cscc/include/sys/uio.h
|
||||
share/cscc/include/time.h
|
||||
share/cscc/include/unistd.h
|
||||
share/cscc/include/varargs.h
|
||||
share/cscc/include/wchar.h
|
||||
share/cscc/include/wctype.h
|
||||
share/cscc/include/xlocale.h
|
|
@ -1,15 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.11 2012/05/07 01:53:42 dholland Exp $
|
||||
|
||||
BUILDLINK_TREE+= pnetC
|
||||
|
||||
.if !defined(PNETC_BUILDLINK3_MK)
|
||||
PNETC_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.pnetC+= pnetC>=0.6.4
|
||||
BUILDLINK_ABI_DEPENDS.pnetC+= pnetC>=0.6.6nb2
|
||||
BUILDLINK_PKGSRCDIR.pnetC?= ../../lang/pnetC
|
||||
|
||||
.include "../../lang/pnet/buildlink3.mk"
|
||||
.endif # PNETC_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -pnetC
|
|
@ -1,5 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.4 2005/02/24 09:03:10 agc Exp $
|
||||
|
||||
SHA1 (pnetC-0.6.6.tar.gz) = 2f81fc6616aafcb70255a4ca60a788177da5da65
|
||||
RMD160 (pnetC-0.6.6.tar.gz) = e4aca63afe25fca0b8428aef7b9e4c249d16c5e0
|
||||
Size (pnetC-0.6.6.tar.gz) = 374843 bytes
|
|
@ -1,4 +0,0 @@
|
|||
This distribution contains an implementation of the C# library, for use
|
||||
with .NET-capable runtime engines and applications. Originally designed
|
||||
for DotGNU Portable.NET, this library can be used by other .NET development
|
||||
effort also.
|
|
@ -1,20 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.12 2011/11/01 06:01:56 sbd Exp $
|
||||
#
|
||||
|
||||
PKGREVISION= 1
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
CONFIGURE_ARGS+= --enable-xft
|
||||
CONFIGURE_ARGS+= --with-x
|
||||
|
||||
CONFLICTS= pnetlib-nox11-[0-9]*
|
||||
|
||||
BUILDLINK_DEPMETHOD.libXt?= build
|
||||
|
||||
.include "../../x11/libXft/buildlink3.mk"
|
||||
.include "../../x11/libICE/buildlink3.mk"
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
.include "../../x11/libXext/buildlink3.mk"
|
||||
.include "../../x11/libXt/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,28 +0,0 @@
|
|||
# $NetBSD: Makefile.common,v 1.12 2012/10/02 20:11:49 asau Exp $
|
||||
#
|
||||
# used by lang/pnetlib/Makefile
|
||||
# used by lang/pnetlib-nox11/Makefile
|
||||
|
||||
DISTNAME= pnetlib-0.8.0
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://download.savannah.gnu.org/releases/dotgnu-pnet/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.dotgnu.org/
|
||||
COMMENT= DotGNU Portable .NET C SHARP class libraries
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_TOOLS+= gmake
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
DESCR_SRC= ${.CURDIR}/../pnetlib/DESCR
|
||||
DISTINFO_FILE= ${.CURDIR}/../pnetlib/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../pnetlib/patches
|
||||
PLIST_SRC= ${.CURDIR}/../pnetlib/PLIST
|
||||
|
||||
# Ensure we export symbols in the linked shared object.
|
||||
LDFLAGS+= ${EXPORT_SYMBOLS_LDFLAGS}
|
||||
|
||||
BUILD_DEPENDS+= treecc>=0.2.6:../../devel/treecc
|
||||
|
||||
.include "../../lang/pnet/buildlink3.mk"
|
|
@ -1,130 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.8 2009/06/14 18:03:38 joerg Exp $
|
||||
bin/csunit
|
||||
bin/ilinstall
|
||||
bin/jsrun
|
||||
lib/cscc/lib/0.81.0.1407/ICSharpCode.SharpZipLib.dll
|
||||
lib/cscc/lib/2.0.0.0/Accessibility.dll
|
||||
lib/cscc/lib/2.0.0.0/DotGNU.Images.dll
|
||||
lib/cscc/lib/2.0.0.0/DotGNU.Misc.dll
|
||||
lib/cscc/lib/2.0.0.0/DotGNU.SSL.dll
|
||||
lib/cscc/lib/2.0.0.0/DotGNU.Terminal.dll
|
||||
lib/cscc/lib/2.0.0.0/DotGNU.XmlRpc.dll
|
||||
lib/cscc/lib/2.0.0.0/I18N.CJK.dll
|
||||
lib/cscc/lib/2.0.0.0/I18N.MidEast.dll
|
||||
lib/cscc/lib/2.0.0.0/I18N.Other.dll
|
||||
lib/cscc/lib/2.0.0.0/I18N.Rare.dll
|
||||
lib/cscc/lib/2.0.0.0/I18N.West.dll
|
||||
lib/cscc/lib/2.0.0.0/I18N.dll
|
||||
lib/cscc/lib/2.0.0.0/ISymWrapper.dll
|
||||
lib/cscc/lib/2.0.0.0/OpenSystem.C.dll
|
||||
lib/cscc/lib/2.0.0.0/OpenSystem.Platform.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Configuration.Install.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Deployment.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Design.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Drawing.Postscript.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Drawing.Win32.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Drawing.Xsharp.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Drawing.dll
|
||||
lib/cscc/lib/2.0.0.0/System.EnterpriseServices.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Net.IrDA.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Windows.Forms.Themes.XP.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Windows.Forms.dll
|
||||
lib/cscc/lib/2.0.0.0/System.Xml.dll
|
||||
lib/cscc/lib/2.0.0.0/System.dll
|
||||
lib/cscc/lib/2.0.0.0/Xsharp.dll
|
||||
lib/cscc/lib/2.0.0.0/ca/I18N.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/ca/System.Configuration.Install.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/ca/System.Drawing.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/ca/System.Net.IrDA.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/ca/System.Windows.Forms.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/ca/System.Xml.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/ca/System.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/ca/Xsharp.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/ca/mscorlib.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/cstest.dll
|
||||
lib/cscc/lib/2.0.0.0/csunit.exe
|
||||
lib/cscc/lib/2.0.0.0/de/I18N.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/de/System.Configuration.Install.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/de/System.Drawing.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/de/System.Net.IrDA.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/de/System.Windows.Forms.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/de/System.Xml.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/de/System.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/de/Xsharp.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/de/mscorlib.resources.dll
|
||||
lib/cscc/lib/2.0.0.0/ilinstall.exe
|
||||
lib/cscc/lib/2.0.0.0/mscorlib.dll
|
||||
lib/cscc/lib/2.0.0.0/pinvoke.map
|
||||
lib/cscc/lib/2.0.0.0/sysglobl.dll
|
||||
lib/cscc/lib/8.0.50727.42/Microsoft.JScript.dll
|
||||
lib/cscc/lib/8.0.50727.42/Microsoft.VisualBasic.dll
|
||||
lib/cscc/lib/8.0.50727.42/Microsoft.VisualC.dll
|
||||
lib/cscc/lib/8.0.50727.42/Microsoft.Vsa.dll
|
||||
lib/cscc/lib/8.0.50727.42/ca/Microsoft.VisualBasic.resources.dll
|
||||
lib/cscc/lib/8.0.50727.42/cscompmgd.dll
|
||||
lib/cscc/lib/8.0.50727.42/de/Microsoft.VisualBasic.resources.dll
|
||||
lib/cscc/lib/8.0.50727.42/jsrun.exe
|
||||
lib/cscc/lib/Accessibility.dll
|
||||
lib/cscc/lib/DotGNU.Images.dll
|
||||
lib/cscc/lib/DotGNU.Misc.dll
|
||||
lib/cscc/lib/DotGNU.SSL.dll
|
||||
lib/cscc/lib/DotGNU.Terminal.dll
|
||||
lib/cscc/lib/DotGNU.XmlRpc.dll
|
||||
lib/cscc/lib/I18N.CJK.dll
|
||||
lib/cscc/lib/I18N.MidEast.dll
|
||||
lib/cscc/lib/I18N.Other.dll
|
||||
lib/cscc/lib/I18N.Rare.dll
|
||||
lib/cscc/lib/I18N.West.dll
|
||||
lib/cscc/lib/I18N.dll
|
||||
lib/cscc/lib/ICSharpCode.SharpZipLib.dll
|
||||
lib/cscc/lib/ISymWrapper.dll
|
||||
lib/cscc/lib/Microsoft.JScript.dll
|
||||
lib/cscc/lib/Microsoft.VisualBasic.dll
|
||||
lib/cscc/lib/Microsoft.VisualC.dll
|
||||
lib/cscc/lib/Microsoft.Vsa.dll
|
||||
lib/cscc/lib/OpenSystem.C.dll
|
||||
lib/cscc/lib/OpenSystem.Platform.dll
|
||||
lib/cscc/lib/System.Configuration.Install.dll
|
||||
lib/cscc/lib/System.Deployment.dll
|
||||
lib/cscc/lib/System.Design.dll
|
||||
lib/cscc/lib/System.Drawing.Postscript.dll
|
||||
lib/cscc/lib/System.Drawing.Win32.dll
|
||||
lib/cscc/lib/System.Drawing.Xsharp.dll
|
||||
lib/cscc/lib/System.Drawing.dll
|
||||
lib/cscc/lib/System.EnterpriseServices.dll
|
||||
lib/cscc/lib/System.Net.IrDA.dll
|
||||
lib/cscc/lib/System.Windows.Forms.Themes.XP.dll
|
||||
lib/cscc/lib/System.Windows.Forms.dll
|
||||
lib/cscc/lib/System.Xml.dll
|
||||
lib/cscc/lib/System.dll
|
||||
lib/cscc/lib/Xsharp.dll
|
||||
lib/cscc/lib/ca/I18N.resources.dll
|
||||
lib/cscc/lib/ca/Microsoft.VisualBasic.resources.dll
|
||||
lib/cscc/lib/ca/System.Configuration.Install.resources.dll
|
||||
lib/cscc/lib/ca/System.Drawing.resources.dll
|
||||
lib/cscc/lib/ca/System.Net.IrDA.resources.dll
|
||||
lib/cscc/lib/ca/System.Windows.Forms.resources.dll
|
||||
lib/cscc/lib/ca/System.Xml.resources.dll
|
||||
lib/cscc/lib/ca/System.resources.dll
|
||||
lib/cscc/lib/ca/Xsharp.resources.dll
|
||||
lib/cscc/lib/ca/mscorlib.resources.dll
|
||||
lib/cscc/lib/cscompmgd.dll
|
||||
lib/cscc/lib/cstest.dll
|
||||
lib/cscc/lib/csunit.exe
|
||||
lib/cscc/lib/de/I18N.resources.dll
|
||||
lib/cscc/lib/de/Microsoft.VisualBasic.resources.dll
|
||||
lib/cscc/lib/de/System.Configuration.Install.resources.dll
|
||||
lib/cscc/lib/de/System.Drawing.resources.dll
|
||||
lib/cscc/lib/de/System.Net.IrDA.resources.dll
|
||||
lib/cscc/lib/de/System.Windows.Forms.resources.dll
|
||||
lib/cscc/lib/de/System.Xml.resources.dll
|
||||
lib/cscc/lib/de/System.resources.dll
|
||||
lib/cscc/lib/de/Xsharp.resources.dll
|
||||
lib/cscc/lib/de/mscorlib.resources.dll
|
||||
lib/cscc/lib/ilinstall.exe
|
||||
lib/cscc/lib/jsrun.exe
|
||||
lib/cscc/lib/libXsharpSupport.la
|
||||
lib/cscc/lib/mscorlib.dll
|
||||
lib/cscc/lib/pinvoke.map
|
||||
lib/cscc/lib/sysglobl.dll
|
||||
share/cscc/config/machine.default
|
|
@ -1,15 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.11 2009/03/20 19:24:51 joerg Exp $
|
||||
|
||||
BUILDLINK_TREE+= pnetlib
|
||||
|
||||
.if !defined(PNETLIB_BUILDLINK3_MK)
|
||||
PNETLIB_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.pnetlib+= pnetlib>=0.6.4
|
||||
BUILDLINK_ABI_DEPENDS.pnetlib+= pnetlib>=0.6.6nb2
|
||||
BUILDLINK_PKGSRCDIR.pnetlib?= ../../lang/pnetlib
|
||||
|
||||
.include "../../lang/pnet/buildlink3.mk"
|
||||
.endif # PNETLIB_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -pnetlib
|
|
@ -1,5 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.5 2008/02/18 16:39:43 xtraeme Exp $
|
||||
|
||||
SHA1 (pnetlib-0.8.0.tar.gz) = 294c04a9d2e88f878382397f405ad21fb3939d23
|
||||
RMD160 (pnetlib-0.8.0.tar.gz) = e438c03ac7439c962452fc235dea5e6e6e3c293f
|
||||
Size (pnetlib-0.8.0.tar.gz) = 5092807 bytes
|
Loading…
Reference in a new issue