Add patch-ah to fix build under netbsd alpha for PR 32113
Thanks riz@ for the testing machine Take maintainership
This commit is contained in:
parent
eb1d35b2f0
commit
d2fae502d0
3 changed files with 62 additions and 3 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile.common,v 1.10 2005/10/29 17:37:20 tonio Exp $
|
||||
# $NetBSD: Makefile.common,v 1.11 2005/12/07 16:25:51 tonio Exp $
|
||||
|
||||
DISTNAME= kaffe-1.1.6
|
||||
CATEGORIES= lang java
|
||||
MASTER_SITES= ftp://ftp.kaffe.org/pub/kaffe/v1.1.x-development/
|
||||
|
||||
MAINTAINER= tech-pkg@NetBSD.org
|
||||
MAINTAINER= tonio@NetBSD.org
|
||||
HOMEPAGE= http://www.kaffe.org/
|
||||
COMMENT= Virtual machine capable of running Java(tm) code
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.17 2005/11/04 21:21:02 tonio Exp $
|
||||
$NetBSD: distinfo,v 1.18 2005/12/07 16:25:51 tonio Exp $
|
||||
|
||||
SHA1 (kaffe-1.1.6.tar.gz) = 8987c3a596db89ddc793013eaf0fab5cf8730128
|
||||
RMD160 (kaffe-1.1.6.tar.gz) = 9fd1177a43923346f9a21e4c0e89015ae42c4dfa
|
||||
|
@ -10,3 +10,4 @@ SHA1 (patch-ad) = d952245f70a61459e527cd846b76dede1df226e4
|
|||
SHA1 (patch-ae) = fac9c2e3e6c711d05f9ddb9f3109c46895f2e835
|
||||
SHA1 (patch-af) = c170e9bb8c559db660ba2d6e7af716c29b981235
|
||||
SHA1 (patch-ag) = ee05e2356c118f048a6a712147b6ccff82a9478a
|
||||
SHA1 (patch-ah) = 2ff354a18becaa544dd9ba794ef02442307fe360
|
||||
|
|
58
lang/kaffe/patches/patch-ah
Normal file
58
lang/kaffe/patches/patch-ah
Normal file
|
@ -0,0 +1,58 @@
|
|||
$NetBSD: patch-ah,v 1.5 2005/12/07 16:25:51 tonio Exp $
|
||||
|
||||
--- config/alpha/netbsd1/md.h.orig 2005-07-04 00:02:55.000000000 +0200
|
||||
+++ config/alpha/netbsd1/md.h
|
||||
@@ -15,6 +15,19 @@
|
||||
#include "alpha/common.h"
|
||||
#include "alpha/threads.h"
|
||||
|
||||
+#if defined(HAVE_SIGNAL_H)
|
||||
+#include <signal.h>
|
||||
+#endif
|
||||
+#if defined(HAVE_SYS_RESOURCE_H)
|
||||
+#include <sys/resource.h>
|
||||
+#endif
|
||||
+#if defined(HAVE_SYS_SIGNAL_H)
|
||||
+#include <sys/signal.h>
|
||||
+#endif
|
||||
+#if defined(HAVE_UNISTD_H)
|
||||
+#include <unistd.h>
|
||||
+#endif
|
||||
+
|
||||
#if defined(TRANSLATOR)
|
||||
#include "jit-md.h"
|
||||
#endif
|
||||
@@ -29,4 +42,33 @@ extern void init_md(void);
|
||||
#undef SP_OFFSET
|
||||
#define SP_OFFSET 34
|
||||
|
||||
+#if defined(HAVE_SYS_UCONTEXT_H)
|
||||
+#include <sys/ucontext.h>
|
||||
+
|
||||
+/* older netbsd's could have this macro missing, so we provide it */
|
||||
+#ifndef _UC_MACHINE_SP
|
||||
+#define _UC_MACHINE_SP(uc) ((uc)->uc_mcontext.__gregs[_REG_UESP])
|
||||
+#endif
|
||||
+#ifndef _UC_MACHINE_PC
|
||||
+#define _UC_MACHINE_PC(uc) ((uc)->uc_mcontext.__gregs[_REG_EIP])
|
||||
+#endif
|
||||
+
|
||||
+#define SIGCONTEXT ucontext_t
|
||||
+
|
||||
+#define SIGNAL_ARGS(sig, sc) int sig, siginfo_t *__si, void *sc
|
||||
+#define SIGNAL_CONTEXT_POINTER(scp) SIGCONTEXT *scp
|
||||
+#define SIGNAL_PC(scp) _UC_MACHINE_PC(((SIGCONTEXT *)(scp)))
|
||||
+#define STACK_POINTER(scp) _UC_MACHINE_SP(((SIGCONTEXT *)(scp)))
|
||||
+#define GET_SIGNAL_CONTEXT_POINTER(sc) (sc)
|
||||
+
|
||||
+#else
|
||||
+
|
||||
+#define SIGNAL_ARGS(sig, sc) int sig, int __code, struct sigcontext *sc
|
||||
+#define SIGNAL_CONTEXT_POINTER(scp) struct sigcontext *scp
|
||||
+#define GET_SIGNAL_CONTEXT_POINTER(sc) (sc)
|
||||
+#define SIGNAL_PC(scp) (scp)->sc_pc
|
||||
+#define STACK_POINTER(scp) (scp)->sc_sp
|
||||
+
|
||||
+#endif
|
||||
+
|
||||
#endif
|
Loading…
Reference in a new issue