Update tcptrace to 6.4.2.

summary of changes since 5.2.1 (there are a few, since this pkg is
~4 years old):

5.2.2 - Mon Sep 27, 1999
  bug fix from Jamshid Majdavi (and Kevin Lahey), SYN-ACKs containing window
    scaling were getting scaled (and shouldn't be).
5.2.3 - Interal changes and enhancements
5.2.4 - Tue Apr 11, 2000
  bug fix by Priya - we were detecting rexmitted bytes in segments in error in
   some cases
  fixed bug in IPv6 header processing reported by Takayoshi Ohnishi,
    IPPROTO_ICMPV6 was causing infinite loop
5.2.6 - Thu Jul  6, 2000
  fixed bug in TCP checksum code, it was always saying CORRECT
6.0.0a - preparing for alpha release of version 6
6.0.1a - added support for atmsnoop output format in snoop.c
6.0.1a2 - changed all of the DLT_ constants in tcpdump.[ch] to PCAP_DLT_
   with the same numbers to avoid OSs that are renumbering them.
6.0.1a3 - added format characters to several options, as an extension of a
   suggestion by Brian Utterback.
6.0.0b4- Saturday, 6 Oct 2001
Added options :
	--xplot_all_files and --xplot_args.

Added support for zero window probe packets and urgent data packets.

Fixed all sprintf's in the code to snprintf's to thwart any
buffer overflow attacks.

Changed functionality for window scaled connections so that
the output of "min win adv" does not print the minimum window
as advertised in SYN packets as SYN packets cannot be scaled
themselves.

Completely revamped the http module with code sent by Bruce Mah.

Added code to verify TCP and UDP checksums in IPv6 packets.
However, code has not been tested thoroughly yet.

6.0.1 - Mon Dec  3, 2001

This is the version we'll release

Also, added support with --print_seq_zero for printing sequence numbers
  as relative to the SYN rather than absolute.  NOTE: this only works for
  "-P" which uses connection records, but NOT for "-p" (which doesn't)
  Also fixed the SACK-printing code to print in decimal if requested.

Updated the manual page and made the necessary change to Makefile.in so
that the manual page gets installed when tcptrace is installed.

Fixed a bug with with the statistics for average window advertisement.
Average was showing more than max.

Fixed a bug with ACK sequence comparisons in the HTTP module. Many thanks to
Daikichi Osuga for pointing out the error.

Fixed a divide-by-zero error in PlotHist() in mod_rttgraph.c.

Matt Muggeridge has been very kind in providing detailed information regarding
porting tcptrace to OpenVMS. Please read the new file README.OpenVMS if you
are interested in running tcptrace on OpenVMS.

Changes made to code in order to be able to compile tcptrace under cygwin on
Windows. Now works on windows too. Does not support reading compressed dump
files directly though.

The ns code was modified by Angelos Stavrou to read in the more detailed
output from the extra headers in the ns FullTcp.

Fixed a bug with the host letters. The function HostLetter was skipping host
names after y, z ... jumping to ba, bb, ... instead of aa, ab ...

6.2.0 - Stable - Fri Jul 26, 2002
This is the version we'll release

6.2.1 - Fri Aug 09, 2002
enhance fulltcp file reading from r.schramp@kpn.com

6.2.2 - Fri Aug 30, 2002
added vlan support to snoop for Tysko.  Need to add support in other
formats too, but I don't have a packet dump to test against yet - sdo

6.2.3 - Wed Sep 18, 2002
bugfix: For FIN segments with data only FIN was getting plotted and not the
	data. Now data gets plotted with the default color and then one byte
	is plotted with the synfin color. For no data, only one byte of FIN
	is plotted with the synfin color.

6.2.4 - Wed Sep 18, 2002
bugfix: RST_IN relative offset was being calculated using the incorrect
        sequence space.

6.2.5 - Mon Nov 11, 2002
bugfix: Negative sequence numbers were being printed by function
	PrintSeqRep() for the packet print '-p' / '-P' switches. Changed the
	print format from %d to %u.

6.2.6 - Thu Nov 14, 2002
bugfix: '-c' option - ignore non-complete connections was working only for
	long output. Fixed it to work for brief output too.

Release 6.4.0
=============
Bugfix made to fix misbehavior due to FILE synchronization issues
found when tcptrace exits with "PCAP error - truncated file" when asked to
read real-time network packets from STDIN - Mani.

Patches added to process dumpfiles with 802.11 wireless headers for the
Prism2 chipset. Courtesy - Brandon Eisenmann.

Added new extended option "--nonreal_live_conn_interval" option to let the
user set the duration to timeout live connections, in non real-time mode
- Ramani.

Merged from development tree:

Added the options --oUDP, --iUDP, --oTCP, --iTCP to filter out TCP
and UDP connections - Mani

Added options --csv, --tsv, --sv=<SP> for comma/tab/<SP>-separated values to be
printed with the long output - Avinash

6.4.1 : 26 APR 2003 Mani
-----
Fixed a bug in the processing of IPv6 extension headers in ipv6.c:findheader()

6.4.2 :  3 MAY 2003 Jitesh
-----
Fixed the processing of duplicate ACKs as in the BSD stack to count towards
the 3 dupacks required for fast-retransmit.
This commit is contained in:
grant 2003-08-20 08:28:56 +00:00
parent d8aaedd0d9
commit d300a02ff0
6 changed files with 69 additions and 65 deletions

View file

@ -1,22 +1,27 @@
# $NetBSD: Makefile,v 1.17 2003/07/17 22:51:55 grant Exp $
# $NetBSD: Makefile,v 1.18 2003/08/20 08:28:56 grant Exp $
# FreeBSD Id: Makefile,v 1.3 1997/07/19 19:43:36 fenner Exp
#
DISTNAME= tcptrace.5.2.1
PKGNAME= tcptrace-5.2.1
WRKSRC= ${WRKDIR}/tcptrace_5.2.1
DISTNAME= tcptrace-6.4.2
CATEGORIES= net
MASTER_SITES= http://jarok.cs.ohiou.edu/software/tcptrace/files/5.2.1/
MASTER_SITES= http://www.tcptrace.org/download/
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://jarok.cs.ohiou.edu/software/tcptrace/tcptrace.html
HOMEPAGE= http://www.tcptrace.org/
COMMENT= TCP dump file analysis tool
GNU_CONFIGURE= yes
USE_BUILDLINK2= yes
ALL_TARGET= tcptrace
DOCFILES= COPYRIGHT README README.tput_graphs
DOCFILES= COPYRIGHT FAQ README README.tput_graphs
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "SunOS"
LDFLAGS+= -lnsl -lsocket -lm
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcptrace ${PREFIX}/bin
@ -26,4 +31,6 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/tcptrace
.endfor
.include "../../archivers/bzip2/buildlink2.mk"
.include "../../net/libpcap/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,8 @@
@comment $NetBSD: PLIST,v 1.1 2001/10/31 22:59:29 zuntum Exp $
@comment $NetBSD: PLIST,v 1.2 2003/08/20 08:28:56 grant Exp $
bin/tcptrace
man/man1/tcptrace.1
share/doc/tcptrace/COPYRIGHT
share/doc/tcptrace/FAQ
share/doc/tcptrace/README
share/doc/tcptrace/README.tput_graphs
@dirrm share/doc/tcptrace

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.3 2003/01/12 21:07:44 tron Exp $
$NetBSD: distinfo,v 1.4 2003/08/20 08:28:56 grant Exp $
SHA1 (tcptrace.5.2.1.tar.gz) = 838f81a2f5537631c16af6ca49b69863f43d2bd3
Size (tcptrace.5.2.1.tar.gz) = 1178005 bytes
SHA1 (patch-aa) = b338e2dada6cb3b1fee66d8d28b909cc5e6858fc
SHA1 (patch-ab) = 39483cb6be4bde804f62c5b437aaafa29af05fca
SHA1 (patch-ac) = 5caa809ef1accda51ee1d5275f18181fc9beba1e
SHA1 (tcptrace-6.4.2.tar.gz) = eb20557b9fe8ab6ec9e748e0bc72be057b835543
Size (tcptrace-6.4.2.tar.gz) = 3384329 bytes
SHA1 (patch-aa) = 80b211dadb9ea9ebebf854e544d3694412baeac6

View file

@ -1,12 +1,50 @@
$NetBSD: patch-aa,v 1.6 1999/09/15 15:43:13 drochner Exp $
--- Makefile.in.orig Wed Sep 8 03:31:58 1999
+++ Makefile.in Wed Sep 15 16:40:36 1999
@@ -179,7 +179,7 @@
# easily.
$NetBSD: patch-aa,v 1.7 2003/08/20 08:28:57 grant Exp $
--- Makefile.in.orig 2003-04-04 09:38:48.000000000 +1000
+++ Makefile.in
@@ -1,4 +1,4 @@
-#
+#
# Makefile for tcptrace
#
filt_parser.c: filt_parser.y filter.h
- bison -vd -p filtyy filt_parser.y -o filt_parser.c
+ yacc -vd -p filtyy -o filt_parser.c filt_parser.y
cp filt_parser.c flex_bison
cp filt_parser.h flex_bison
filt_scanner.c: filt_scanner.l filter.h filt_parser.h
srcdir = @srcdir@
@@ -34,8 +34,8 @@ DEFINES += -DBUNZIP2="\"bunzip2\""
#
##################################################################
PCAP_LDLIBS = @V_PCAP_LDLIBS@
-PCAP_INCS = -I/usr/local/include -I. -I../pcap -I/usr/include/pcap
-PCAP_LDFLAGS = -L/usr/local/lib -Llib -Lpcap -L../pcap -L./cygwin-libs
+PCAP_INCS = -I.
+PCAP_LDFLAGS = -Llib -L./cygwin-libs
@@ -118,8 +118,8 @@ DEFINES += -DGROK_NETSCOUT
#
##################################################################
# Pathname of directory to install the binary
-BINDIR = /usr/local/bin
-MANDIR = /usr/local/man/
+BINDIR = ${PREFIX}/bin
+MANDIR = ${PREFIX}/man
##################################################################
@@ -140,7 +140,7 @@ INCLS = -I. @V_INCLS@ ${PCAP_INCS}
# Probably want full optimization
# FreeBSD needs -Ae
# HP needs -Ae
-CFLAGS = $(CCOPT) $(DEFINES) @DEFS@ @V_DEFINES@ $(INCLS)
+CFLAGS += $(CCOPT) $(DEFINES) @DEFS@ @V_DEFINES@ $(INCLS)
# Standard LIBS
LDLIBS = @LIBS@ ${PCAP_LDLIBS}
@@ -185,7 +185,7 @@ tcptrace: ${OFILES}
# your machine, just hack in a quick string below in place of the command.
version.o: ${CFILES} Makefile
${CC} ${CFLAGS} -o version.o -c $(srcdir)/version.c \
- -DBUILT_USER="\"`whoami`\"" -DBUILT_HOST="\"`hostname`\"" -DBUILT_DATE="\"`date`\""
+ -DBUILT_USER="\"${USER}\"" -DBUILT_HOST="\"${HOST}\"" -DBUILT_DATE="\"`date`\""
#
# special rules for scanner/parser

View file

@ -1,16 +0,0 @@
$NetBSD: patch-ab,v 1.3 2003/01/12 21:07:45 tron Exp $
--- tcptrace.h.orig Thu Aug 12 19:33:10 1999
+++ tcptrace.h Sun Jan 12 22:03:30 2003
@@ -484,10 +484,7 @@
/* external routine decls */
-double sqrt(double x);
-char *ether_ntoa(struct ether_addr *e);
-void free(void *);
-int finite(double);
+char *my_ether_ntoa(struct ether_addr *e);
/* global routine decls */

View file

@ -1,24 +0,0 @@
$NetBSD: patch-ac,v 1.3 2003/01/12 21:07:45 tron Exp $
--- print.c.orig Wed Sep 8 00:40:15 1999
+++ print.c Sun Jan 12 22:05:19 2003
@@ -110,8 +110,8 @@
printeth_packet(
struct ether_header *pep)
{
- printf("\tETH Srce: %s\n", ether_ntoa((struct ether_addr *)&pep->ether_shost));
- printf("\tETH Dest: %s\n", ether_ntoa((struct ether_addr *)&pep->ether_dhost));
+ printf("\tETH Srce: %s\n", my_ether_ntoa((struct ether_addr *)&pep->ether_shost));
+ printf("\tETH Dest: %s\n", my_ether_ntoa((struct ether_addr *)&pep->ether_dhost));
printf(
hex?"\t Type: 0x%x %s\n":"\t Type: %d %s\n",
@@ -708,7 +708,7 @@
/* and it messes up my cross-platform testing. I'll just do it the */
/* "one true" way! :-) */
char *
-ether_ntoa (struct ether_addr *e)
+my_ether_ntoa (struct ether_addr *e)
{
unsigned char *pe;
static char buf[30];