Don't define true and false.

This commit is contained in:
joerg 2011-12-05 22:54:57 +00:00
parent bede422705
commit d31f4bc559
2 changed files with 17 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.16 2009/05/12 13:58:44 obache Exp $
$NetBSD: distinfo,v 1.17 2011/12/05 22:54:57 joerg Exp $
SHA1 (xorp-1.6.tar.gz) = 366d32068ed76b8ec69958b601d4fbde61ef4cbb
RMD160 (xorp-1.6.tar.gz) = 32b3f6d03defc816ed983088e61b5e808de17f98
@ -6,3 +6,4 @@ Size (xorp-1.6.tar.gz) = 7895108 bytes
SHA1 (patch-aa) = 0c4bceca2560e963885069eaa7e868676c856694
SHA1 (patch-ab) = 248719bb3ffc5fa92a2fd6a5cc63c0f77ba8d5b6
SHA1 (patch-ac) = 87710604d945b8a58cdabeb08dbd5c484f2ad3ba
SHA1 (patch-libxorp_xorp.h) = 33e2aaaec3aeaefc0d6738985b085a3270ba8bec

View file

@ -0,0 +1,15 @@
$NetBSD: patch-libxorp_xorp.h,v 1.1 2011/12/05 22:54:57 joerg Exp $
--- libxorp/xorp.h.orig 2011-12-05 19:51:40.000000000 +0000
+++ libxorp/xorp.h
@@ -173,9 +173,7 @@ using namespace std::rel_ops;
#define FALSE (0)
#define TRUE (!FALSE)
#endif /* TRUE, FALSE */
-#ifndef __cplusplus
-typedef enum { true = TRUE, false = FALSE } bool;
-#endif
+#include <stdbool.h>
typedef bool bool_t;
/*