Updated package to latest version, 1.6.2. Changes include:
Uninstalling findlib no longer uninstalls the ocamlbuild library by accident (Gabriel Scherer, Edwin Török) Adding an "ocamldoc" library, providing the cmi's for ocamldoc plugins (suggested by Armaël Guéneau) Support for OCaml-4.03: recognize that the new -color option has an argument (reported by Guillaume Bury)
This commit is contained in:
parent
b573e63af4
commit
d321f2d0f8
4 changed files with 14 additions and 14 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.27 2016/04/30 20:16:11 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.28 2016/05/05 09:42:19 jaapb Exp $
|
||||
|
||||
DISTNAME= findlib-1.6.1
|
||||
DISTNAME= findlib-1.6.2
|
||||
PKGNAME= ocaml-${DISTNAME}
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://download.camlcity.org/download/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.9 2016/02/02 11:41:45 jaapb Exp $
|
||||
@comment $NetBSD: PLIST,v 1.10 2016/05/05 09:42:19 jaapb Exp $
|
||||
bin/ocamlfind
|
||||
${OCAML_SITELIB}/bigarray/META
|
||||
${OCAML_SITELIB}/bytes/META
|
||||
|
@ -27,12 +27,12 @@ ${OCAML_SITELIB}/findlib/fl_package_base.mli
|
|||
${OCAML_SITELIB}/findlib/topfind.cmi
|
||||
${OCAML_SITELIB}/findlib/topfind.mli
|
||||
${OCAML_SITELIB}/graphics/META
|
||||
${OCAML_SITELIB}/ocamldoc/META
|
||||
${OCAML_SITELIB}/num-top/META
|
||||
${OCAML_SITELIB}/num-top/num_top.cma
|
||||
${OCAML_SITELIB}/num-top/num_top.cmi
|
||||
${OCAML_SITELIB}/num-top/num_top_printers.cmi
|
||||
${OCAML_SITELIB}/num/META
|
||||
${OCAML_SITELIB}/ocamlbuild/META
|
||||
${OCAML_SITELIB}/stdlib/META
|
||||
${OCAML_SITELIB}/str/META
|
||||
${OCAML_SITELIB}/threads/META
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.13 2016/02/02 11:41:45 jaapb Exp $
|
||||
$NetBSD: distinfo,v 1.14 2016/05/05 09:42:19 jaapb Exp $
|
||||
|
||||
SHA1 (findlib-1.6.1.tar.gz) = ca84a83c4e64e1d2823386c3880cc11b00c99c39
|
||||
RMD160 (findlib-1.6.1.tar.gz) = aeec03730ef05c161e9ce7d06283ab56aecb1358
|
||||
SHA512 (findlib-1.6.1.tar.gz) = b781d117ff033e8b91b6610c562382c5868a25ceed51f0a5947a77bfdd5825723ad32adcbe1636d4f7952d4c7535093f5c8ad3b954bebb1dcf4738f7a16d3ef8
|
||||
Size (findlib-1.6.1.tar.gz) = 254797 bytes
|
||||
SHA1 (patch-Makefile) = 823c52a1b581c36f1d097289bf15750ae9e41199
|
||||
SHA1 (findlib-1.6.2.tar.gz) = 25da312f0a0013fe04ebe0577594e8bc9e7f5d64
|
||||
RMD160 (findlib-1.6.2.tar.gz) = b6d448a5266254b3bfeceb8ca445e454291007fb
|
||||
SHA512 (findlib-1.6.2.tar.gz) = 8c4098e6956530bc88d20a1b91512c68368e8a866398ce4d504afe3f71e81124c01644ba31ff97da6e61e7410328b533fb1d31a513166231047dab1933179fc4
|
||||
Size (findlib-1.6.2.tar.gz) = 253764 bytes
|
||||
SHA1 (patch-Makefile) = c1688615027f5f0f67a738c15ddd44a31a77ffdf
|
||||
SHA1 (patch-configure) = 023cc1610ab082cf3cdb82efda00df0f4b25d881
|
||||
SHA1 (patch-src_findlib_Makefile) = 0fc2570c4d2cb271bbd8a872d8331b3d3edcbc7c
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-Makefile,v 1.3 2016/02/02 11:41:46 jaapb Exp $
|
||||
$NetBSD: patch-Makefile,v 1.4 2016/05/05 09:42:19 jaapb Exp $
|
||||
|
||||
make package support DESTDIR; use BSD_INSTALL_* instead of mkdir and cp
|
||||
--- Makefile.orig 2015-12-07 14:35:24.000000000 +0000
|
||||
--- Makefile.orig 2016-03-07 13:46:34.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -17,14 +17,14 @@ opt:
|
||||
for p in $(PARTS); do ( cd src/$$p; $(MAKE) opt ) || exit; done
|
||||
|
@ -38,8 +38,8 @@ make package support DESTDIR; use BSD_INSTALL_* instead of mkdir and cp
|
|||
|
||||
.PHONY: install-meta
|
||||
install-meta:
|
||||
- for x in `ls site-lib-src`; do if [ "$$x" != "CVS" -a -f "site-lib-src/$$x/META" ]; then mkdir -p "$(prefix)$(OCAML_SITELIB)/$$x"; cp site-lib-src/$$x/META "$(prefix)$(OCAML_SITELIB)/$$x"; fi; done
|
||||
+ for x in `ls site-lib-src`; do if [ "$$x" != "CVS" -a -f "site-lib-src/$$x/META" ]; then $(BSD_INSTALL_DATA_DIR) "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/$$x"; $(BSD_INSTALL_DATA) site-lib-src/$$x/META "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/$$x"; fi; done
|
||||
- for x in `ls site-lib-src`; do if [ -f "site-lib-src/$$x/META" ]; then mkdir -p "$(prefix)$(OCAML_SITELIB)/$$x"; cp site-lib-src/$$x/META "$(prefix)$(OCAML_SITELIB)/$$x"; fi; done
|
||||
+ for x in `ls site-lib-src`; do if [ -f "site-lib-src/$$x/META" ]; then $(BSD_INSTALL_DATA_DIR) "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/$$x"; $(BSD_INSTALL_DATA) site-lib-src/$$x/META "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/$$x"; fi; done
|
||||
|
||||
.PHONY: uninstall-meta
|
||||
uninstall-meta:
|
||||
|
|
Loading…
Reference in a new issue