remove patch-aa for DragonFly.
Upstream take care it whth different way in 4.2 and this patch broke it.
This commit is contained in:
parent
dbead09574
commit
d35ec52fd1
2 changed files with 1 additions and 34 deletions
|
@ -1,9 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.23 2011/03/12 15:26:45 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.24 2011/03/22 04:45:31 obache Exp $
|
||||
|
||||
SHA1 (bash-4.2.tar.gz) = 487840ab7134eb7901fbb2e49b0ee3d22de15cb8
|
||||
RMD160 (bash-4.2.tar.gz) = df7ae51783f039a1234d3b720ffcf4bfa5d09673
|
||||
Size (bash-4.2.tar.gz) = 7009201 bytes
|
||||
SHA1 (patch-aa) = 907a2429a94591a354130b9e6fb3ded73897362f
|
||||
SHA1 (patch-af) = dfd1d1be3d822cfc3ae0fd21bb2bbd3e35b11f0d
|
||||
SHA1 (patch-ag) = 4da0a43f6b890482affff46b18eef4be67770e48
|
||||
SHA1 (patch-ai) = 26825922898567841bed0bf62a8dee3bcc50cd75
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.6 2011/03/12 15:26:45 wiz Exp $
|
||||
|
||||
--- lib/sh/fpurge.c.orig 2010-12-22 14:32:58.000000000 +0000
|
||||
+++ lib/sh/fpurge.c
|
||||
@@ -137,7 +137,7 @@ fpurge (FILE *fp)
|
||||
extern int fpurge (FILE *);
|
||||
# endif
|
||||
int result = fpurge (fp);
|
||||
-# if defined __sferror || defined __DragonFly__ /* FreeBSD, NetBSD, OpenBSD, DragonFly, MacOS X, Cygwin */
|
||||
+# if defined __sferror /* FreeBSD, NetBSD, OpenBSD, DragonFly, MacOS X, Cygwin */
|
||||
if (result == 0)
|
||||
/* Correct the invariants that fpurge broke.
|
||||
<stdio.h> on BSD systems says:
|
||||
@@ -147,6 +147,9 @@ fpurge (FILE *fp)
|
||||
into the buffer, although they shouldn't be allowed to. */
|
||||
if ((fp_->_flags & __SRD) != 0)
|
||||
fp_->_w = 0;
|
||||
+#elif defined __DragonFly__
|
||||
+ if ((((struct __FILE_public *) fp_)->_flags & __SRD) != 0)
|
||||
+ ((struct __FILE_public *) fp_)->_w = 0;
|
||||
# endif
|
||||
return result;
|
||||
|
||||
@@ -165,7 +168,7 @@ fpurge (FILE *fp)
|
||||
fp->_IO_save_base = NULL;
|
||||
}
|
||||
return 0;
|
||||
-# elif defined __sferror || defined __DragonFly__ /* FreeBSD, NetBSD, OpenBSD, DragonFly, MacOS X, Cygwin */
|
||||
+# elif defined __sferror /* FreeBSD, NetBSD, OpenBSD, MacOS X, Cygwin */
|
||||
fp_->_p = fp_->_bf._base;
|
||||
fp_->_r = 0;
|
||||
fp_->_w = ((fp_->_flags & (__SLBF | __SNBF | __SRD)) == 0 /* fully buffered and not currently reading? */
|
Loading…
Reference in a new issue