Update to v1.5.3.6, a maintenance release. Remove patch-ac (handled
properly upstream). Fixes since v1.5.3.5 ==================== * git-cvsexportcommit handles root commits better. * git-svn dcommit used to clobber when sending a series of patches. * git-svn dcommit failed after attempting to rebase when started with a dirty index; now it stops upfront. * git-grep sometimes refused to work when your index was unmerged. * "git-grep -A1 -B2" acted as if it was told to run "git -A1 -B21". * git-hash-object did not honor configuration variables, such as core.compression. * git-index-pack choked on a huge pack on 32-bit machines, even when large file offsets are supported. * atom feeds from git-web said "10" for the month of November. * a memory leak in commit walker was plugged. * When git-send-email inserted the original author's From: address in body, it did not mark the message with Content-type: as needed. * git-revert and git-cherry-pick incorrectly refused to start when the work tree was dirty. * git-clean did not honor core.excludesfile configuration. * git-add mishandled ".gitignore" files when applying them to subdirectories. * While importing a too branchy history, git-fastimport did not honor delta depth limit properly. * Support for zlib implementations that lack ZLIB_VERNUM and definition of deflateBound() has been added. * Quite a lot of documentation clarifications.
This commit is contained in:
parent
75f37170e2
commit
d36bb853aa
3 changed files with 6 additions and 20 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.19 2007/11/05 06:34:55 bjs Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2007/11/19 06:31:55 bjs Exp $
|
||||
#
|
||||
|
||||
DISTNAME= git-1.5.3.5
|
||||
DISTNAME= git-1.5.3.6
|
||||
PKGNAME= scm${DISTNAME}
|
||||
CATEGORIES= devel scm
|
||||
MASTER_SITES= http://www.kernel.org/pub/software/scm/git/
|
||||
|
|
|
@ -1,11 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.16 2007/11/05 06:34:56 bjs Exp $
|
||||
$NetBSD: distinfo,v 1.17 2007/11/19 06:31:55 bjs Exp $
|
||||
|
||||
SHA1 (git-1.5.3.5.tar.gz) = 90afa7d2fd32cc8f97e64b0ae4b739a76a5b4a1e
|
||||
RMD160 (git-1.5.3.5.tar.gz) = f7cd639dc03bf048b053e9c1c1d290e464a5ed1c
|
||||
Size (git-1.5.3.5.tar.gz) = 1602348 bytes
|
||||
SHA1 (git-1.5.3.6.tar.gz) = 12b4fdd37404a4462fe7849156ac075773a72b28
|
||||
RMD160 (git-1.5.3.6.tar.gz) = 1f7960ba2c2bf3c134566c03ac2c2a9259bb5cbf
|
||||
Size (git-1.5.3.6.tar.gz) = 1607263 bytes
|
||||
SHA1 (patch-aa) = dd2075bb0bd330d286e792564f28691cba3120ca
|
||||
SHA1 (patch-ab) = ac5f9e2723ec3470d47c20e98be2375a4750d45f
|
||||
SHA1 (patch-ac) = c2571c4397282b0d06061af62698b3e224ed70d8
|
||||
SHA1 (patch-ae) = 44f30c796c922b028773668e80d71c0a48606f5c
|
||||
SHA1 (patch-af) = d2b6fff88913d89f37bf5453babc65027a6a5a54
|
||||
SHA1 (patch-ag) = feb17b439e0e4e89c25985f2e14e300d698c8dcf
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.2 2007/09/11 09:23:55 bjs Exp $
|
||||
|
||||
--- cache.h.orig 2007-09-02 01:57:44.000000000 -0400
|
||||
+++ cache.h
|
||||
@@ -6,7 +6,7 @@
|
||||
#include SHA1_HEADER
|
||||
#include <zlib.h>
|
||||
|
||||
-#if ZLIB_VERNUM < 0x1200
|
||||
+#if ZLIB_VERNUM < 0x1200 || !defined(deflateBound)
|
||||
#define deflateBound(c,s) ((s) + (((s) + 7) >> 3) + (((s) + 63) >> 6) + 11)
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue