Set modulename so cffi doesn't have to invent them.
Fixes PLIST issues with different compilers. Bump PKGREVISION.
This commit is contained in:
parent
63f255aeda
commit
d38544096f
4 changed files with 21 additions and 13 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.5 2014/01/25 10:30:22 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2014/03/21 14:06:01 wiz Exp $
|
||||
|
||||
DISTNAME= v0.7.2
|
||||
PROPERNAME= ${DISTNAME:S/v/xattr-/}
|
||||
PKGNAME= ${PYPKGPREFIX}-${PROPERNAME}
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= https://github.com/xattr/xattr/archive/
|
||||
|
||||
|
@ -24,14 +24,6 @@ REPLACE_PYTHON= xattr/tool.py
|
|||
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 33
|
||||
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
|
||||
.if ${PYPKGPREFIX} == "py27"
|
||||
PLIST_SUBST+= SONAME=_cffi__xf4c78acfx6ee6f75
|
||||
.elif ${PYPKGPREFIX} == "py26"
|
||||
PLIST_SUBST+= SONAME=_cffi__x9365fd4fx6ee6f75
|
||||
.endif
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2013/10/18 11:57:35 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2014/03/21 14:06:01 wiz Exp $
|
||||
bin/xattr
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
|
@ -10,10 +10,10 @@ ${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
|||
${PYSITELIB}/xattr/__init__.py
|
||||
${PYSITELIB}/xattr/__init__.pyc
|
||||
${PYSITELIB}/xattr/__init__.pyo
|
||||
${PYSITELIB}/xattr/${SONAME}.so
|
||||
${PYSITELIB}/xattr/lib.py
|
||||
${PYSITELIB}/xattr/lib.pyc
|
||||
${PYSITELIB}/xattr/lib.pyo
|
||||
${PYSITELIB}/xattr/tool.py
|
||||
${PYSITELIB}/xattr/tool.pyc
|
||||
${PYSITELIB}/xattr/tool.pyo
|
||||
${PYSITELIB}/xattr/xattr.so
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2013/09/30 17:25:51 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.2 2014/03/21 14:06:01 wiz Exp $
|
||||
|
||||
SHA1 (xattr/v0.7.2.tar.gz) = 9345898f5bc992f0c82e2552368908ee84decb52
|
||||
RMD160 (xattr/v0.7.2.tar.gz) = 950630c21d86c534fcffea093d9578a6963be18c
|
||||
Size (xattr/v0.7.2.tar.gz) = 9515 bytes
|
||||
SHA1 (patch-xattr_lib.py) = 1b83f0ab0e8820e8a76c5ad00ed1b71d95803cf6
|
||||
|
|
15
sysutils/py-xattr/patches/patch-xattr_lib.py
Normal file
15
sysutils/py-xattr/patches/patch-xattr_lib.py
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-xattr_lib.py,v 1.1 2014/03/21 14:06:01 wiz Exp $
|
||||
|
||||
Set modulename so cffi doesn't have to invent them.
|
||||
|
||||
--- xattr/lib.py.orig 2013-07-22 20:10:15.000000000 +0000
|
||||
+++ xattr/lib.py
|
||||
@@ -589,7 +589,7 @@ static ssize_t xattr_flistxattr(int fd,
|
||||
#ifndef XATTR_NOSECURITY
|
||||
#define XATTR_NOSECURITY 0x0008
|
||||
#endif
|
||||
-""", ext_package='xattr')
|
||||
+""", ext_package='xattr', modulename='xattr')
|
||||
|
||||
XATTR_NOFOLLOW = lib.XATTR_NOFOLLOW
|
||||
XATTR_CREATE = lib.XATTR_CREATE
|
Loading…
Reference in a new issue