Initial import of arla-0.33, a free AFS implementation from KTH

(Kungliga Tekniska Hoogskolan, Stockholm, Sweden)
This commit is contained in:
wennmach 2000-06-08 15:56:28 +00:00
parent 89103f939b
commit d3b0a4520b
22 changed files with 560 additions and 0 deletions

137
net/arla/Makefile Normal file
View file

@ -0,0 +1,137 @@
# $NetBSD: Makefile,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
#
DISTNAME= arla-0.33
CATEGORIES= net security
MASTER_SITES= ftp://ftp.stacken.kth.se/pub/arla/
MAINTAINER= wennmach@netbsd.org
HOMEPAGE= http://www.stacken.kth.se/project/arla/
DEPENDS+= kth-krb4-1.0.1:../../security/kth-krb4
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-krb4=${PREFIX}
.if defined(ARLA_CACHE)
CONFIGURE_ARGS+= --with-arlacachedir=${ARLA_CACHE}
.endif
PLIST_SRC= ${WRKDIR}/PLIST
MESSAGE_FILE= ${WRKDIR}/MESSAGE
.include "../../mk/bsd.prefs.mk"
.if defined(ARLA_CACHE)
CACHEDIR= ${ARLA_CACHE}
.else
CACHEDIR= ${LOCALBASE}/cache
.endif
post-patch:
# This is ugly. Utterly ugly. Sigh.
# kth-krb4 and arla both have their own, different, versions or libroken.
# To resolve this conflict, which manifests in the inability to recompile
# kth-krb4 once it is installed, we rename arla's roken to arla-roken.
@${ECHO} "===> Applying more NetBSD patches for ${DISTNAME}"
@${ECHO} -n "=> Patching configure,"
@${MV} ${WRKSRC}/configure ${WRKSRC}/configure.old
# Notice, the following sed produces some funny comments in configure :-)
@${SED} -e 's/roken/arla-roken/g' ${WRKSRC}/configure.old > ${WRKSRC}/configure
@${CHMOD} 755 ${WRKSRC}/configure
@${ECHO} -n " Makefile.in,"
@for file in `${FIND} ${WRKSRC} -name Makefile.in -print`; { \
${MV} $$file $$file.old; \
${SED} -e 's/roken/arla-roken/g' $$file.old > $$file; \
}
@${ECHO} -n " .c files,"
@for file in `${FIND} ${WRKSRC} -name "*.c" -print`; { \
${MV} $$file $$file.old; \
${SED} -e 's/roken.h/arla-roken.h/g' $$file.old > $$file; \
}
@${ECHO} -n " .h files,"
@for file in `${FIND} ${WRKSRC} -name "*.h" -print`; { \
${MV} $$file $$file.old; \
${SED} -e 's/roken.h/arla-roken.h/g' $$file.old > $$file; \
}
@${ECHO} -n " .y files,"
@for file in `${FIND} ${WRKSRC} -name "*.y" -print`; { \
${MV} $$file $$file.old; \
${SED} -e 's/roken.h/arla-roken.h/g' $$file.old > $$file; \
}
@${ECHO} -n " .l files"
@for file in `${FIND} ${WRKSRC} -name "*.l" -print`; { \
${MV} $$file $$file.old; \
${SED} -e 's/roken.h/arla-roken.h/g' $$file.old > $$file; \
}
@${ECHO} "."
@${MV} ${WRKSRC}/lib/roken/roken.h ${WRKSRC}/lib/roken/arla-roken.h
@${MV} ${WRKSRC}/lib/roken ${WRKSRC}/lib/arla-roken
do-configure:
# *Sometimes* it's bad to try to be too smart:
# pkgsrc's LDFLAGS choice is completely inadequate for arla, since
# arla's configure uses $LDFLAGS as flags for $LD, whereas
# pkgsrc's LDFLAGS are conceived to be used with $CC
# So, basically, bsd.pkg.mk sets LDFLAGS=-Wl,-R${LOCALBASE}
# while arla expects LDFLAGS=-R${LOCALBASE}
@(LDFLAGS= ; cd ${WRKSRC}; ./configure ${CONFIGURE_ARGS})
pre-install:
@${SED} -e 's|@ARLA_CACHE@|${CACHEDIR}|g' \
<${PKGDIR}/PLIST \
>${PLIST_SRC}
@${SED} -e 's|@PREFIX@|${PREFIX}|g' \
-e 's|@ARLA_CACHE@|${CACHEDIR}|g' \
<${PKGDIR}/MESSAGE \
>${MESSAGE_FILE}
post-install:
@${ECHO} " "
@if [ -e ${CACHEDIR} ]; then \
${ECHO} "Arla cache dir (${CACHEDIR}) already exists"; \
else \
${ECHO} "Creating arla cache directory ${CACHEDIR}"; \
${MKDIR} ${CACHEDIR}; \
${CHMOD} 700 ${CACHEDIR}; \
${CHOWN} root ${CACHEDIR}; \
fi
@if [ -e /sbin/mount_xfs ]; then \
${ECHO} "/sbin/mount_xfs already exists"; \
else \
${ECHO} "Creating /sbin/mount_xfs"; \
${LN} -s ${PREFIX}/bin/mount_xfs /sbin/mount_xfs; \
fi
@-${MKDIR} ${PREFIX}/share/examples/arla
@${SED} -e 's|@PREFIX@|${PREFIX}|g' \
< ${FILESDIR}/lkm.conf \
> ${PREFIX}/share/examples/arla/lkm.conf
@if ${GREP} xfs_mod /etc/lkm.conf 2>/dev/null 1>&2 ; then \
${ECHO} "Not changing /etc/lkm.conf"; \
else \
${ECHO} "Appending to /etc/lkm.conf"; \
${CAT} ${PREFIX}/share/examples/arla/lkm.conf \
>> /etc/lkm.conf; \
fi
@${INSTALL} -c -o root -g wheel -m 444 \
${FILESDIR}/services ${PREFIX}/share/examples/arla
@if ${GREP} afs3-bos /etc/services 2>/dev/null 1>&2 ; then \
${ECHO} "Not changing /etc/services"; \
else \
${ECHO} "Appending to /etc/services"; \
${CAT} ${PREFIX}/share/examples/arla/services \
>> /etc/services; \
fi
@${INSTALL} -c -o root -g wheel -m 444 \
${FILESDIR}/fstab ${PREFIX}/share/examples/arla
@if ${GREP} afs /etc/fstab 2>/dev/null 1>&2 ; then \
${ECHO} "Not changing /etc/fstab"; \
else \
${ECHO} "Appending to /etc/fstab"; \
${CAT} ${PREFIX}/share/examples/arla/fstab \
>> /etc/fstab; \
fi
@${SED} -e 's|@PREFIX@|${PREFIX}|' ${FILESDIR}/arlad.sh \
> ${PREFIX}/etc/rc.d/arlad.sh
@${ECHO} " "
.include "../../mk/bsd.pkg.mk"

6
net/arla/files/arlad.sh Normal file
View file

@ -0,0 +1,6 @@
#!/bin/sh
# $NetBSD: arlad.sh,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
if [ -f @PREFIX@/sbin/arlad ]; then
echo -n " arlad"
@PREFIX@/sbin/arlad -z /dev/xfs0
fi

2
net/arla/files/fstab Normal file
View file

@ -0,0 +1,2 @@
# $NetBSD: fstab,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
/dev/xfs0 /afs xfs rw 0 0

2
net/arla/files/lkm.conf Normal file
View file

@ -0,0 +1,2 @@
# $NetBSD: lkm.conf,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
@PREFIX@/lkm/xfs_mod.o - xfs_mod @PREFIX@/bin/xfs_makedev /var/tmp/symbols BEFOREMOUNT

3
net/arla/files/md5 Normal file
View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
MD5 (arla-0.33.tar.gz) = 90fd5d2b1ecd13294a6721bcf37c4b8d

13
net/arla/files/patch-sum Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-sum,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
MD5 (patch-aa) = e96c11332180783528b4f549cb7884a4
MD5 (patch-ab) = 380a7bf1be1293ef21eefdd8b6ca14bf
MD5 (patch-ac) = 4e9b4470df7e95646c62d7f8fd25fed8
MD5 (patch-ad) = c0ce62d0b18c7df1889002fd12577afe
MD5 (patch-ae) = 632f0a681e1423bfc6a41707489d1f2a
MD5 (patch-af) = d191babc47ad634383f607406efadd5e
MD5 (patch-ag) = 75603787951f1d56abbbbdcca0ea92db
MD5 (patch-ah) = 5e194c76b21e9076bd6968b2fca24629
MD5 (patch-ai) = 1407e37a0d72566e22dfcf6f402ee1dd
MD5 (patch-aj) = 0f9b4da8858d60fab0ac2b3de97a3795
MD5 (patch-ak) = 35638f7dc4dd55a5541dd3832afb40fc

14
net/arla/files/services Normal file
View file

@ -0,0 +1,14 @@
# $NetBSD: services,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
#
# AFS Services
#
afs3-fileserver 7000/udp # Fileserver
afs3-callback 7001/udp # Callback server
afs3-prserver 7002/udp # Protection server
afs3-vlserver 7003/udp # Volumelocation server
afs3-kaserver 7004/udp # Kerberos authenication server
afs3-volser 7005/udp # Volume server
afs3-errors 7006/udp # Error server ?
afs3-bos 7007/udp # Basic over-see server ?
afs3-update 7008/udp # ?
afs3-rmtsys 7009/udp # ?

16
net/arla/patches/patch-aa Normal file
View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Do not add a path to the library search path (-L) to find libsl.a. This will
find kth-krb4's sl library, which is the wrong one.
--- appl/fs/Makefile.in.orig Mon May 29 19:09:12 2000
+++ appl/fs/Makefile.in Mon May 29 19:10:11 2000
@@ -55,7 +55,7 @@
-L../../rx -lrx \
-L../../lwp -llwp @PLWP_LIB_FLAGS@ \
-L../../lib/ko -lko -L../../util -lutil \
- -L../../lib/sl -lsl \
+ ../../lib/sl/libsl.a \
-L../../lib/roken \
$(READLINE_lib) \
$(RXKAD_LIBS) \

16
net/arla/patches/patch-ab Normal file
View file

@ -0,0 +1,16 @@
$NetBSD: patch-ab,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Do not add a path to the library search path (-L) to find libsl.a. This will
find kth-krb4's sl library, which is the wrong one.
--- appl/vos/Makefile.in.orig Mon May 29 19:16:56 2000
+++ appl/vos/Makefile.in Mon May 29 19:17:40 2000
@@ -55,7 +55,7 @@
-L../../rx -lrx \
-L../../lwp -llwp @PLWP_LIB_FLAGS@ \
-L../../lib/ko -lko -L../../util -lutil \
- -L../../lib/sl -lsl \
+ ../../lib/sl/libsl.a \
-L../../lib/roken \
$(READLINE_lib) \
$(RXKAD_LIBS) \

26
net/arla/patches/patch-ac Normal file
View file

@ -0,0 +1,26 @@
$NetBSD: patch-ac,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Do not install libsl.a and ss/ss.h. There is a conflict with the libsl.a from
the kth-krb4 package.
--- lib/sl/Makefile.in.orig Mon May 29 21:40:42 2000
+++ lib/sl/Makefile.in Mon May 29 21:50:14 2000
@@ -58,18 +58,8 @@
$(CC) -c $(DEFS) -I../../include -I. -I$(srcdir) $(KRB4_INC_FLAGS) $(CFLAGS) $(CPPFLAGS) $(PICFLAGS) $<
install: all
- $(MKINSTALLDIRS) $(DESTDIR)$(includedir)/ss
- $(INSTALL_DATA) $(srcdir)/ss.h $(DESTDIR)$(includedir)/ss/ss.h
- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
- $(INSTALL) -m 555 $(sl_LIB) $(DESTDIR)$(libdir)/$(sl_LIB)
- $(INSTALL) -m 555 $(sl_LIB) $(DESTDIR)$(libdir)/$(ss_LIB)
- $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
- $(INSTALL) -m 0555 $(PROGS) $(DESTDIR)$(bindir)/$(PROGS)
uninstall:
- rm -f $(DESTDIR)$(includedir)/ss/ss.h
- rm -f $(DESTDIR)$(libdir)/$(sl_LIB) $(DESTDIR)$(libdir)/$(ss_LIB)
- rm -f $(DESTDIR)$(bindir)/$(PROGS)
TAGS: $(SOURCES)
etags $(SOURCES)

18
net/arla/patches/patch-ad Normal file
View file

@ -0,0 +1,18 @@
$NetBSD: patch-ad,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Do not install libacl.a. Conflicts with libacl.a from kth-krb4.
--- lib/acl/Makefile.in.orig Mon May 29 21:52:48 2000
+++ lib/acl/Makefile.in Mon May 29 21:53:22 2000
@@ -46,11 +46,8 @@
$(CC) -c $(DEFS) $(REALCFLAGS) $(PICFLAGS) $(CPPFLAGS) $<
install: all
- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
- $(INSTALL_DATA) -m 0555 $(LIB) $(DESTDIR)$(libdir)/$(LIB)
uninstall:
- rm -f $(DESTDIR)$(libdir)/$(LIB)
TAGS: $(SOURCES)
etags $(SOURCES)

25
net/arla/patches/patch-ae Normal file
View file

@ -0,0 +1,25 @@
$NetBSD: patch-ae,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Do not install libutil.a and the header files bool.h, hash.h, heap.h, list.h,
and log.h. There is a potential conflict with other libutils.
--- util/Makefile.in.orig Tue May 30 18:49:46 2000
+++ util/Makefile.in Tue May 30 18:50:13 2000
@@ -74,17 +74,8 @@
libutil_LIB: $(libutil_OBJS)
install: all
- $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
- $(INSTALL_DATA) $(LIB) $(DESTDIR)$(libdir)/$(LIB)
- for i in $(HEADERS); do \
- $(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(includedir)/$$i; \
- done
uninstall:
- rm -f $(DESTDIR)$(libdir)/$(LIB)
- for i in $(HEADERS); do \
- rm $(DESTDIR)$(includedir)/$$i; \
- done
libutil.a: $(libutil_OBJS)
$(AR) cr $@ $(libutil_OBJS)

34
net/arla/patches/patch-af Normal file
View file

@ -0,0 +1,34 @@
$NetBSD: patch-af,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Do not attempt to install CellServDB, ThisCell, arla.conf. Only install
the default files and tell the user to customize them. This avoids PLIST
magic and assures that no customized files will be removed on pkg_delete.
--- conf/Makefile.in.orig Tue May 30 22:42:05 2000
+++ conf/Makefile.in Tue May 30 22:45:45 2000
@@ -26,24 +26,13 @@
for x in $$CONF_FILES; do \
echo $(INSTALL_DATA) $(srcdir)/$$x $(DESTDIR)$(sysconfdir)/$$x.default; \
$(INSTALL_DATA) $(srcdir)/$$x $(DESTDIR)$(sysconfdir)/$$x.default; \
- if test -f $(DESTDIR)$(sysconfdir)/$$x; then \
- echo "$@ will not overwrite $(DESTDIR)$(sysconfdir)/$$x"; \
- else \
- echo $(INSTALL_DATA) $(srcdir)/$$x $(DESTDIR)$(sysconfdir)/$$x; \
- $(INSTALL_DATA) $(srcdir)/$$x $(DESTDIR)$(sysconfdir)/$$x; \
- fi; \
done
- if test -f $(DESTDIR)$(sysconfdir)/SuidCells; then \
- echo "$@ will not overwrite $(DESTDIR)$(sysconfdir)/SuidCells"; \
- else \
- > $(DESTDIR)$(sysconfdir)/SuidCells; \
- fi
+ > $(DESTDIR)$(sysconfdir)/SuidCells.default; \
uninstall:
CONF_FILES='$(CONF_FILES)'; \
for x in $$CONF_FILES; do \
rm -f $(DESTDIR)$(sysconfdir)/$$x.default; \
- rm -f $(DESTDIR)$(sysconfdir)/$$x; \
done
clean :

34
net/arla/patches/patch-ag Normal file
View file

@ -0,0 +1,34 @@
$NetBSD: patch-ag,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Install arlad into $(sbindir), not $(bindir).
--- arlad/Makefile.in.orig Wed May 31 23:31:50 2000
+++ arlad/Makefile.in Wed May 31 23:33:34 2000
@@ -15,6 +15,7 @@
libdir = @libdir@
libexecdir = @libexecdir@
bindir = @bindir@
+sbindir = @sbindir@
sysconfdir = @sysconfdir@
transform = @program_transform_name@
ARLACACHEDIR = @ARLACACHEDIR@
@@ -139,16 +140,16 @@
$(CC) -c $(CPPFLAGS) $(DEFS) -I$(srcdir) -I. $(REALCFLAGS) $<
install: all
- $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
PROG_BIN='$(ARLA_BIN)'; for x in $$PROG_BIN; do \
f=`echo $$x | sed '$(transform)'`; \
- $(INSTALL_PROGRAM) $$x $(DESTDIR)$(bindir)/$$f; \
+ $(INSTALL_PROGRAM) $$x $(DESTDIR)$(sbindir)/$$f; \
done
uninstall:
PROG_BIN='$(ARLA_BIN)'; for x in $$PROG_BIN; do \
f=`echo $$x | sed '$(transform)'`; \
- rm -f $(DESTDIR)$(bindir)/$$f; \
+ rm -f $(DESTDIR)$(sbindir)/$$f; \
done
arlad: $(arlad_OBJS) $(LIBDEPENDS)

45
net/arla/patches/patch-ah Normal file
View file

@ -0,0 +1,45 @@
$NetBSD: patch-ah,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Install xfs_mod.o into $(lkmdir), not $(bindir).
Do not strip xfs_mod.o while installing it.
--- xfs/bsd/Makefile.in.orig Wed May 31 23:38:35 2000
+++ xfs/bsd/Makefile.in Sat Jun 3 12:33:29 2000
@@ -18,6 +18,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_LKM = ${INSTALL_PROGRAM:C/-s//}
INSTALL_DATA = @INSTALL_DATA@
MKINSTALLDIRS = @top_srcdir@/mkinstalldirs
@@ -26,6 +27,7 @@
libdir = @libdir@
libexecdir = @libexecdir@
bindir = @bindir@
+lkmdir = $(exec_prefix)/lkm
transform = @program_transform_name@
EXECSUFFIX = @EXECSUFFIX@
@@ -111,10 +113,10 @@
./bin/umount_xfs /afs
install: all
- $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ $(MKINSTALLDIRS) $(DESTDIR)$(lkmdir)
PROG_BIN='$(XFS_BIN)'; for x in $$PROG_BIN; do \
f=`echo $$x | sed '$(transform)'`; \
- $(INSTALL_PROGRAM) $$x $(DESTDIR)$(bindir)/$$f; \
+ $(INSTALL_LKM) $$x $(DESTDIR)$(lkmdir)/$$f; \
done
for i in lkm subsys modules; do \
if test -d /$$i; then \
@@ -126,7 +128,7 @@
uninstall:
PROG_BIN='$(XFS_BIN)'; for x in $$PROG_BIN; do \
f=`echo $$x | sed '$(transform)'`; \
- rm -f $(DESTDIR)$(bindir)/$$f; \
+ rm -f $(DESTDIR)$(lkmdir)/$$f; \
done
cd bin && $(MAKE) $(MFLAGS) uninstall

14
net/arla/patches/patch-ai Normal file
View file

@ -0,0 +1,14 @@
$NetBSD: patch-ai,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Use our own rx directory instead of the rx already installed.
--- lib/bufdir/Makefile.in.orig Sat Jun 3 12:54:53 2000
+++ lib/bufdir/Makefile.in Sat Jun 3 12:55:39 2000
@@ -18,6 +18,7 @@
MKINSTALLDIRS = @top_srcdir@/mkinstalldirs
INCLUDE=-I../../include -I$(srcdir) \
+ -I../../rx \
-I../../rxdef \
-I$(srcdir)/../roken \
@KRB4_INC_FLAGS@ \

15
net/arla/patches/patch-aj Normal file
View file

@ -0,0 +1,15 @@
$NetBSD: patch-aj,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Also install rxgencon.h, since rx.h includes it.
--- rx/Makefile.in.orig Sat Jun 3 12:59:05 2000
+++ rx/Makefile.in Sat Jun 3 12:59:28 2000
@@ -29,7 +29,7 @@
LIB = librx.a
include_HEADERS = rx.h rx_clock.h rx_event.h rx_globs.h rx_mach.h rx_misc.h \
rx_multi.h rx_null.h rx_pkt.h rx_queue.h rx_trace.h \
- rx_user.h
+ rx_user.h rxgencon.h
PROGS = test_rx_clock

17
net/arla/patches/patch-ak Normal file
View file

@ -0,0 +1,17 @@
$NetBSD: patch-ak,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
Do not print a cryptic message after xfs_mod has been modloaded, say it
in clear text.
--- xfs/bsd/xfs_wrap-bsd.c.orig Thu Jun 8 13:28:58 2000
+++ xfs/bsd/xfs_wrap-bsd.c Thu Jun 8 13:35:12 2000
@@ -310,8 +310,7 @@
ret = lkmdispatch(lkmtp, cmd);
if(cmd == LKM_E_LOAD) {
xfs_dev_major = _module.lkm_offset;
- printf ("xfs: cdev: %d, syscall: %d\n",
- xfs_dev_major, xfs_syscall_num);
+ printf("xfs_mod driver for arla loaded.\n");
}
return ret;
}

1
net/arla/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
Free AFS implementation from KTH

8
net/arla/pkg/DESCR Normal file
View file

@ -0,0 +1,8 @@
Arla provides a free implementation of AFS. It includes:
o A cache manager (arlad) that works both in user-level mode and with
the kernel module.
o Some simple programs (amon, fs, klog, tokens, vos, udebug, and pts).
o An experimental AFS server called milko.

18
net/arla/pkg/MESSAGE Normal file
View file

@ -0,0 +1,18 @@
===============================================================================
Arla now has been installed on your system.
The cache directory used by arla is @ARLA_CACHE@.
This directory should be on a local disk. You can change the location
of the cache directory by setting the ARLA_CACHE environment variable
(or by setting ARLA_CACHE in /etc/mk.conf) to the desired location prior
to building arla.
To complete the installation you'll have to configure arla.
Default configuration files are installed in @PREFIX@/etc.
At a minimum, to configure an arla client, copy
@PREFIX@/etc/{CellServDB,SuidCells,ThisCell,arla.conf}.default to
@PREFIX@/etc/{CellServDB,SuidCells,ThisCell,arla.conf} and customize them.
Also, start arlad from rc.local, using the script provided in
@PREFIX@/etc/rc.d/arlad.sh
===============================================================================

96
net/arla/pkg/PLIST Normal file
View file

@ -0,0 +1,96 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2000/06/08 15:56:28 wennmach Exp $
include/atypes.h
include/fs_errors.h
include/base64.h
include/getarg.h
include/parse_bytes.h
include/parse_time.h
include/parse_units.h
include/resolve.h
include/arla-roken.h
include/lock.h
include/preempt.h
include/timer.h
include/lwp_asm.h
include/rx/rx.h
include/rx/rx_clock.h
include/rx/rx_event.h
include/rx/rx_globs.h
include/rx/rx_mach.h
include/rx/rx_misc.h
include/rx/rx_multi.h
include/rx/rx_null.h
include/rx/rx_pkt.h
include/rx/rx_queue.h
include/rx/rx_trace.h
include/rx/rx_user.h
include/rx/rxkad.h
include/rx/rxgencon.h
include/vldb.h
include/cb.h
include/fs.h
include/pts.h
include/vldb.cs.h
include/vldb.ss.h
include/cb.cs.h
include/cb.ss.h
include/fs.cs.h
include/fs.ss.h
include/pts.cs.h
include/pts.ss.h
include/ubik.cs.h
include/ubik.ss.h
include/bos.cs.h
include/cellconfig.h
include/auth.h
lib/libarla-roken.a
lib/liblwp.a
lib/librx.a
lib/librxdefclient.a
lib/librxfsserver.a
lib/librxvlserver.a
lib/librxvolserver.a
lib/libptserver.a
lib/libptclient.a
lib/libbosserver.a
lib/libbosclient.a
lib/libkaclient.a
lib/libkaserver.a
lib/libko.a
lib/libbufdir.a
lib/librxkad.a
lib/libarlalib.a
lkm/xfs_mod.o
@unexec /bin/rm -f %D/lkm/xfs_mod
@dirrm lkm
bin/ydr
bin/mount_xfs
bin/umount_xfs
bin/xfs_makedev
bin/startarla
bin/klog
bin/tokens
bin/unlog
bin/up
bin/amon
bin/fs
bin/pts
bin/udebug
bin/vos
sbin/arlad
etc/CellServDB.default
etc/ThisCell.default
etc/arla.conf.default
etc/SuidCells.default
etc/rc.d/arlad.sh
share/examples/arla/lkm.conf
share/examples/arla/services
share/examples/arla/fstab
@dirrm share/examples/arla
@exec if [ ! -e @ARLA_CACHE@ ] ; then /bin/mkdir -p @ARLA_CACHE@; /bin/chmod 700 @ARLA_CACHE@; chown root @ARLA_CACHE@; fi
@exec if [ ! -e /sbin/mount_xfs ]; then /bin/ln -s %D/bin/mount_xfs /sbin/mount_xfs; fi
@exec if ! /usr/bin/grep xfs_mod /etc/lkm.conf 2>/dev/null 1>&2 ; then /bin/cat %D/share/examples/arla/lkm.conf >> /etc/lkm.conf; fi
@exec if ! /usr/bin/grep afs3-bos /etc/services 2>/dev/null 1>&2 ; then /bin/cat %D/share/examples/arla/services >> /etc/services; fi
@exec if ! /usr/bin/grep afs /etc/fstab 2>/dev/null 1>&2 ; then /bin/cat %D/share/examples/arla/fstab >> /etc/fstab; fi
@unexec /bin/rm -f /sbin/mount_xfs
@unexec /bin/rm -rf @ARLA_CACHE@