Update www/thoth to 0.2.1.
* Use lang/ruby/gem.mk instead of misc/rubygems/rubygem.mk. * Add LICENSE. * Remove default value of GEM_BUILD. * Update dependency according to gemspec. * Add CONFLICTS since it will install the same name commands both ruby18 and ruby19 based packages. Exact changes are unknown.
This commit is contained in:
parent
c83b11c4d4
commit
d3bda2320e
4 changed files with 37 additions and 51 deletions
|
@ -1,26 +1,26 @@
|
|||
# $NetBSD: Makefile,v 1.4 2008/04/21 16:33:19 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2010/09/10 13:25:11 taca Exp $
|
||||
|
||||
DISTNAME= thoth-0.1.4
|
||||
DISTNAME= thoth-0.2.1
|
||||
CATEGORIES= www
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://thothblog.org/
|
||||
COMMENT= Minimalistic blog engine
|
||||
LICENSE= modified-bsd
|
||||
|
||||
DEPENDS+= erubis>=2.5.0:../../www/erubis
|
||||
DEPENDS+= ramaze>=0.3.9.1:../../www/ramaze
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-ramaze>=2008.06:../../www/ramaze
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-erubis>=2.6.2:../../www/erubis
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-builder>=2.1.2:../../textproc/ruby-builder
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-configuration>=0.0.5:../../misc/ruby-configuration
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-cssmin>=1.0.0:../../www/ruby-cssmin
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-cssmin>=1.0.2:../../www/ruby-cssmin
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-hpricot>=0.6:../../textproc/ruby-hpricot
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-jsmin>=1.0.0:../../www/ruby-jsmin
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-json-pure>=1.1.2:../../textproc/ruby-json-pure
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-redcloth>=3.0.4:../../textproc/ruby-redcloth
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-sequel-core>=1.4.0:../../databases/ruby-sequel-core
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-sequel>=1.4.0:../../databases/ruby-sequel
|
||||
DEPENDS+= thin>=0.7.1:../../www/thin
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-json-pure>=1.1.3:../../textproc/ruby-json-pure
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-redcloth>=4.0.3:../../textproc/ruby-redcloth
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-sequel>=2.5.0:../../databases/ruby-sequel
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-thin>=0.8.2:../../www/thin
|
||||
|
||||
GEM_BUILD= gemspec
|
||||
CONFLICTS+= ruby[1-9][0-9]-thoth-*
|
||||
|
||||
.include "../../misc/rubygems/rubygem.mk"
|
||||
.include "../../lang/ruby/gem.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,12 +1,16 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2009/06/14 22:00:37 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2010/09/10 13:25:11 taca Exp $
|
||||
bin/thoth
|
||||
${GEM_HOME}/cache/thoth-${PKGVERSION}.gem
|
||||
${GEM_HOME}/cache/${GEM_NAME}.gem
|
||||
${GEM_LIBDIR}/LICENSE
|
||||
${GEM_LIBDIR}/bin/thoth
|
||||
${GEM_LIBDIR}/lib/proto/thoth.conf.sample
|
||||
${GEM_LIBDIR}/lib/thoth.rb
|
||||
${GEM_LIBDIR}/lib/thoth/config.rb
|
||||
${GEM_LIBDIR}/lib/thoth/controller/admin.rb
|
||||
${GEM_LIBDIR}/lib/thoth/controller/api/comment.rb
|
||||
${GEM_LIBDIR}/lib/thoth/controller/api/page.rb
|
||||
${GEM_LIBDIR}/lib/thoth/controller/api/post.rb
|
||||
${GEM_LIBDIR}/lib/thoth/controller/api/tag.rb
|
||||
${GEM_LIBDIR}/lib/thoth/controller/archive.rb
|
||||
${GEM_LIBDIR}/lib/thoth/controller/comment.rb
|
||||
${GEM_LIBDIR}/lib/thoth/controller/main.rb
|
||||
|
@ -16,15 +20,19 @@ ${GEM_LIBDIR}/lib/thoth/controller/page.rb
|
|||
${GEM_LIBDIR}/lib/thoth/controller/post.rb
|
||||
${GEM_LIBDIR}/lib/thoth/controller/search.rb
|
||||
${GEM_LIBDIR}/lib/thoth/controller/tag.rb
|
||||
${GEM_LIBDIR}/lib/thoth/errors.rb
|
||||
${GEM_LIBDIR}/lib/thoth/helper/admin.rb
|
||||
${GEM_LIBDIR}/lib/thoth/helper/cookie.rb
|
||||
${GEM_LIBDIR}/lib/thoth/helper/error.rb
|
||||
${GEM_LIBDIR}/lib/thoth/helper/pagination.rb
|
||||
${GEM_LIBDIR}/lib/thoth/helper/sanitize.rb
|
||||
${GEM_LIBDIR}/lib/thoth/helper/wiki.rb
|
||||
${GEM_LIBDIR}/lib/thoth/helper/ysearch.rb
|
||||
${GEM_LIBDIR}/lib/thoth/importer.rb
|
||||
${GEM_LIBDIR}/lib/thoth/importer/pants.rb
|
||||
${GEM_LIBDIR}/lib/thoth/importer/poseidon.rb
|
||||
${GEM_LIBDIR}/lib/thoth/migrate/001_create_schema.rb
|
||||
${GEM_LIBDIR}/lib/thoth/migrate/002_add_media_size.rb
|
||||
${GEM_LIBDIR}/lib/thoth/model/comment.rb
|
||||
${GEM_LIBDIR}/lib/thoth/model/media.rb
|
||||
${GEM_LIBDIR}/lib/thoth/model/page.rb
|
||||
|
@ -33,11 +41,19 @@ ${GEM_LIBDIR}/lib/thoth/model/tag.rb
|
|||
${GEM_LIBDIR}/lib/thoth/model/tags_posts_map.rb
|
||||
${GEM_LIBDIR}/lib/thoth/monkeypatch/dispatcher/file.rb
|
||||
${GEM_LIBDIR}/lib/thoth/plugin.rb
|
||||
${GEM_LIBDIR}/lib/thoth/plugin/thoth_delicious.rb
|
||||
${GEM_LIBDIR}/lib/thoth/plugin/thoth_flickr.rb
|
||||
${GEM_LIBDIR}/lib/thoth/plugin/thoth_tags.rb
|
||||
${GEM_LIBDIR}/lib/thoth/plugin/thoth_twitter.rb
|
||||
${GEM_LIBDIR}/lib/thoth/public/css/admin.css
|
||||
${GEM_LIBDIR}/lib/thoth/public/css/error.css
|
||||
${GEM_LIBDIR}/lib/thoth/public/css/thoth.css
|
||||
${GEM_LIBDIR}/lib/thoth/public/images/admin-sprite.png
|
||||
${GEM_LIBDIR}/lib/thoth/public/images/thoth-sprite.png
|
||||
${GEM_LIBDIR}/lib/thoth/public/js/admin/comments.js
|
||||
${GEM_LIBDIR}/lib/thoth/public/js/admin/name.js
|
||||
${GEM_LIBDIR}/lib/thoth/public/js/admin/tagcomplete.js
|
||||
${GEM_LIBDIR}/lib/thoth/public/js/lazyload-min.js
|
||||
${GEM_LIBDIR}/lib/thoth/public/js/thoth.js
|
||||
${GEM_LIBDIR}/lib/thoth/public/robots.txt
|
||||
${GEM_LIBDIR}/lib/thoth/version.rb
|
||||
|
@ -69,6 +85,7 @@ ${GEM_LIBDIR}/lib/thoth/view/page/form.rhtml
|
|||
${GEM_LIBDIR}/lib/thoth/view/page/index.rhtml
|
||||
${GEM_LIBDIR}/lib/thoth/view/page/list.rhtml
|
||||
${GEM_LIBDIR}/lib/thoth/view/page/new.rhtml
|
||||
${GEM_LIBDIR}/lib/thoth/view/post/comments.rhtml
|
||||
${GEM_LIBDIR}/lib/thoth/view/post/compact.rhtml
|
||||
${GEM_LIBDIR}/lib/thoth/view/post/delete.rhtml
|
||||
${GEM_LIBDIR}/lib/thoth/view/post/edit.rhtml
|
||||
|
@ -81,5 +98,6 @@ ${GEM_LIBDIR}/lib/thoth/view/search/index.rhtml
|
|||
${GEM_LIBDIR}/lib/thoth/view/sidebar.rhtml
|
||||
${GEM_LIBDIR}/lib/thoth/view/tag/index.rhtml
|
||||
${GEM_LIBDIR}/lib/thoth/view/util/pager.rhtml
|
||||
${GEM_LIBDIR}/lib/thoth/view/util/simple_pager.rhtml
|
||||
${GEM_LIBDIR}/lib/thoth/view/util/table_sortheader.rhtml
|
||||
${GEM_HOME}/specifications/thoth-${PKGVERSION}.gemspec
|
||||
${GEM_HOME}/specifications/${GEM_NAME}.gemspec
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.4 2008/04/21 16:35:05 jlam Exp $
|
||||
$NetBSD: distinfo,v 1.5 2010/09/10 13:25:11 taca Exp $
|
||||
|
||||
SHA1 (thoth-0.1.4.gem) = af5469d8b2932a133509cdd911f42767335e6755
|
||||
RMD160 (thoth-0.1.4.gem) = 94dc76bdc6ffeece6ed6c08afc073f7cc94ce264
|
||||
Size (thoth-0.1.4.gem) = 46592 bytes
|
||||
SHA1 (patch-aa) = 1b154c2f0ff7c6817211cc25b89c4dcff5f359e8
|
||||
SHA1 (thoth-0.2.1.gem) = 7d0147fac9854bb8e70b01aed076bfacb0fa8e17
|
||||
RMD160 (thoth-0.2.1.gem) = f5f2574be89cbed41d3c81cfaab8089205c1d568
|
||||
Size (thoth-0.2.1.gem) = 59392 bytes
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2008/04/21 16:33:19 jlam Exp $
|
||||
|
||||
--- ../thoth-0.1.4.gemspec.orig 2008-04-14 14:05:00.000000000 -0400
|
||||
+++ ../thoth-0.1.4.gemspec
|
||||
@@ -100,7 +100,7 @@ dependencies:
|
||||
requirements:
|
||||
- - ">="
|
||||
- !ruby/object:Gem::Version
|
||||
- version: "1.3"
|
||||
+ version: "1.4.0"
|
||||
version:
|
||||
- !ruby/object:Gem::Dependency
|
||||
name: sequel_core
|
||||
@@ -109,16 +109,7 @@ dependencies:
|
||||
requirements:
|
||||
- - ">="
|
||||
- !ruby/object:Gem::Version
|
||||
- version: "1.3"
|
||||
- version:
|
||||
-- !ruby/object:Gem::Dependency
|
||||
- name: sequel_model
|
||||
- version_requirement:
|
||||
- version_requirements: !ruby/object:Gem::Requirement
|
||||
- requirements:
|
||||
- - - ">="
|
||||
- - !ruby/object:Gem::Version
|
||||
- version: 0.5.0.2
|
||||
+ version: "1.4.0"
|
||||
version:
|
||||
- !ruby/object:Gem::Dependency
|
||||
name: thin
|
Loading…
Reference in a new issue