Fix abuse of "WRKSRC" which must not be set to a sub directory of the

source tree that actually gets built. This will various checks that
get performed to check for problems with the built (e.g. work
directory references).

As a side effect the problem with GNU patch 2.5.8 gets fixed as well.
This commit is contained in:
tron 2011-06-24 13:04:43 +00:00
parent 56343c27f3
commit d3c78a0c7d
4 changed files with 12 additions and 14 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.37 2011/06/24 09:03:32 tron Exp $
# $NetBSD: Makefile,v 1.38 2011/06/24 13:04:43 tron Exp $
DISTNAME= xvidcore-1.2.2
CATEGORIES= multimedia
@ -38,14 +38,12 @@ SUBST_SED.ld+= -e "s|-Wl,--version-script=libxvidcore.ld||"
PKG_INSTALLATION_TYPES= overwrite pkgviews
WRKSRC= ${WRKDIR}/xvidcore/build/generic
WRKSRC= ${WRKDIR}/xvidcore
CONFIGURE_DIRS= build/generic
GNU_CONFIGURE= YES
MAKE_ENV+= MKDIR=${MKDIR:Q}
post-extract:
@${LN} -s ../../src ${WRKSRC}/src
.if ${OPSYS} == "Darwin"
post-install:
${RM} -f ${DESTDIR}${PREFIX}/lib/libxvidcore.so.4

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.24 2011/06/24 09:03:32 tron Exp $
$NetBSD: distinfo,v 1.25 2011/06/24 13:04:43 tron Exp $
SHA1 (xvidcore-1.2.2.tar.bz2) = d03270c803592f7655e7aa4181de587be25ba97f
RMD160 (xvidcore-1.2.2.tar.bz2) = 5fbbc99a02d9eab7f2394220cec2c872957ff26f
Size (xvidcore-1.2.2.tar.bz2) = 643344 bytes
SHA1 (patch-aa) = 593ae63ddb5ec646d7f531b99783de64a9d6ceb3
SHA1 (patch-ab) = 870ae0eee0f1eafd87c9e5693b593642a564a3c9
SHA1 (patch-aa) = 468884a8ab9dc528d9b51cbdb498bce2e08a02db
SHA1 (patch-ab) = d97c169e6d04dba4cc26448343f19a6d8b6af281
SHA1 (patch-ac) = a04244714825effafbf0a6db9de38585413f794b

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.4 2006/10/09 12:52:35 joerg Exp $
$NetBSD: patch-aa,v 1.5 2011/06/24 13:04:43 tron Exp $
--- Makefile.orig 2005-12-30 14:45:30.000000000 +0000
+++ Makefile
--- build/generic/Makefile.orig 2005-12-30 14:45:30.000000000 +0000
+++ build/generic/Makefile
@@ -83,7 +83,7 @@ $(OBJECTS): platform.inc
$(BUILD_DIR):

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ab,v 1.6 2010/05/21 13:06:19 obache Exp $
$NetBSD: patch-ab,v 1.7 2011/06/24 13:04:43 tron Exp $
--- configure.orig 2009-05-28 17:13:31.000000000 +0000
+++ configure
--- build/generic/configure.orig 2009-05-28 17:13:31.000000000 +0000
+++ build/generic/configure
@@ -3802,7 +3802,7 @@ SHARED_EXTENSION=""
STATIC_EXTENSION=""
OBJECT_EXTENSION=""