Update xmlsec1 to 1.2.16.
* May 26 2010 Changes in XML Security Library 1.2.16 release: * New xmlsec-gcrypt library. * xmlsec-gcrypt: Added RSA with SHA1/SHA256/SHA384/SHA512/MD5/RIPEMD160, DSA with SHA1, AES/DES KW support. * xmlsec-gnutls: Added X509 support and converted the library to use xmlsec- crypt library for all crypto operations. * xmlsec-mscrypto: RSA/OAEP and AES/DES KW support. * Several minor bug fixes and code cleanups. * April 29 2010 Changes in XML Security Library 1.2.15 release: * xmlsec-mscrypto: Added HMAC with MD5, SHA1, SHA256/384/512; RSA with MD5, SHA256/384/512 support. * xmlsec-mscrypto: Converted to Unicode (the non-Unicode builds are still available as compile time option). * xmlsec-nss: Added MD5 and SHA256/384/512 support for digest, HMAC and RSA (the new minimum required version for NSS library is 3.9). * xmlsec-gnutls: Added SHA256/384/512 for digest and HMAC; MD5 and RIPEMD160 digests support (the new minimum required version for GnuTLS library is 2.8.0). * Fixed typo: "Copyrigth" should be "Copyright". * Several critical bug fixes and code cleanups. * December 5 2009 Changes in XML Security Library 1.2.14 release: * XMLSec library is switched from built-in LTDL library to the system LTDL library on Linux/Unix and native calls on Windows to fix security issue (CVE-2009-3736) in LTDL. * Fixed minor bugs (see log for complete list).
This commit is contained in:
parent
087589d065
commit
d3d7334aaa
7 changed files with 77 additions and 38 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.19 2010/01/17 12:02:45 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2010/06/06 12:36:11 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xmlsec1-1.2.13
|
||||
PKGREVISION= 2
|
||||
DISTNAME= xmlsec1-1.2.16
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.aleksey.com/xmlsec/download/
|
||||
|
||||
|
@ -12,20 +11,28 @@ COMMENT= XML signature and encryption library
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_LIBTOOL= yes
|
||||
#PKGCONFIG_OVERRIDE+= ${WRKSRC}/xmlsec-gnutls.pc.in
|
||||
#PKGCONFIG_OVERRIDE+= ${WRKSRC}/xmlsec-nss.pc.in
|
||||
|
||||
PKGCONFIG_OVERRIDE+= ${WRKSRC}/xmlsec-gcrypt.pc.in
|
||||
PKGCONFIG_OVERRIDE+= ${WRKSRC}/xmlsec-gnutls.pc.in
|
||||
PKGCONFIG_OVERRIDE+= ${WRKSRC}/xmlsec-nss.pc.in
|
||||
PKGCONFIG_OVERRIDE+= ${WRKSRC}/xmlsec-openssl.pc.in
|
||||
PKGCONFIG_OVERRIDE+= ${WRKSRC}/xmlsec.pc.in
|
||||
GNU_CONFIGURE= yes
|
||||
#CONFIGURE_ARGS+= --without-openssl
|
||||
|
||||
CONFIGURE_ARGS+= --with-openssl=${BUILDLINK_PREFIX.openssl}
|
||||
CONFIGURE_ARGS+= --without-gnutls
|
||||
CONFIGURE_ARGS+= --with-libxml=${BUILDLINK_PREFIX.libxml2}
|
||||
CONFIGURE_ARGS+= --with-libxslt=${BUILDLINK_PREFIX.libxslt}
|
||||
CONFIGURE_ARGS+= --with-gcrypt=${BUILDLINK_PREFIX.libgcrypt}
|
||||
|
||||
.include "../../devel/libltdl/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.libgcrypt+= libgcrypt>=1.4.0
|
||||
.include "../../security/libgcrypt/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
#.include "../../security/gnutls/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.libxml2+= libxml2>=2.7.4
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../textproc/libxslt/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2009/10/30 19:32:11 tnn Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2010/06/06 12:36:11 obache Exp $
|
||||
bin/xmlsec1
|
||||
bin/xmlsec1-config
|
||||
include/xmlsec1/xmlsec/app.h
|
||||
|
@ -9,6 +9,9 @@ include/xmlsec1/xmlsec/crypto.h
|
|||
include/xmlsec1/xmlsec/dl.h
|
||||
include/xmlsec1/xmlsec/errors.h
|
||||
include/xmlsec1/xmlsec/exports.h
|
||||
include/xmlsec1/xmlsec/gcrypt/app.h
|
||||
include/xmlsec1/xmlsec/gcrypt/crypto.h
|
||||
include/xmlsec1/xmlsec/gcrypt/symbols.h
|
||||
include/xmlsec1/xmlsec/io.h
|
||||
include/xmlsec1/xmlsec/keyinfo.h
|
||||
include/xmlsec1/xmlsec/keys.h
|
||||
|
@ -37,8 +40,10 @@ include/xmlsec1/xmlsec/xmldsig.h
|
|||
include/xmlsec1/xmlsec/xmlenc.h
|
||||
include/xmlsec1/xmlsec/xmlsec.h
|
||||
include/xmlsec1/xmlsec/xmltree.h
|
||||
lib/libxmlsec1-gcrypt.la
|
||||
lib/libxmlsec1-openssl.la
|
||||
lib/libxmlsec1.la
|
||||
lib/pkgconfig/xmlsec1-gcrypt.pc
|
||||
lib/pkgconfig/xmlsec1-openssl.pc
|
||||
lib/pkgconfig/xmlsec1.pc
|
||||
lib/xmlsec1Conf.sh
|
||||
|
@ -77,6 +82,10 @@ share/doc/xmlsec1/api/xmlsec-examples-sign-dynamimc-template.html
|
|||
share/doc/xmlsec1/api/xmlsec-examples-sign-template-file.html
|
||||
share/doc/xmlsec1/api/xmlsec-examples-sign-x509.html
|
||||
share/doc/xmlsec1/api/xmlsec-examples.html
|
||||
share/doc/xmlsec1/api/xmlsec-gcrypt-app.html
|
||||
share/doc/xmlsec1/api/xmlsec-gcrypt-crypto.html
|
||||
share/doc/xmlsec1/api/xmlsec-gcrypt-ref.html
|
||||
share/doc/xmlsec1/api/xmlsec-gcrypt.sgml
|
||||
share/doc/xmlsec1/api/xmlsec-gnutls-app.html
|
||||
share/doc/xmlsec1/api/xmlsec-gnutls-crypto.html
|
||||
share/doc/xmlsec1/api/xmlsec-gnutls-ref.html
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.5 2010/05/29 05:53:04 obache Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.6 2010/06/06 12:36:11 obache Exp $
|
||||
|
||||
BUILDLINK_TREE+= xmlsec1
|
||||
|
||||
|
@ -12,8 +12,10 @@ BUILDLINK_INCDIRS.xmlsec1+= include/xmlsec1
|
|||
BUILDLINK_CPPFLAGS.xmlsec1+= -DXMLSEC_CRYPTO_OPENSSL
|
||||
BUILDLINK_LIBS.xmlsec1+= -lxmlsec1-openssl
|
||||
|
||||
.include "../../devel/libltdl/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../textproc/libxslt/buildlink3.mk"
|
||||
.include "../../security/libgcrypt/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.endif # XMLSEC1_BUILDLINK3_MK
|
||||
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.6 2009/12/01 08:43:52 manu Exp $
|
||||
$NetBSD: distinfo,v 1.7 2010/06/06 12:36:11 obache Exp $
|
||||
|
||||
SHA1 (xmlsec1-1.2.13.tar.gz) = 7953be1ba966fe7ca379839631299bd6963c418f
|
||||
RMD160 (xmlsec1-1.2.13.tar.gz) = 4743dbf406cc63db60ececb3257967398a1416a6
|
||||
Size (xmlsec1-1.2.13.tar.gz) = 1576354 bytes
|
||||
SHA1 (patch-ab) = 34856f6c7d810f9bd51b871ccb870b28f05b1fd8
|
||||
SHA1 (patch-ac) = 550f37db0db36ce5fa88c6c0d0acd6725aa69470
|
||||
SHA1 (patch-ad) = 99d400098b41e1ae0d9e89efcd591ece21552f07
|
||||
SHA1 (xmlsec1-1.2.16.tar.gz) = ecd220b4498bbe212188fffd0aded92910d4bbd9
|
||||
RMD160 (xmlsec1-1.2.16.tar.gz) = 15064b3c3ec84c87b271013cb3fa165972f0e2c4
|
||||
Size (xmlsec1-1.2.16.tar.gz) = 1803092 bytes
|
||||
SHA1 (patch-ab) = 6c771503bba0d291c26db6102dd1365a561d17a2
|
||||
SHA1 (patch-ac) = 03e9d3d97ab6ab2e753516574f1be8e7eda236c4
|
||||
|
|
|
@ -1,8 +1,19 @@
|
|||
$NetBSD: patch-ab,v 1.2 2009/10/30 19:32:11 tnn Exp $
|
||||
$NetBSD: patch-ab,v 1.3 2010/06/06 12:36:11 obache Exp $
|
||||
|
||||
--- configure.orig 2009-09-12 22:09:00.000000000 +0200
|
||||
portability fix
|
||||
|
||||
--- configure.orig 2010-05-25 21:53:07.000000000 +0000
|
||||
+++ configure
|
||||
@@ -23233,7 +23233,7 @@ else
|
||||
@@ -10988,7 +10988,7 @@ CC="$lt_save_CC"
|
||||
|
||||
|
||||
|
||||
-if test "z$RM" == "z" ; then
|
||||
+if test "z$RM" = "z" ; then
|
||||
# Extract the first word of "rm", so it can be a program name with args.
|
||||
set dummy rm; ac_word=$2
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
@@ -11703,7 +11703,7 @@ else
|
||||
fi
|
||||
|
||||
|
||||
|
@ -11,12 +22,12 @@ $NetBSD: patch-ab,v 1.2 2009/10/30 19:32:11 tnn Exp $
|
|||
shrext=$shrext_cmds
|
||||
fi
|
||||
|
||||
@@ -24720,7 +24720,7 @@ fi
|
||||
@@ -12771,7 +12771,7 @@ else
|
||||
XMLSEC_CRYPTO_DISABLED_LIST="$XMLSEC_CRYPTO_DISABLED_LIST openssl"
|
||||
fi
|
||||
|
||||
|
||||
|
||||
-if test "z$XMLSEC_NO_OPENSSL" == "z1"; then
|
||||
+if test "z$XMLSEC_NO_OPENSSL" = "z1"; then
|
||||
- if test "z$XMLSEC_NO_OPENSSL" == "z1"; then
|
||||
+ if test "z$XMLSEC_NO_OPENSSL" = "z1"; then
|
||||
XMLSEC_NO_OPENSSL_TRUE=
|
||||
XMLSEC_NO_OPENSSL_FALSE='#'
|
||||
else
|
||||
|
|
|
@ -1,8 +1,28 @@
|
|||
$NetBSD: patch-ac,v 1.1 2006/10/14 02:26:39 rillig Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2010/06/06 12:36:11 obache Exp $
|
||||
|
||||
--- configure.in.orig 2004-08-26 04:49:24.000000000 +0200
|
||||
+++ configure.in 2006-10-14 04:21:57.000000000 +0200
|
||||
@@ -390,7 +390,7 @@ else
|
||||
portability fix
|
||||
|
||||
--- configure.in.orig 2010-05-25 21:52:46.000000000 +0000
|
||||
+++ configure.in
|
||||
@@ -37,7 +37,7 @@ LT_INIT
|
||||
dnl
|
||||
dnl Find programs
|
||||
dnl
|
||||
-if test "z$RM" == "z" ; then
|
||||
+if test "z$RM" = "z" ; then
|
||||
AC_PATH_PROG(RM, rm, /bin/rm)
|
||||
fi
|
||||
AC_PATH_PROG(CP, cp, /bin/cp)
|
||||
@@ -127,7 +127,7 @@ AM_CONDITIONAL(SHAREDLIB_HACK, [test "z$
|
||||
dnl ==========================================================================
|
||||
dnl Hack for autoconf version mismatch
|
||||
dnl ==========================================================================
|
||||
-if test "z$shrext" == "z" ; then
|
||||
+if test "z$shrext" = "z" ; then
|
||||
shrext=$shrext_cmds
|
||||
fi
|
||||
|
||||
@@ -505,7 +505,7 @@ else
|
||||
XMLSEC_CRYPTO_DISABLED_LIST="$XMLSEC_CRYPTO_DISABLED_LIST openssl"
|
||||
fi
|
||||
|
||||
|
|
|
@ -1,9 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2009/12/01 08:43:52 manu Exp $
|
||||
--- configure.orig 2009-11-30 22:21:32.000000000 +0100
|
||||
+++ configure 2009-11-30 22:23:40.000000000 +0100
|
||||
@@ -24212,4 +24212,5 @@
|
||||
*-*-mingw*) openssl_exlibs=;;
|
||||
*-*-osf5*) openssl_exlibs=;;
|
||||
+ *-*-netbsd*) openssl_exlibs=;;
|
||||
#FIXME: check if lib "dl" is required
|
||||
*) openssl_exlibs=-ldl;;
|
Loading…
Reference in a new issue