Imported botan from .
Botan (formerly OpenCL) aims to be a portable, easy to use, and efficient C++ crypto library. It currently supports the following algorithms: Public Key Algorithms: Diffie-Hellman, DSA, ElGamal, Nyberg-Rueppel, Rabin-Williams, RSA Block Ciphers: Blowfish, CAST256, CAST5, CS-Cipher, DES, GOST, IDEA, Lion, Luby-Rackoff, MISTY1, RC2, RC5, RC6, Rijndael, SAFER-SK128, Serpent, SHARK, Skipjack, Square, TEA, Threeway, Twofish, XTEA Stream Ciphers: ARC4, ISAAC, SEAL Hash Functions: HAVAL, MD2, MD4, MD5, RIPEMD-128, RIPEMD-160, SHA-1, SHA2-256, SHA2-512, Tiger, Whirlpool MACs: EMAC, HMAC, MD5-MAC, ANSI X9.19 MAC Misc: Adler32, CRC24, CRC32, Randpool, X9.17 RNG Cipher Modes: CBC w/ Padding, CTS, CFB, OFB, Counter Packaged by Aleksandar Simic <asimic@gmail.com>.
This commit is contained in:
parent
cfa95d218d
commit
d3ffdfe7f0
10 changed files with 308 additions and 0 deletions
14
security/botan/DESCR
Normal file
14
security/botan/DESCR
Normal file
|
@ -0,0 +1,14 @@
|
|||
Botan (formerly OpenCL) aims to be a portable, easy to use, and efficient
|
||||
C++ crypto library. It currently supports the following algorithms:
|
||||
|
||||
Public Key Algorithms: Diffie-Hellman, DSA, ElGamal, Nyberg-Rueppel,
|
||||
Rabin-Williams, RSA
|
||||
Block Ciphers: Blowfish, CAST256, CAST5, CS-Cipher, DES, GOST, IDEA,
|
||||
Lion, Luby-Rackoff, MISTY1, RC2, RC5, RC6, Rijndael, SAFER-SK128,
|
||||
Serpent, SHARK, Skipjack, Square, TEA, Threeway, Twofish, XTEA
|
||||
Stream Ciphers: ARC4, ISAAC, SEAL
|
||||
Hash Functions: HAVAL, MD2, MD4, MD5, RIPEMD-128, RIPEMD-160, SHA-1,
|
||||
SHA2-256, SHA2-512, Tiger, Whirlpool
|
||||
MACs: EMAC, HMAC, MD5-MAC, ANSI X9.19 MAC
|
||||
Misc: Adler32, CRC24, CRC32, Randpool, X9.17 RNG
|
||||
Cipher Modes: CBC w/ Padding, CTS, CFB, OFB, Counter
|
22
security/botan/Makefile
Normal file
22
security/botan/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2006/02/05 01:25:12 rillig Exp $
|
||||
|
||||
DISTNAME= Botan-1.4.11
|
||||
PKGNAME= botan-1.4.11
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://files.randombit.net/botan/
|
||||
EXTRACT_SUFX= .tbz
|
||||
|
||||
MAINTAINER= tech-pkg@NetBSD.org
|
||||
HOMEPAGE= http://botan.randombit.net/
|
||||
COMMENT= Portable, easy to use, and efficient C++ crypto library
|
||||
|
||||
USE_LANGUAGES+= c++
|
||||
REPLACE_PERL+= ./configure.pl
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_SCRIPT= ./configure.pl
|
||||
CONFIGURE_ARGS+= --prefix=${PREFIX:Q}
|
||||
|
||||
MAKE_FLAGS+= INSTALL_CMD_EXEC=${INSTALL_PROGRAM:Q}
|
||||
MAKE_FLAGS+= INSTALL_CMD_DATA=${INSTALL_DATA:Q}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
security/botan/PLIST.FreeBSD
Normal file
2
security/botan/PLIST.FreeBSD
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST.FreeBSD,v 1.1.1.1 2006/02/05 01:25:12 rillig Exp $
|
||||
include/botan/es_ftw.h
|
2
security/botan/PLIST.Linux
Normal file
2
security/botan/PLIST.Linux
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST.Linux,v 1.1.1.1 2006/02/05 01:25:12 rillig Exp $
|
||||
include/botan/es_ftw.h
|
2
security/botan/PLIST.OpenBSD
Normal file
2
security/botan/PLIST.OpenBSD
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST.OpenBSD,v 1.1.1.1 2006/02/05 01:25:12 rillig Exp $
|
||||
include/botan/es_ftw.h
|
190
security/botan/PLIST.common
Normal file
190
security/botan/PLIST.common
Normal file
|
@ -0,0 +1,190 @@
|
|||
@comment $NetBSD: PLIST.common,v 1.1.1.1 2006/02/05 01:25:12 rillig Exp $
|
||||
bin/botan-config
|
||||
include/botan/adler32.h
|
||||
include/botan/aes.h
|
||||
include/botan/algolist.h
|
||||
include/botan/allocate.h
|
||||
include/botan/arc4.h
|
||||
include/botan/asn1.h
|
||||
include/botan/asn1_obj.h
|
||||
include/botan/asn1_oid.h
|
||||
include/botan/barrett.h
|
||||
include/botan/base.h
|
||||
include/botan/base64.h
|
||||
include/botan/basefilt.h
|
||||
include/botan/ber_dec.h
|
||||
include/botan/bigint.h
|
||||
include/botan/bit_ops.h
|
||||
include/botan/blinding.h
|
||||
include/botan/blowfish.h
|
||||
include/botan/botan.h
|
||||
include/botan/botan.py
|
||||
include/botan/buf_es.h
|
||||
include/botan/buf_filt.h
|
||||
include/botan/cast128.h
|
||||
include/botan/cast256.h
|
||||
include/botan/cbc.h
|
||||
include/botan/certstor.h
|
||||
include/botan/cfb.h
|
||||
include/botan/charset.h
|
||||
include/botan/cmac.h
|
||||
include/botan/conf.h
|
||||
include/botan/config.h
|
||||
include/botan/crc24.h
|
||||
include/botan/crc32.h
|
||||
include/botan/crl_ent.h
|
||||
include/botan/ctr.h
|
||||
include/botan/cts.h
|
||||
include/botan/data_snk.h
|
||||
include/botan/data_src.h
|
||||
include/botan/def_eng.h
|
||||
include/botan/defalloc.h
|
||||
include/botan/der_enc.h
|
||||
include/botan/des.h
|
||||
include/botan/dh.h
|
||||
include/botan/dl_algo.h
|
||||
include/botan/dl_param.h
|
||||
include/botan/dlies.h
|
||||
include/botan/dsa.h
|
||||
include/botan/eax.h
|
||||
include/botan/ecb.h
|
||||
include/botan/elgamal.h
|
||||
include/botan/eme.h
|
||||
include/botan/emsa.h
|
||||
include/botan/engine.h
|
||||
include/botan/enums.h
|
||||
include/botan/es_egd.h
|
||||
include/botan/es_file.h
|
||||
include/botan/es_unix.h
|
||||
include/botan/exceptn.h
|
||||
include/botan/fd_unix.h
|
||||
include/botan/filter.h
|
||||
include/botan/filters.h
|
||||
include/botan/fips140.h
|
||||
include/botan/fork256.h
|
||||
include/botan/gost.h
|
||||
include/botan/has160.h
|
||||
include/botan/hash_id.h
|
||||
include/botan/haval.h
|
||||
include/botan/hex.h
|
||||
include/botan/hmac.h
|
||||
include/botan/idea.h
|
||||
include/botan/if_algo.h
|
||||
include/botan/init.h
|
||||
include/botan/isaac.h
|
||||
include/botan/kasumi.h
|
||||
include/botan/kdf.h
|
||||
include/botan/keypair.h
|
||||
include/botan/lion.h
|
||||
include/botan/look_add.h
|
||||
include/botan/look_pk.h
|
||||
include/botan/lookup.h
|
||||
include/botan/lubyrack.h
|
||||
include/botan/mars.h
|
||||
include/botan/md2.h
|
||||
include/botan/md4.h
|
||||
include/botan/md5.h
|
||||
include/botan/mdx_hash.h
|
||||
include/botan/mem_ops.h
|
||||
include/botan/mem_pool.h
|
||||
include/botan/mgf1.h
|
||||
include/botan/misty1.h
|
||||
include/botan/mmap_mem.h
|
||||
include/botan/mod_exp.h
|
||||
include/botan/mode_pad.h
|
||||
include/botan/modebase.h
|
||||
include/botan/mp_core.h
|
||||
include/botan/mp_madd.h
|
||||
include/botan/mp_types.h
|
||||
include/botan/mutex.h
|
||||
include/botan/mux_pthr.h
|
||||
include/botan/nr.h
|
||||
include/botan/numthry.h
|
||||
include/botan/ofb.h
|
||||
include/botan/oids.h
|
||||
include/botan/openpgp.h
|
||||
include/botan/out_buf.h
|
||||
include/botan/par_hash.h
|
||||
include/botan/parsing.h
|
||||
include/botan/pbe.h
|
||||
include/botan/pbe_pkcs.h
|
||||
include/botan/pem.h
|
||||
include/botan/pgp_s2k.h
|
||||
include/botan/pipe.h
|
||||
include/botan/pk_algs.h
|
||||
include/botan/pk_core.h
|
||||
include/botan/pk_filts.h
|
||||
include/botan/pk_keys.h
|
||||
include/botan/pk_ops.h
|
||||
include/botan/pk_util.h
|
||||
include/botan/pkcs10.h
|
||||
include/botan/pkcs5.h
|
||||
include/botan/pkcs8.h
|
||||
include/botan/pubkey.h
|
||||
include/botan/randpool.h
|
||||
include/botan/rc2.h
|
||||
include/botan/rc5.h
|
||||
include/botan/rc6.h
|
||||
include/botan/reducer.h
|
||||
include/botan/rmd128.h
|
||||
include/botan/rmd160.h
|
||||
include/botan/rng.h
|
||||
include/botan/rsa.h
|
||||
include/botan/rw.h
|
||||
include/botan/s2k.h
|
||||
include/botan/safer_sk.h
|
||||
include/botan/seal.h
|
||||
include/botan/secmem.h
|
||||
include/botan/secqueue.h
|
||||
include/botan/seed.h
|
||||
include/botan/serpent.h
|
||||
include/botan/sha160.h
|
||||
include/botan/sha256.h
|
||||
include/botan/sha_64.h
|
||||
include/botan/skipjack.h
|
||||
include/botan/square.h
|
||||
include/botan/symkey.h
|
||||
include/botan/tea.h
|
||||
include/botan/tiger.h
|
||||
include/botan/timers.h
|
||||
include/botan/tm_unix.h
|
||||
include/botan/turing.h
|
||||
include/botan/twofish.h
|
||||
include/botan/types.h
|
||||
include/botan/ui.h
|
||||
include/botan/unix_cmd.h
|
||||
include/botan/util.h
|
||||
include/botan/version.h
|
||||
include/botan/whrlpool.h
|
||||
include/botan/wid_wake.h
|
||||
include/botan/x509_ca.h
|
||||
include/botan/x509_crl.h
|
||||
include/botan/x509_key.h
|
||||
include/botan/x509_obj.h
|
||||
include/botan/x509cert.h
|
||||
include/botan/x509self.h
|
||||
include/botan/x509stor.h
|
||||
include/botan/x919_mac.h
|
||||
include/botan/x931_rng.h
|
||||
include/botan/xtea.h
|
||||
lib/libbotan-1.4.11.so
|
||||
lib/libbotan-1.4.so
|
||||
lib/libbotan-1.so
|
||||
lib/libbotan.a
|
||||
lib/libbotan.so
|
||||
share/doc/Botan-1.4.11/api.pdf
|
||||
share/doc/Botan-1.4.11/api.tex
|
||||
share/doc/Botan-1.4.11/authors.txt
|
||||
share/doc/Botan-1.4.11/botan.rc
|
||||
share/doc/Botan-1.4.11/bugs.txt
|
||||
share/doc/Botan-1.4.11/deprecated.txt
|
||||
share/doc/Botan-1.4.11/fips140.pdf
|
||||
share/doc/Botan-1.4.11/fips140.tex
|
||||
share/doc/Botan-1.4.11/license.txt
|
||||
share/doc/Botan-1.4.11/log.txt
|
||||
share/doc/Botan-1.4.11/pgpkeys.asc
|
||||
share/doc/Botan-1.4.11/readme.txt
|
||||
share/doc/Botan-1.4.11/thanks.txt
|
||||
share/doc/Botan-1.4.11/todo.txt
|
||||
share/doc/Botan-1.4.11/tutorial.pdf
|
||||
share/doc/Botan-1.4.11/tutorial.tex
|
3
security/botan/PLIST.common_end
Normal file
3
security/botan/PLIST.common_end
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST.common_end,v 1.1.1.1 2006/02/05 01:25:12 rillig Exp $
|
||||
@dirrm include/botan
|
||||
@dirrm share/doc/Botan-1.4.11
|
7
security/botan/distinfo
Normal file
7
security/botan/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2006/02/05 01:25:12 rillig Exp $
|
||||
|
||||
SHA1 (Botan-1.4.11.tbz) = 508605c1debaae78db201afb6c87fa93c25e4432
|
||||
RMD160 (Botan-1.4.11.tbz) = bafca4a73f6acbf4f1bb3f2cb35727e2ebdce3d4
|
||||
Size (Botan-1.4.11.tbz) = 1660829 bytes
|
||||
SHA1 (patch-aa) = 09a5c83960977e5f5fce08f3f1dacec9010292f8
|
||||
SHA1 (patch-ab) = 478d91bce78f484fb8ba2d23ceecb462728b29db
|
53
security/botan/patches/patch-aa
Normal file
53
security/botan/patches/patch-aa
Normal file
|
@ -0,0 +1,53 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2006/02/05 01:25:12 rillig Exp $
|
||||
|
||||
--- configure.pl.orig 2006-01-01 02:02:28.000000000 +0100
|
||||
+++ configure.pl 2006-02-05 01:59:57.000000000 +0100
|
||||
@@ -74,7 +74,6 @@ my %DOCS = (
|
||||
'deprecated.txt' => $DOC_DIR,
|
||||
'license.txt' => $DOC_DIR,
|
||||
'log.txt' => $DOC_DIR,
|
||||
- 'rngs.txt' => $DOC_DIR,
|
||||
'thanks.txt' => $DOC_DIR,
|
||||
'todo.txt' => $DOC_DIR
|
||||
);
|
||||
@@ -1696,12 +1695,6 @@ sub guess_triple
|
||||
my @CCS = ('gcc', 'icc', 'compaq', 'kai'); # Skips several, oh well...
|
||||
|
||||
# First try the CC enviornmental variable, if it's set
|
||||
- if(defined($ENV{CC}))
|
||||
- {
|
||||
- my @new_CCS = ($ENV{CC});
|
||||
- foreach my $cc (@CCS) { push @new_CCS, $cc; }
|
||||
- @CCS = @new_CCS;
|
||||
- }
|
||||
|
||||
my $cc = '';
|
||||
foreach (@CCS)
|
||||
@@ -2040,8 +2033,12 @@ sub print_unix_makefile {
|
||||
my $link_to = "-lm";
|
||||
foreach my $lib (@{ $lib_list })
|
||||
{
|
||||
+ if ($lib =~ m/pthread/) {
|
||||
+ $link_to .= " -" . $lib;
|
||||
+ } else {
|
||||
$link_to .= " -l" . $lib;
|
||||
}
|
||||
+ }
|
||||
|
||||
##################################################
|
||||
# Generate a few variables #
|
||||
@@ -2279,12 +2276,12 @@ $__TAB__\@for i in \$(HEADERS); do \\
|
||||
$__TAB__ \$(INSTALL_CMD_DATA) \$\$i \$(HEADERDIR); \\
|
||||
$__TAB__ done
|
||||
$__TAB__\@\$(INSTALL_CMD_DATA) \$(STATIC_LIB) \$(LIBDIR)
|
||||
-$__TAB__\@\$(INSTALL_CMD_EXEC) \$(CONFIG_SCRIPT) \$(BINDIR)
|
||||
+$__TAB__\@\${INSTALL_SCRIPT} \$(CONFIG_SCRIPT) \$(BINDIR)
|
||||
END_OF_INSTALL_SCRIPTS
|
||||
|
||||
if($make_shared) {
|
||||
print $makefile <<END_OF_SYMLINKS;
|
||||
-$__TAB__\@\$(INSTALL_CMD_EXEC) \$(SHARED_LIB) \$(LIBDIR)
|
||||
+$__TAB__\@\${INSTALL_LIB} \$(SHARED_LIB) \$(LIBDIR)
|
||||
$__TAB__\$(CD) \$(LIBDIR); \$(LN) \$(SYMLINK0) \$(SYMLINK1)
|
||||
$__TAB__\$(CD) \$(LIBDIR); \$(LN) \$(SYMLINK1) \$(SYMLINK2)
|
||||
$__TAB__\$(CD) \$(LIBDIR); \$(LN) \$(SYMLINK2) \$(SYMLINK3)
|
13
security/botan/patches/patch-ab
Normal file
13
security/botan/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2006/02/05 01:25:12 rillig Exp $
|
||||
|
||||
--- modules/tm_posix/tm_posix.cpp.orig 2006-01-01 01:02:28.000000000 +0000
|
||||
+++ modules/tm_posix/tm_posix.cpp 2006-02-01 17:27:07.000000000 +0000
|
||||
@@ -9,7 +9,7 @@
|
||||
|
||||
#include <botan/tm_posix.h>
|
||||
#include <botan/util.h>
|
||||
-#include <time.h>
|
||||
+#include <sys/time.h>
|
||||
|
||||
#ifndef CLOCK_REALTIME
|
||||
#define CLOCK_REALTIME 0
|
Loading…
Reference in a new issue